TVHeadend TS Playback Issue
Hi there, I have successfully implemented EricV's branch of TVHeadend (which includes the TS recording option) onto a QNAP NAS.

The purpose of implementing this branch was to overcome the "seek-while-recording" issues that stock TVHeadend has due to the MKV format. How I arrived at this approach is detailed here...

I have hit a problem with XBMC seeking through TS recordings from a specific channel. This channel (Channel One in Australia) is generally HD and has AC3 audio. It seems from the XBMC logs that playing back TS recordings from this source that the audio (AC3/Dolby) causes XBMC playback to crash. More details here...

Below are the MediaInfo, and related XBMC logs when trying to playback (and seek through) the recording. I seem to have hit the wall in terms of options, does anyone have any idea why the playback in XBMC would fail when skipping/seeking through this recording?

Here is the MEDIAINFO for the recording

XBMC log (for playing the recording back over HTSP - TVHeadend)

XBMC Log (for playing the recording directly of the NAS
Quote:implemented EricV's branch

From the fragment of logs you provided I can see that this branch uses some outdated patches for vdpau I have done. It's impossible to track this down in this state. Could you switch pvr master branch and provide debug logs?
The version of XBMC is OpenElec 1.95.4 (or 1.95.5) and either ION PVR or Generic PVR. I have 2 OpenElec machines, but cant remember off the top of my head which one i recorded the program on.

I'm on 1.95.4 currently (one Generic and one ION), so I will record another program from the above source, and report the XBMC playback logs for each platform.

I'll post them later tonight when i have access to the XBMC machines in question.

Cheers Nathan
I havent been able to get those logs yet, but saw another post on the xbmc forum by you regarding vpdau rewrites.
I assume the following "frodo" builds by newphreak contain your most recent vpdau patches?

Should I give that a go, or is it a little too bleeding edge?

Cheers Nathan
Quote:Should I give that a go, or is it a little too bleeding edge?

If I say yes, you'll blame me if something does not work Smile
Well, it's the version I have installed on my box in my living room.
Given that the builds above are pre-beta, i have only myself to blame Smile

From memory, I applied the following

At first glance it seems to have solved the seeking issue on the TS files. I'll have to do some more testing, but it looks promising.
Do these frodo build form the basis for the next official beta? Or are frodo releases further down the line?

Also, I really like the audio rework! My Sony TV over HDMi was auto detected, and for the first time i didnt have to fiddle around with asound.conf and plughw custom settings! Nice!

Cheers Nathan
Quote:At first glance it seems to have solved the seeking issue on the TS files

I don't think so because I have fixed it yesterday and submitted a pull request to mainline. The problem was that ffmpeg did not observe the 33bit PTS counter overflow.
ah, must have been a coincidence then that the recording i tried was ok... I'll look forward to testing the pull request. I don't know a great deal about hte process, but is it likely that your pull request will make it into a beta build in openelec? I ask, as that's my only real way of testing any changes (im a 100% openelec at present). Cheer, and thanks for the hard work. Nathan
You will probably find it here: after newphreak has done a new build.
excellent, I'll monitor that location for a new build, and when one arrives, i'll apply it, and reply with my experience... Cheers Nathan
New build arrived, but the playback has regular skips (every 2-3 seconds) on any content, which renders it unwatchable. Audio engine seemed to pickup the sony TV over HDMI which is great, but I had to revert to 1.95.4 to get reasonable playback for the living room TV. I can upgrade to this frodo build again and get logs for anything should you require it. Cheers Nathan

Logout Mark Read Team Forum Stats Members Help
TVHeadend TS Playback Issue0
This forum uses Lukasz Tkacz MyBB addons.