TVHeadEnd crashing & dropping tv signal
#1
HI all, I have an issue which is becoming annoying an wonder if anyone can help. I have changed my lounge setup from OpenElec 1.95.5 to using LinuxMint v13 64 bit and Install XBMC-PVR with TVHeadend from the Pulse-Eight Repo. OpenElec used to install TVHeadend v 2.1.3 but now I am on the latest on Pulse-Eight Repo. Unfortunatley in the upgrade I have broken something, Live TV is unusable. Here in NZ we are on DVB-T with x264 codec, AC3 for audio and I am using a Hauppage 1200 DVB-T card but after about 10 mins of live TV the picture starts to stutter. I can change channel and it come right for a little while but It still stops after a while. I cannot record anything as after about 15 mins TVHeadend must crash completely as I cannot access it from XBMC or the web browser. The error I see in the log is Transport Error Indicator. I never had this problem with OpenElec. Is it because now I am on 64-Bit? any suggestions? cheers - Nathan
Reply
#2
Well seems I might be the only one with this issue so I have done a clean wipe and installed 32 bit. Lets see how it goes now
Reply
#3
With out logs etc... there is not a lot people will be able to comment on.

Adam
Reply
#4
this is a sample of what i get, at least on 32bit it does seem to come right for a bit instead of crash.

Aug 13 18:23:40 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: H264 @ #450: Continuity counter error, 980 duplicate log lines suppressed

Aug 13 18:23:40 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: AC3 @ #410: Continuity counter error, 56 duplicate log lines suppressed

Aug 13 18:23:41 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: Transport error indicator, 6869 duplicate log lines suppressed

Aug 13 18:23:41 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: H264 @ #450: Continuity counter error, 1043 duplicate log lines suppressed

Aug 13 18:23:41 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: AC3 @ #410: Continuity counter error, 59 duplicate log lines suppressed

Aug 13 18:23:41 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: AAC @ #400: Corrupted PES header

Aug 13 18:23:42 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: Transport error indicator, 7283 duplicate log lines suppressed

Aug 13 18:23:42 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: H264 @ #450: Continuity counter error, 1113 duplicate log lines suppressed

Aug 13 18:23:42 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: AC3 @ #410: Continuity counter error, 65 duplicate log lines suppressed

Aug 13 18:23:43 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: Transport error indicator, 7660 duplicate log lines suppressed

Aug 13 18:23:43 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: AAC @ #400: Continuity counter error, 27 duplicate log lines suppressed

Aug 13 18:23:43 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: AC3 @ #410: Continuity counter error, 69 duplicate log lines suppressed

Aug 13 18:23:43 TS: NXP TDA10048HN DVB-T/Freeview : 570,000 kHz/TV3: H264 @ #450: Continuity counter error, 1173 duplicate log lines suppressed
Reply
#5
Well it is still playing up, maybe a driver issue?? Lost tv today, checked tvheadend webinterface and the capture card has disappeared out of the drop down list under TV adapters. How can I check kernel, drivers etc?

Edit I found out how to update the distro and am now running kernel 3.2.0-29 but i have no idea if this affects the capture card drivers ??
Reply
#6
(2012-08-13, 18:47)the_mouse Wrote: Well it is still playing up, maybe a driver issue?? Lost tv today, checked tvheadend webinterface and the capture card has disappeared out of the drop down list under TV adapters. How can I check kernel, drivers etc?

Edit I found out how to update the distro and am now running kernel 3.2.0-29 but i have no idea if this affects the capture card drivers ??

Often times the issue with TV Capture cards is that Linux tends to reupload the firmware to the card/dongle every 60 seconds. You can usually disable this feature in your modules config. Details for your particular adapter may vary. Since most adapters are Windows only, having the firmware is a necessary evil. You shouldn't have to upload it every 60 seconds though.

This is the issue I ran into while using a WinTV 950 USB stick. It would work for a bit, then it would just flake out. I bought a PCIe with native Linux support and it worked flawlessly. Unfortuneately, I had to move the card to a windows box... and now my problems are all Windows/WiFi related.
Reply
#7
I brought the Hauppauge HVR-1200 because I read it had good linux support maybe it doesnt. It must be a configuration or s/w as i did not have this issue under openelec. I went to a full distro as I needed to use a full desktop with web browser etc on that machine. I will certainly look into this firmware upload I don't understand why it would not just upload it once on boot and thats it.
Reply
#8
whenever i've had continuity issues, it has generally been related to the cabling or connection of the cabling to the tuner.
* Have you got any way to test that the tuner is working properly with the current cabling (i.e. a windows laptop)?
* Another possibility is that whatever build you are now using is not optimised for your hardware? I use the OpenElec ION PVR 1.95.4 and it works fine in Australia on a little AsRock ION330.
Cheers Nathan (yes, it is a great name isnt it) Smile
Reply
#9
Yep ya right Nathan is a good name !!

Cheers for the info. I would normally agree that a continuity error sounds like signal, but I have tested it to the TV ( I know they have better tuners but they still provide real-time signal strength and quality for DVB-T) and its very strong. Besides that should not make it drop the card off completely?? I have a feeling this is build related but not being a Linux Guru its a bit hard for me to know where to start all i do know is running OpenElec Generic PVR 1.95.4 it was fine.


Update :- ok i have done some digging, I see there are modules loaded by the kernel for devices, so for my DVB-T card there are tda8290, tda10048 and cx23885 I take it these are tuner and decoder. how can i work out what's different with the openelec distro modules (which worked) and the precise 3.2.29 modules?
Reply
#10
I'm suddenly having the same issue. It ran fine (on my Synology + TV headend)

Aug 14 22:15:13 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: Transport error indicator, 53579 duplicate log lines suppressed
Aug 14 22:15:13 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: MPEG2VIDEO @ #7021: Continuity counter error, 19320 duplicate log lines suppressed
Aug 14 22:15:13 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: TELETEXT @ #7023: Continuity counter error, 2163 duplicate log lines suppressed
Aug 14 22:15:13 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: MPEG2AUDIO @ #7022: Continuity counter error, 1288 duplicate log lines suppressed
Aug 14 22:15:14 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: Transport error indicator, 53880 duplicate log lines suppressed
Aug 14 22:15:14 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: MPEG2VIDEO @ #7021: Continuity counter error, 19434 duplicate log lines suppressed
Aug 14 22:15:14 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: MPEG2AUDIO @ #7022: Continuity counter error, 1298 duplicate log lines suppressed
Aug 14 22:15:14 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: TELETEXT @ #7023: Continuity counter error, 2176 duplicate log lines suppressed
Aug 14 22:15:14 TS: IT9135 USB DVB-T/Digitenne: 642,000 kHz/Nederland 2: MPEG2VIDEO @ #7021: Corrupted PES header, 80 duplicate log lines suppressed

Dongle is recognized and supported by Synology by default in DSM 4.1 beta.

Any suggestion is welcome.
Reply
#11
Wink 
I found this info by Igosr Petroff . I did try this on 64 bit, but it didnt work. Last night I thought I would try it now I am on 32 bit and I had 2 hrs of no glitch TV! I am very happy now its fine
I do remember that even windows sees a DVB stream as a network adapter, the old technisat Skystar 2 even installs as a network adapter, so this makes perfect sense.

Hi.
That's well known buffer problem.
You have to add to /etc/sysctl.conf this:
net.core.rmem_max = 16777216
net.core.wmem_max = 16777216

https://www.lonelycoder.com/redmine/boar...opics/3920
Reply



Logout Mark Read Team Forum Stats Members Help
TVHeadEnd crashing & dropping tv signal0
This forum uses Lukasz Tkacz MyBB addons.