Thread Rating:
  • 0 Vote(s) - 0 Average
MySQL-problems [2003] and (101)
Hello (my first post)

I'm trying to sync my library from my Netgear ReadyNAS MySQL-server to my pc (Windows) and Raspberry Pi with OpenELEC. (I do hope OpenELEC is sort of "supported" in this forum).
I got it all up and running between the NAS and my windows PC, I can fill and get my library from the MySQL-server.

On the raspberry i only got this error:
ERROR: Unable to open database: MyVideos60 [2003](Can't connect to MySQL server on '' (101))
The advancedsettings.xml (as shown in the below pastebin) is the same on both machines, so i can't understand what the problem might be?

Full debug log on the raspberry openElec:

I have tried to find an answer from people with similar problems but for all of them it seems to be a go/no go on all devices, where I instead only have problem with one device.
I'm guessing the problem here is you're using XBMC v11 on the Windows desktop, and the OpenELEC build, being based on pre-v12 code, is trying to update the database and doesn't have access. Even if it did, the two machines won't sync because they're not using the same code. You'd need to update the Windows desktop to a nightly build (wiki) that is close to what the OpenELEC build is using.

But that's just a guess. Is this setup working fine on the Windows PC? No errors and the library loads fine?
ok, will test to update windows PC.

Yes the PC is loading the library fine, no errors.

Debug log from windows PC:
Ah, I think I see the problem here. The user/password on the PC's advancedsettings.xml file is "xbmc" while the user on the R-Pi is "xbmcelec"

They both need to be "xbmc". That, and updating the PC to a nightly build, should fix the issue.
I got both users (did some testing on my own) but have change so both are correct now..

Your suggestion is to find the exactly matching nightly build on my pc?

When I use the latest build on PC it works great, but still not working on RPi:

Latest RPi-debug:
That last pastebin link doesn't seem to work?
Here is another try:
btw: PC is working with db named MyVideos68 and MyMusic27 now, and it doesn't seems like the RPi look for those, therefor my question; am I supposed to try another nightly build on the PC?
I changed to Raspbmc and now everything is working fine now (edit: sort of not). Seems to be something with OpenELEC/my settings in OpenELEC.

Thank you for your help though Ned!

EDIT: Actually it seems like it's a Wifi-thing, like xbmc tries to connect to MySQL before the wifi is up, and therefore results in a bad connection.
Any idea how to "fix" this or do I allways have to run on wired network to be able to load the library?

MySQL-problems [2003] and (101)00