ION2 - EDID no DTS-HD and TrueHD :-(
#1
I have ION2 running nice with xbmc. I have one problem i cant use DTS-HD and TrueHD. The problem is my ONKYO TX-SR308 reciver hav a bug in EDID that is known. In windows 7 i solved the problem with a custom EDID-file - look http://www.avsforum.com/t/1227161/edid-o...-ati-5xxxs . Is there a solotion in linux to fix the problem ?
Reply
#2
@golddk:
If you already have the edid file, you can make nvidia driver use it. First method through nvidia-settings, click on your Monitor Device and choose: Acquire Edid.

If this is not enough, you can also use xorg.conf to load a custom EDID (http://analogbit.com/node/23)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2012-08-17, 17:52)fritsch Wrote: @golddk:
If you already have the edid file, you can make nvidia driver use it. First method through nvidia-settings, click on your Monitor Device and choose: Acquire Edid.

If this is not enough, you can also use xorg.conf to load a custom EDID (http://analogbit.com/node/23)

I have the the monitor.inf file to Windows but i am not sure that this is the same file to use in linux ?
Reply
#4
Nope, follow the thread you linked. Read the the first part concerning of "getting the edid". You only need the edid information, there is no requierement to put it into a monitor.inf file.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
11.0 or 12 nightly? 11.0 is not able to passthrough HD audio formats under linux with ion2.
Reply
#6
(2012-08-17, 23:18)fritsch Wrote: Nope, follow the thread you linked. Read the the first part concerning of "getting the edid". You only need the edid information, there is no requierement to put it into a monitor.inf file.

Thx for the info. I found the error inside the EDID and build a new EDID and all is running nice now.

Some Onkyo recivers have this bad EDID. The fix is to have 7.1 in EDID instead of 5.1, then DTS HD and TrueHD is working. (and this is strange, the reciver is only 5.1)
Reply
#7
@golddk:
Please summarize the steps in here, so that _new users_ can easily follow.

And: Congratulations :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
Follow the steps here: http://www.avsforum.com/t/1227161/edid-o...-ati-5xxxs

Then edit it with EDID manager and in Speaker Allocation Data Block (SADB) add Rear Left Center/Rear Right Center Audio Channel (RLC/RRC) to EDID, for me i changed 0F to 4F.
Reply
#9
Bitstream or LPCM?
Reply
#10
(2012-08-19, 01:06)john.cord Wrote: Bitstream or LPCM?

Bitstream
Reply
#11
But not with 11.0 Eden?
Reply
#12
@John.cord:
No DTS-HD and no TrueHD on Eden. This is one of the big features the frodo release with AudioEngine will bring.

@golddk: Can you set this thread to solve?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
ION2 - EDID no DTS-HD and TrueHD :-(00
This forum uses Lukasz Tkacz MyBB addons.