Ember - UNRAID access denied
This is probably a quick one for someone who knows:

I have just started to move my media over to UNRAID. I have all my kids movies on my PC server. Updating them with Ember is fine.

I moved one movie across to the UNRAID. I now try to add that directory to Ember, I click Apply and the message below comes back ..

How should I approach this ?

Title: Error
Message: Access to the path 'C:\Ember_1.3.0.7\AdvancedSettings.xml' is denied.

StackTrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at System.Xml.XmlTextWriter..ctor(String filename, Encoding encoding)
at System.Xml.XmlDocument.Save(String filename)
at EmberAPI.AdvancedSettings.Save()
Date/Time: 9/4/2012 7:36:09 PM
It may be a shot in the dark but have you tried running Ember as Administrator? (Right click on whatever link you use to run it, Run as Administrator). As a guess, it doesn't seem like it specifically has anything to do with the fact you are using UnRaid (I use it myself with no problems) but more that Ember doesn't have the authority to save changes to the AdvancedSettings.xml file for some reason. If that doesn't work, how are you adding the shares from UnRaid to Ember? Do you have them mapped as drive letters or are you just using the network path? I have tried it both ways myself with no problems on Win 7 x64, but if you are doing something different I can try it on my end.
Client: XBMCuntu Frodo - ASRock ION 330 Pro - Logitech Harmony One
Server: 4U NORCO RPC-4220 20-drive case - UnRAID 5.0 - 38 TB parity-protected storage
It means that the AdvancedSettings.xml file is locked.

It happened to me sometimes but I always thought it was my fault due to the development multiple instances.

when it happens can you please try to open the AdvancedSettings.xml file (WITHOUT CLOSING EMBER) from notepad and let me know the outcome?

Obviously you must have full rights on the folder where Ember is stored.
If you think I'm useful please use the +/- button to raise my reputation

Logout Mark Read Team Forum Stats Members Help
Ember - UNRAID access denied0
This forum uses Lukasz Tkacz MyBB addons.