PSA: The forum server will be physically migrated to a new datacenter. Expect a large downtime of the forum between the 27th and the 29th of September.

Linux - XBMCBuntu Remote Wakeup

  Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
edhen Offline
Banned
Posts: 71
Joined: May 2012
Post: #1
I have about 12 tabs open each engaging solutions for this, But all are saying the same thing (well most). edit rc.local then add
Code:
echo USB1 > /proc/acpi/wakeup
and
echo enabled > /sys/bus/usb/devices/(device)/power/wakeup etc etc.

But none is working. After trying echo USB1 > /proc/acpi/wakeup (as root) nothing actually happens and there is no USB entry after doing the insert command.

All I wish to do is wake my htpc from my usb ir receiver which should act as a keyboard none the less...

so far my lsusb says
Code:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 003: ID 0471:20cc Philips (or NXP)
Bus 002 Device 004: ID 8086:0189 Intel Corp.
then
Code:
grep 20cc /sys/bus/usb/devices/*/idProduct
shows /sys/bus/usb/devices/2-1.4/idProduct:20cc

after checking /sys/bus/usb/devices/2-1.4/power/wakeup, it says enabled without having too echo enabled. So im assuming ive done what is required, so why can't i wake my pc via usb remote control?


EDIT: btw this is a zotac ID-81 in case that might help...
(This post was last modified: 2012-09-09 14:28 by edhen.)
find quote
edhen Offline
Banned
Posts: 71
Joined: May 2012
Post: #2
Considering this is still an issue i will bump this just in hope there is atleast 1 person with an idea for it too work, otherwise i give up...
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,339
Joined: Jul 2010
Reputation: 114
Location: USA
Post: #3
Are you sure your remote's receiver is USB1?

Post the result of:
Code:
cat /proc/acpi/wakeup

Try enabling each of your USB devices one at a time and see which one, if any, will keep your remote's port active during sleep. On one of my systems, it's not even USB*, but rather UHC2 that I had to enable.
find quote
john.cord Offline
Fan
Posts: 656
Joined: Jan 2007
Reputation: 7
Location: Vienna
Post: #4
i encounterd the same problem after switching from Ubuntu 10.10 to 12.04

None of the things that enabled USB Wakeup in 10.10 is working in 12.04

All USB Devices are enabled for wakeup and echo enabled > /sys/bus/usb/devices/(device)/power/wakeup as root is activated

But no USB Wakeup with IR Remot. A press on the usb rf keyboard is waking the system but remote not...
find quote
anthony.selby Offline
Member
Posts: 85
Joined: Jan 2011
Reputation: 0
Post: #5
Did you change the auto suspend part

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash xbmc=autostart,noredir usbcore.autosuspend=-1"
find quote
john.cord Offline
Fan
Posts: 656
Joined: Jan 2007
Reputation: 7
Location: Vienna
Post: #6
(2012-10-01 00:29)anthony.selby Wrote:  Did you change the auto suspend part

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash xbmc=autostart,noredir usbcore.autosuspend=-1"

yep!
find quote
vbat99 Offline
Posting Freak
Posts: 2,170
Joined: Aug 2009
Reputation: 57
Location: New Zealand
Post: #7
Can confirm this also, can't get remote to wake up in XBMCbuntu, any release.

Working in Dharma after editing grub, rc.local etc.

Same tricks don't work on XBMCbuntu.

So reinstalled Dharma and staying here till I can get remote wakeup working. And I do wish to upgrade.

Any help appreciated.

Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
find quote
john.cord Offline
Fan
Posts: 656
Joined: Jan 2007
Reputation: 7
Location: Vienna
Post: #8
http://ubuntuforums.org/showthread.php?t=1968487

Will test this tomorrow...

EDIT:

It is working !!! Rofl

Short guide:

First type:

Code:
sudo lsusb

Look for the vendor and product ID of your USB Receiver
Here is a example:

Code:
Bus 003 Device 002: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver

0471 is Vendor and 0815 is Product. They can be different in your case!

Create new file

Code:
$ sudo nano /etc/udev/rules.d/90-mcewakeup.rules

and put this line in it

Code:
SUBSYSTEM=="usb", ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0815" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

And change Vendor and Product ID with yours!

And dont forget about the GRUB Line

Code:
usbcore.autosuspend=-1

In my case it looks like this

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

Finaly

Code:
sudo update-grub

and Reboot !!!
(This post was last modified: 2012-10-01 11:02 by john.cord.)
find quote
sirgaric Offline
Junior Member
Posts: 4
Joined: May 2012
Reputation: 0
Post: #9
Great finding

What about the rc.local lines? Are they not needed anymore?

Cheers
find quote
john.cord Offline
Fan
Posts: 656
Joined: Jan 2007
Reputation: 7
Location: Vienna
Post: #10
in my case not...
find quote
vbat99 Offline
Posting Freak
Posts: 2,170
Joined: Aug 2009
Reputation: 57
Location: New Zealand
Post: #11
(2012-10-01 03:58)john.cord Wrote:  Create new file

Code:
$ sudo nano /etc/udev/rules.d/90-mcewakeup.rules

and put this line in it

Code:
SUBSYSTEM=="usb", ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0815" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

And change Vendor and Product ID with yours!

Well it will have to wait till the weekend for me to test, but the above section must be the culprit when it comes to Ubuntu 12.04.(XBMCbuntu)



(2012-10-01 12:27)sirgaric Wrote:  Great finding

What about the rc.local lines? Are they not needed anymore?

Cheers
Seems in Ubuntu 12.04 (which XBMCbuntu is now based on), the USB ports are already enabled by default. And
Code:
echo enabled > /sys/bus/usb/devices/(device)/power/wakeup etc etc.
may be superseded with above new rule.

Added to my notes for testing. Thanks John.

Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
find quote
sirgaric Offline
Junior Member
Posts: 4
Joined: May 2012
Reputation: 0
Post: #12
I can confirm that it worked flawlessly. Great!

I was fearing it was a hardware issue with my motherboard (IONITX-T-E), since I had read some nasty things about some of its brothers while looking for a fix.
find quote
edhen Offline
Banned
Posts: 71
Joined: May 2012
Post: #13
I still cant get mine working :/ i followed the instructions yet i still cant power it back on via usb, yet WoL etc works fine. Here is my /proc/acpi/wakeup and as you can see, there are no usb's... i ahve tried many methods but none seem too be working... Arrggh

Code:
Device  S-state   Status   Sysfs node
P0P1      S4    *disabled
RP01      S4    *disabled  pci:0000:00:1c.0
PXSX      S4    *enabled   pci:0000:01:00.0
RP02      S4    *disabled
PXSX      S4    *disabled
RP03      S4    *disabled  pci:0000:00:1c.2
PXSX      S4    *disabled  pci:0000:02:00.0
RP04      S4    *disabled  pci:0000:00:1c.3
PXSX      S4    *disabled  pci:0000:03:00.0
RP05      S4    *disabled
PXSX      S4    *disabled
RP06      S4    *disabled
PXSX      S4    *disabled
RP07      S4    *disabled
PXSX      S4    *disabled
RP08      S4    *disabled
PXSX      S4    *disabled
PEG0      S4    *disabled
PEGP      S4    *disabled
PEG1      S4    *disabled
PEG2      S4    *disabled
PEG3      S4    *disabled
GLAN      S4    *disabled
EHC1      S4    *disabled  pci:0000:00:1d.0
EHC2      S4    *disabled  pci:0000:00:1a.0
HDEF      S4    *disabled  pci:0000:00:1b.0
PWRB      S3    *enabled
(This post was last modified: 2012-10-13 02:16 by edhen.)
find quote
john.cord Offline
Fan
Posts: 656
Joined: Jan 2007
Reputation: 7
Location: Vienna
Post: #14
sudo lsusb plz !!
find quote
Devaron Offline
Member
Posts: 93
Joined: Apr 2011
Reputation: 5
Location: Netherlands
Post: #15
Hi there. I've had a LOT of problems getting my remote to work correctly, and have tried many different solutions. In the end the following worked for me:

(BTW sorry for my english. It's not my first language and i'm a little bit in a hurry... Big Grin )

To show you all connected USB devices, open a terminal window and enter the following:
Code:
lsusb

Your remote reciever should be there. Write down the ID (mine is 0471:060c, so i write down 060c. Yours can be different ofc, but i'll use mine in this example).

Find out on what USB port your remote reciever is connected:
Code:
grep 060c /sys/bus/usb/devices/*/idProduct

The result looks something like: /sys/bus/usb/devices/3-1/idProduct:060c

Write it down. Here the "3-1" shows me on which USB port the remote reciever is connected (3 is USB hub 3, 4 is USB hub 4 etc.). Again, yours can be different, but i'll use this one in this example.

Check if wakeup is enabled on that USB port:
Code:
cat /sys/bus/usb/devices/3-1/power/wakeup

The result should be "enabled". If not, enable it with:
Code:
sudo sh -c 'echo "enabled" > /sys/bus/usb/devices/3-1/power/wakeup'

substituting the 3-1 in this example for your USB port.

BTW. remember the two quotes ( ' ) (or whatever they're called). One just before the word 'echo' and one after the word 'wakeup'.

This setting resets after every boot so to permanently save it, open the file 'rc.local'
Code:
nano /etc/rc.local

and scroll all the way down. Add the following lines at the bottom of the file, but BEFORE the line 'exit 0':
Code:
echo USB3 > /proc/acpi/wakeup
echo enabled > /sys/bus/usb/devices/3-1/power/wakeup

Make sure the 'USB3' is the correct USB port. If you got "4-2" this should be 'USB4' etc.

Save the file and make sure that the file rc.local is executable:
Code:
sudo chmod +x /etc/rc.local

That should be it. Reboot and see if it works.
find quote
Post Reply