XBMC + 3D = Crosstalk / Ghosting ? SOLUTION HERE!
make sure your pixel aspect ratio is correct when not in 3D mode. Don't calibrate in 3D mode as it doesn't have a separate calibration. Also, try to turn of overscan wherever possible if your TV doesn't need it. So first make sure everything is fine in 2D.

Also, does this issue show up on every SBS movie or only a particular one?
Overscan is turned off on TV. Only setting I use there would be "maximize visible area", but disabled even that one for the testing purpose.
The pixel aspect ratio should be "1.000" for 2D, Will check again and try other 3D content.
I will try other movies too. But I think I already notified it on others too. The one in particular was the Into of a low budget scifi movie, everything black but many spaceships flying from left to right.
I will try the few movies I have to see if I can find it somewhere else too.

Is there a way to change the aspect ratio in any of the xml files?
Already searched inside the guiconfiguration.xml (maybe another name, but gui was inside) and found many entrys that could fit...

Okay, after the re installation I checked the ratio again, it is on "1.000" and "2.000" in 3D mode.
It seems the border disappeared.
But the effect is still there, where the opper left part of the picture features ghosting.
I will check my old TV-Box tomorrow, checking if it was present there already. It is a neotv 550 by netgear... Piece of crap since the support was dropped mid beta ... Still doing it job for movies somehow Wink
I don't know what happend ...
Haven't changed anything, but the picture seems better...
On the neotv I haven't found any traces of the ghosting. After switching to kodi I neither found them there ...
Maybe really the source material that was bad

Thank you very much for this post, it almost made my day, I was searching for a solution for a very long time.
I have Kodi running on Fire TV and beside the configuration you wrote I had to set the TV settings in Fire TV to 1080p/60Hz, it was 1080p/50Hz before and then it worked for me.

So why 'almost' mode my day?
It's still not as perfect as you describe your experience. It is much, much, much better, it's not comparable anymore to the very bad 3D picture before.
Before I had such bad crosstalk that it led to nearly 20 cm (8 inch) dark overlay on left an right side.
Now it's just about 1 cm on both sides, so the picture is about 20 times better ;-)
Now I am able to watch the movies, but there is still a small ghosting in it and the 3D effect is not as good as when I watch a movie directly via media streaming on the Samsung TV. I think I made 99% to perfection and now I'm looking for the 1% to get there.

But without your post I wouldn't have reached 20% yet.

Thanks so much.
My PC was already set with overscan 0, so I just to had to modify the TV setting.
In my Philips TV the right format is called "Unscaled".

Really Thanks
Old thread but I wanted to revive it to thank the OP. I've been suffering from bad crosstalk on my 2014 Samsung LED HDTV when watching 3D movies, and I couldn't figure out why. I had already set everything the OP suggested, but then I remembered a setting I had enabled for zoom to eliminate black bars, which I had set at a 4% threshold. This meant that if there were black bars at the top and bottom, the image would be stretched vertically up by 4%. This worked great on 2D movies that had some slight cropping and I just wanted to "clean up" the image, but after reading the OP I realized this was the source of my 3D crosstalk/ghosting issues! I disabled this feature and now my 3D movies are almost completely crosstalk/ghosting free! This was driving me insane for over a year, to the point when I stopped watching 3D movies because I got so annoyed by the poor image quality. Thanks again OP!
Thread Rating:
  • 2 Vote(s) - 5 Average

Logout Mark Read Team Forum Stats Members Help
XBMC + 3D = Crosstalk / Ghosting ? SOLUTION HERE!52
This forum uses Lukasz Tkacz MyBB addons.