Help me set up SMB sharing to my Raspberry PI?
#1
Hello everyone,

I recently bought a raspberry pi as an upgrade to my old and outdated hacked up Wii media center but between my SSD upgrade on my desktop and switching to my pi I seem to have lost the ability to use SMB sharing.

I'm not quite sure if this is a problem on the xmbc end or on the windows side. I followed this tutorial to try to reset-up my smb shares but now when I try to share I just get an error saying this folder cannot be shared and nothing shows up on my pi.

My pi is connected via ethernet, and is running Xbian (should I try a different OS?)
Playing files from a USB hard drive works fine.

Any ideas?

Reply
#2
Hi i have been wondering the same thing, but i would like to have the SMB share to the usb disk that is auto mounted in boot as i have to plug the disk in after a reboot

Reply
#3
OpenElec by default installs Samba/SMB on their Raspberry PI image but the title of this thread seems misleading as it seems you are just having issues accessing the network FROM your RPi, not setting up or installing SMB/Samba on your Pi. Otherwise theres many other threads about installing it manually if you are using another flavor like RaspBMC or whatever.
Search first, provide details and keep forums clean. Mark things solved, to close them out and acknowledge helpful volunteers who share. If I have helped, click the plus button.
Reply
#4
(2012-09-14, 23:15)transcender Wrote: OpenElec by default installs Samba/SMB on their Raspberry PI image.

But I'm not trying to share from the pi, I'm trying to share from my Windows machine TO my pi.

Also noob question:

What is NFS sharing? It says in the siticky that NFS is the prefered sharing type. Is this available on windows? How can I set it up (Google gave me nothing)?
Ok I have verified that my SMB sharing is working correctly. I can accsess and view all the videos on my Mac Mini running Lion.

Is this an Xbian problem then?
Reply
#5
I tried the latest openELEC with the same result....

Anyone got some ideas?
Reply
#6
Are they both using the same workgroup name?
Image
Reply
#7
Yes same workgroup, its just the default WORKGROUP.

I also noticed that I cannot see the openELEC share on my PC but I can view both the openELEC share and the PC share on my Mac Mini.

I tried a bunch of supposed fixes last night with no luck...
Reply
#8
try to use \\<ipadress> in your windows explorer
greetings, Stephan

Image
Reply
#9
(2012-09-15, 18:28)sraue Wrote: try to use \\<ipadress> in your windows explorer

THANK YOU!!!!!

I put in the ip for the raspberry pi and then the share popped up, then I went added the share by the ip adress of my PC into openELEC and boom!

Thanks all!
Reply
#10
Hi

i have this working it comes up in wondows to but it keeps asking me for a user name and password in windows any ideas?

porky550
Reply
 
Thread Rating:
  • 3 Vote(s) - 2.33 Average



Logout Mark Read Team Forum Stats Members Help
Help me set up SMB sharing to my Raspberry PI?2.333