• 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 174
OpenELEC Testbuilds for RaspberryPi
(2012-11-20, 20:15)Trixster Wrote: It's not the nas speed over the network that's the issue as my xbox360 plays the video fine. It looks like the audio is 5.1 WMAPro - could that be the issue?

Could be. Depends if WMAPro is more complex in decoding than DTS.
(2012-11-20, 15:13)Trixster Wrote: I'm running:


File system is nfs, using a MybookWorld network hard drive.

I'm not upping core or sdram at the mo as I don't want to risk corrupting the sd card.

Is it likely that core and sdram need to be bumped, or is it likely the network speed (all Ethernet) is the issue? 1080p ac3 files run fine, but DTS ones stutter and lose video/audio sync.
rbej, have you changed any of the openelec configs or settings to get things running smoothly? The specific video in question is 10gb in size, however I have other 10gb 1080p ac3 files which run ok.
And were i to try upping the clocks, what would be sensible settings for core and sdram to match the 1000mhz arm freq?
Just take a image backup first of your sd card. (: It take 5mins and is good general practice in any case.
Btw the parameter is force_turbo not turbo_force.

My config:
Last line is to force AAC audio to my tv as digital otherwise software decoding sent it to the wrong speakers. Software DTS.

512mb board - current uptime (not total) 2days 3mins.
It will do 1150 with over_voltage=8 but a half piece of pi is fine. (:

Warning: Will break warranty but I'm not to worried about the electronics but more the mechanics had to replace the sdcard holder on my first pi which lead me to impulse buy a extra pi while ordering the new sdcard slot. Heh..

In the process of making a headless web server with 2.5" harddrive of the old one to save energy and noise and it's surprisingly efficient and fast.
@tuxen: Typo in your config - "force=turbo=1" should be "force_turbo=1"

Note that overvolting in combination with force_turbo=1 will void the Pi warranty - just an FYI for anyone looking to use the same settings.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yeah I wrote/edited both right after I noticed. Smile The config.txt was not a copy/paste though as it was just as fast writing it again.
Sorry for some confusion guys, I'm using force_turbo=1, not turbo_force (a typo!).

It also looks like it's just one video that's the issue, which for some reason is using 5.1 WMAPro and causes the Pi all sorts of stuttering issues. I'll re-encode it. I've acquired another 15gb 1080p DTS 5.1 video and that's running with zero issues on a 1ghz overclock using NFS.
Hi guys.

A bit of a noob on all this stuff, but learning a bit more everyday.

Currently I have 1 OpenElec image (r12457 - XBMC 12.0-ALPHA7 Git:860cd91) and 1 DarkElec (r12333 - XBMC 12.0-ALPHA7 Git:20121107-b53c827) and both have the same issue, which I'm not sure if it is XBMC fault or not, bust most probable.

I could build my Movie database successfully, but I cannot make it to actually search for and find new content. System seems to be searching, but at the end, the new files don't appear in the library.

Does anybody know why this may be happening or can guide me on how I can find out what may be happening? Nothing odd appears in xbmc.log. I can even find and play the files if I go through the Files section and its source...but I cannot make XBMC add it to the library how it should.

Any help will be appreciated.
Maybe the naming convention of the files and the scrapper dosnt know what to do with it. Check names of the files and try different scrapper or maybe you have to manually make nfo for it to scrap.

This what I absolutely hate abot xbmc is having to go through a scrapper to get items added to movie/tv library. I can understand why they use this database method over flat files, but there should be a way to bypass scrappers to get items in to the database. So much easier if the scrapper fails or it is a custom movie/tv show if you could force it to use the movie/tv show file name and whatever cover is in the folder with it.
That shouldn't be the case, otherwise it should have never worked and it did the first time I built the library. It's just the adding new files that don't work...

Is there any kind of log I can check for this library updates? Xbmc.log has nothing useful...
are your newer files accessible to the user that xbmc runs as
how do you manually force XBMC to use the pre-generated NFO files for movie descriptions please? I tried it with an earlier openELEC build and it still went off to the web sites.
When you're adding a source don't check the option to use the folder names for lookup.

OpenELEC Development build (r12577):

to update a older build without reinstalling see:

Please also read http://sources.openelec.tv/tmp/image/ope..._FIRST.txt for general notes about our development builds.

This are the changes:
  • updated XBMC to the last and greatest XBMC master checkout (something between Beta 1 and Beta 2) :-)
  • added a new "boot from RAM" function (please read the notes below)
  • various other improvenments, fixes and many package updates.

This build primary added a function to boot from RAM instead accessing the SDCard to much on boot (512MB RPi only):
by default OpenELEC now copys the SYSTEM file to a ramdisk very early and before the SYSTEM file is mounted, if at least 356MB "Total Memory"
cat /proc/meminfo
is avaible (256MB + 100MB reserved for the system). This at least should give us a quicker boot and fewer diskaccess on boot. Also Network boot setups should benefit from this.
This feature is not avaible on 256MB RPi's because of to low RAM and can be disabled on 512RPi systems with adding
to /flash/cmdline.txt.
By default this feature is enabled and must be disabled manually with the noram option if not wanted. Please dont use a to high GPU Memory split so
you dont run in to few "Total Memory" where this function is not avaible (a 128MB Memory split which is our default should work fine).

If you boot from RAM a file /dev/SYSTEM is avaible, if booting not from RAM the file is not there (to check which boot method was used).

Please test the builds and compare with and without the noram option and report back your findings.

A 256MB RPi should boot like before.

With one of the last builds we have update the latest bootloaderfiles to support 512MB RPi's (see: http://www.raspberrypi.org/phpBB3/viewto...25#p198079 and http://www.raspberrypi.org/phpBB3/viewto...25#p198247. This also also includes the following changes:
  • on creating a fresh SD-Card a default config.txt will be installed which allocates 128MB GPU memory on 256MB and 512MB Raspberry's
  • on updating there will be checked if a config.txt exist, if not the default config.txt will be installed
  • if a config.txt with a uncommented variable 'gpu_mem' variable already exist nothing will be changed
  • if a config.txt without a 'gpu_mem' variable exist our default config.txt will be installed and will be enhanced with your old config.txt. your old config.txt will be backed up to config.txt.bk.

Please backup your old config.txt in the case you dont find your license codes anymore before you install this update

After the update please check your /flash/config.txt byself and report back any issues. Please report back if this update work like excepted on 256MB and 512MB Raspberry's

because XBMC now supports officially RPi and PVR please use XBMC's Trac (http://trac.xbmc.org/) to report XBMC bugs and OpenELEC's github issue tracker (https://github.com/OpenELEC/OpenELEC.tv/issues) for OS related issues and feature/driver requests.
greetings, Stephan


Very good build. Fast and smooth.

DHCP doesnt get DNS address (v12.0 beta 1 25bb46a)

DHCP works, however the DNS address is with no secondary, my DHCP server gives out 2 DNS addresses, this is a bug.

Not sure about this, in SYSTEM > SYSTEM INFO > Network (DNS) it shows as and says has internet but not DNS.

If i go to SYSTEM > SETTINGS > ADD-ONS > ENABLED ADD-ONS > PROGRAM ADD-ONS > OPENELEC OS SETTINGS > CONFIGURE > NETWORK and add a static IP address and DNS, this still doesnt show up in the system (even after a proper reboot), however the DNS is still but the "no DNS address" message is gone.

I still cant get PVR service working (which i thought was a name resolution issue due to the above DNS problem).
Many Thanks

© Copyright 2016 - www.ashleygriffin.ca
Hi, I've been testing/playing with Openelec and XBMC over the past few weeks on my 256 Rpi. I have some observations on AirPlay. Everything seems OK for 720p or lower but if you attempt to view 1080p content (I'm streaming from an iPad-2 and/or iPhone-4) its extremely slow and is simply not usable/watchable.

I'm running version 12563 (from openelec.thestateofme.com).

Can someone please confirm AirPlay issues with 1080p video ? Any known work-around ?

  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 174

Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi12
This forum uses Lukasz Tkacz MyBB addons.