OpenELEC Testbuilds for RaspberryPi

  Thread Rating:
  • 12 Vote(s) - 4.58 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
rbej Offline
Fan
Posts: 659
Joined: Sep 2012
Reputation: 25
Post: #901
(2013-01-16 15:25)gizmomel Wrote:  Why such high usage? Is that normal? thank you.

Yes. Is normal.




find
brra Offline
Junior Member
Posts: 5
Joined: Jan 2013
Reputation: 1
Post: #902
Hi,

This is regarding the 100% CPU utilization issue.
I managed to get it down by changing the setting 'Vertical blank sync' to 'Always enabled' under System - Settings.
Would be nice to have this confirmed on other systems.



Don't ask way, but this works!
When I used samba to running 1080p it was lagging, I switched to NFS, no problem.
This could be a solution to some of the issues I have read about.

Please look over the Samba configuration, transfer speed is very low for some reason.
(This post was last modified: 2013-01-16 19:46 by brra.)
find
popcornmix Offline
Team-Kodi Member
Posts: 7,767
Joined: Feb 2011
Reputation: 320
Post: #903
(2013-01-16 16:06)aegis123 Wrote:  @popcornmix, which software is good to cut the movie? Can't put the whole movie on USB cause I have a 8gb stick and all my movies are 10gb+
I'll try and test when I cut up the movie and put that piece on USB.

Use mmg from here:
http://www.bunkus.org/videotools/mkvtoolnix/
(2013-01-16 19:40)brra Wrote:  This is regarding the 100% CPU utilization issue.
I managed to get it down by changing the setting 'Vertical blank sync' to 'Always enabled' under System - Settings.
Would be nice to have this confirmed on other systems.

That would be surprising. Can you confirm that switching 'Vertical blank sync' off again reliably makes the CPU go back up.
(This post was last modified: 2013-01-16 19:48 by popcornmix.)
find
brra Offline
Junior Member
Posts: 5
Joined: Jan 2013
Reputation: 1
Post: #904
(2013-01-16 19:40)brra Wrote:  This is regarding the 100% CPU utilization issue.
I managed to get it down by changing the setting 'Vertical blank sync' to 'Always enabled' under System - Settings.
Would be nice to have this confirmed on other systems.

That would be surprising. Can you confirm that switching 'Vertical blank sync' off again reliably makes the CPU go back up.
[/quote]

Confirmed!
15-25% CPU utilization when enabled, 80%-99% when disabled.
find
pplucky Offline
Senior Member
Posts: 112
Joined: Nov 2012
Reputation: 1
Post: #905
(2013-01-16 20:12)brra Wrote:  15-25% CPU utilization when enabled, 80%-99% when disabled.
Not here. Same CPU utilization with or without that setting enabled.

OK, it seems you were checking it with top via SSH and not via XBMC...
(This post was last modified: 2013-01-16 20:50 by pplucky.)
find
miappa Offline
Posting Freak
Posts: 1,068
Joined: Dec 2012
Reputation: 80
Post: #906
(2013-01-16 20:12)brra Wrote:  Confirmed!
15-25% CPU utilization when enabled, 80%-99% when disabled.

Weird, but same for me.
12-15% when enabled, jumping between 60-95% when disabled.
I´m on r12945.
(2013-01-16 20:12)brra Wrote:  Confirmed!
15-25% CPU utilization when enabled, 80%-99% when disabled.

Weird, but same for me.
12-15% when disabled, jumping between 60-95% when disabled.
I´m on r12945.
(2013-01-16 20:12)brra Wrote:  Confirmed!
15-25% CPU utilization when enabled, 80%-99% when disabled.

Weird, but same for me.
12-15% when disabled, jumping between 60-95% when disabled.
I´m on r12945.
(This post was last modified: 2013-01-16 20:36 by miappa.)
find
brra Offline
Junior Member
Posts: 5
Joined: Jan 2013
Reputation: 1
Post: #907
This is what I did:
1. Disabled all the functions that you dont use.
2. removed all samba mounts, only using NFS now
3. Removed all plugins I dont use.
4. Enabled 'Vertical blank sync'.

When I Enabled 'Vertical blank sync' CPU usage went down alot, About 80%, I have peaks, but when the system is on the home screen the CPU usage is at 10-15%.

Hope this helps.

Good for you to know, I run on r12945
(This post was last modified: 2013-01-16 20:41 by brra.)
find
carl1jenn Offline
Junior Member
Posts: 23
Joined: Jan 2013
Reputation: 0
Post: #908
Which skin are you using?
find
brra Offline
Junior Member
Posts: 5
Joined: Jan 2013
Reputation: 1
Post: #909
Confluence, just to have the most simple skin to optimize CPU
find
miappa Offline
Posting Freak
Posts: 1,068
Joined: Dec 2012
Reputation: 80
Post: #910
Wth happaned to my postConfused Confused

Anyway... don´t know if you were referring to me, but I myself use Hybrid.
Took me a while to set it up, but now it runs as well, if not smoother, than Confluence.

It depends where I "stand" at home menu, but enabling vertical black sync and I get ≈ 12-15% at home screen.
find
popcornmix Offline
Team-Kodi Member
Posts: 7,767
Joined: Feb 2011
Reputation: 320
Post: #911
(2013-01-16 19:40)brra Wrote:  This is regarding the 100% CPU utilization issue.
I managed to get it down by changing the setting 'Vertical blank sync' to 'Always enabled' under System - Settings.
Would be nice to have this confirmed on other systems.

Okay, I've poked around and this setting is beneficial.
When "Always enabled" it limits the GUI rate to the display's framerate (e.g. 50 or 60 Hz).
"Disabled" and "let driver choose" will allow the fps to exceed the display framerate (capped at 100 fps). This is pointless and just increases CPU.

It depends where you are in the menus whether this setting has an effect. Easiest to see by enabling debug, then you get fps and cpu overlaid on the screen.
If the screen has a lot of text then we might only be able run at 45 fps, so this setting has no effect.
If the screen is simple we might be able to run at 75 fps, then limiting to 50 might produce a measurable CPU drop.
If you are in a 24/25/30 Hz hdmi mode, then you will get more benefit from this setting.
(This post was last modified: 2013-01-16 22:01 by popcornmix.)
find
miappa Offline
Posting Freak
Posts: 1,068
Joined: Dec 2012
Reputation: 80
Post: #912
Cheers Popcorn, this explains it.
However, I must confess that I had no idea that this would affect the GUI, I thought it was for video playback only.

I will play around with it a little bit and see how it behaves on different settings.

Edit:
Ok, just to let everyone else who will test this know:
It´s better to use top via ssh since the debug text will cause the CPU to fluctuate a little to much. Smile


Edit:
Did some testing if anyone is interested:

I got a 24p TV so I tested 24, 50 and 60Hz: "Calm" screen / Just some more text and graphics

50Hz always enabled: 30% / 40%
50Hz let driver…: Same as always but higher top and lower drop

60Hz always enabled: 28% / 36%
60Hz let driver…: Same as always but higher top and lower drop

24Hz always enabled: 30% / 36%
24Hz let driver…: Same as always but higher top and lower drop


I also tested on screen with a lot of text and graphics (after a reboot):

60Hz "let driver…": 55% but quite high top
60Hz always enabled: 55%

24Hz always enabled (no reboot, only tested always…): same as 60Hz on always


Last test 60Hz on "always" with very "calm" screen: 12-15%

Conclusion: I will stay at 60Hz with always enabled, same settings as I had before. Big Grin
(This post was last modified: 2013-01-16 23:14 by miappa.)
find
tuxen Offline
Fan
Posts: 383
Joined: May 2011
Reputation: 6
Post: #913
(2013-01-16 19:40)brra Wrote:  Hi,

This is regarding the 100% CPU utilization issue.
I managed to get it down by changing the setting 'Vertical blank sync' to 'Always enabled' under System - Settings.
Would be nice to have this confirmed on other systems.



Don't ask way, but this works!
When I used samba to running 1080p it was lagging, I switched to NFS, no problem.
This could be a solution to some of the issues I have read about.

Please look over the Samba configuration, transfer speed is very low for some reason.

Yes this is true an example if you are overclocked and use the systeminfo screen.

Because I run 1050/500/500 if I turn off vsync I get 85fps in the system screen and the CPU is hammering away at around 100%. If I turn vsync on and go to the system info screen the vblank limits fps to 60 because I run 60hz and therefore the CPU is not hammering as much to put out as many frames as possible and is down to 75%.

If I stay at that screen while measuring CPU with top I get roughly the same numbers.

But the failure here is you can not use the systeminfo screen to measure CPU idle usage neither must you be on this screen while measuring with top.

So go to the front page and use top and you will get a correct reading.

What you are describing above is normal because there will be more spikes where the fps run higher than your HZ setting with vsync off.

Vsync on will give a more fluid GUI and more cpu overhead because you do not reach these fps spikes.

Edit: Arg missed your answer popcornmix <sigh> actually the whole page and before that and I just looked briefly up to the previous post. Typical me not to refresh.
Anyway I have been aware off this for a long time because of my high overclock it became very transparent.
(This post was last modified: 2013-01-17 07:20 by tuxen.)
find
Wanderlei Offline
Senior Member
Posts: 129
Joined: Aug 2012
Reputation: 0
Post: #914
(2013-01-16 19:40)brra Wrote:  When I used samba to running 1080p it was lagging, I switched to NFS, no problem.
This could be a solution to some of the issues I have read about.

Please look over the Samba configuration, transfer speed is very low for some reason.

Is this something that will be improved? I think a lot of people would use shares from windows machines.
find
tfft Offline
Junior Member
Posts: 47
Joined: Nov 2012
Reputation: 1
Post: #915
Hi, I've been running openelec master/head (f5d4937ada) and I'm seeing various random freezes and then reboots from misc streaming sources. For instance, TMZ->TMZ-Live and pick any offering seems to reboot the most again at various inconsistent times.

How does one go about debugging the cause of such things ?

Thanks.
find
Thread Closed