Has anyone ever seen a crash on display of NEF files
#1
I had two crashes running Win7 x32 Eden 11 on i3 with a GT430.

I haven't tried to replicate it again, I'm just wondering if anyone has seen this. I was browsing a dir of about 200 pictures (Nikon NEF format) and at about #90, the photos lost most resolution (looked like a oversized thumbnail) , and at photo #100 XBMC crashed.

It looks like maybe the card ran out of memory?

ERROR: CD3DTexture::Create - failed 0x8876017C

http://pastebin.com/f1qvvs53

Thoughts?



Reply
#2
(2012-09-20, 16:31)ixnu Wrote: I had two crashes running Win7 x32 Eden 11 on i3 with a GT430.

I haven't tried to replicate it again, I'm just wondering if anyone has seen this. I was browsing a dir of about 200 pictures (Nikon NEF format) and at about #90, the photos lost most resolution (looked like a oversized thumbnail) , and at photo #100 XBMC crashed.

It looks like maybe the card ran out of memory?

ERROR: CD3DTexture::Create - failed 0x8876017C

http://pastebin.com/f1qvvs53

Thoughts?
I've seen the low resolution happen, but I don't recall having a crash.
Reply
#3
Quote:I've seen the low resolution happen, but I don't recall having a crash.

It appears to be a driver issue. I can repeatedly crash with my GT430 browsing over 120 NEF files. However, my HTPC with an HD5570 with almost the exact set up does not crash.
Reply
#4
I'm not so sure it is a driver issue. I tried using an XBMC live disc and I still had NEF pictures eventually crashing the system. Current nightlies also have issues.

I've since gone and gotten a good log (from my main WIndows 7 machine, recent nightly) of the picture slideshow changing from NEF's being displayed correctly, to looking like blownup thumbnails. After that point the system eventually became non-responsive and required a forced closure.
The log is located here.

Any ideas what "Qlock" is about? That seems to be smack in the middle of the change from proper resolution NEFs to thumbnail displayed NEFs.
Code:
20:43:32 T:21288   DEBUG: Image smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-07_17-06-59__DSC3852.NEF is finished rendering, switching to smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-07_17-07-01__DSC3853.NEF
20:43:32 T:21288   DEBUG: CAnnouncementManager - Announcement: OnPlay from xbmc
20:43:32 T:21288   DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnPlay
20:43:32 T:21288   DEBUG: UPnP: Building didl for object ''
20:43:32 T:21288   DEBUG:   msg: JpgParse: Not a JPEG file smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-07_17-07-01__DSC3853.NEF
20:43:32 T:21288   DEBUG: Loading the next image 13: smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-07_17-07-04__DSC3854.NEF
20:43:33 T:6100   DEBUG: Finished background loading slot 1, 13: smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-07_17-07-04__DSC3854.NEF
20:43:34 T:20860   DEBUG: ### [Qlock] - Delaying 240 secs
20:43:34 T:19508   DEBUG: Caching image 'smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-26_21-10-15__DSC4423.NEF' to '8/88de5ce4.jpg':
20:43:34 T:19508   DEBUG: cached image 'special://masterprofile/Thumbnails/8/88de5ce4.jpg' size 160x120
20:43:36 T:19508   DEBUG: Caching image 'smb://THE_VAULT/vault/Pictures/2013/Isabelle - 04/2013-04-26_21-10-15__DSC4424.NEF' to '2/21260f7c.jpg':
20:43:36 T:19508   DEBUG: cached image 'special://masterprofile/Thumbnails/2/21260f7c.jpg' size 160x120
Reply
#5
Is there any additional debugging that can be done to help get this fixed? Is this an issue with the underlying raw image library??
Reply
#6
the central raw topic: http://forum.xbmc.org/showthread.php?tid=167127

You can try putting .nef extension in your as.xml or test with a local file. But I wont think it helps. Also you could try a nightly + ace his patch (see raw topic).
Best change is to have jmarshall (or other teammember) have a ,look.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Has anyone ever seen a crash on display of NEF files00