"Start Recording" not changing to "Stop Recording"
#1
I have posted a thread to this issue already, my first thought was that it is a Plugin error, but I tested several PVR plugins and tv-server, all with the same result, so i guess it is a general xbmc pvr issue....:

When I start a tv channel and choose "Start recording" in the channels context menu, the recording starts(files are created and i can see a little camera symbol in the top-left corner showing recording-time), but the "Start Recording" string in the context menu is not changing to "Stop Recording", also no red recording DOT is appearing....

When I hit "Start Recording" a second time, a new record-file is created(first one is also going on with recording), and the context menu changes to "Stop Recording" and the red recording DOT appears.

User jajoflo told me it is a known issue and the problem is that tv-server can not notify the client about status.
My question is why recognizes xbmc that the server is recording when I hit "Start Recording" the second time?

So I think it is not that big to handle this issue, either you force xbmc to go to "IS Recording state" when "Start Recording" button is pressed without notification from tv-server, or the better way would be to ask the server for its state directly after hitting "Start Recording" from context menu, in other words "do the same thing that is making xbmc recognizing that server is recording when Start Recording is pressed the second time".



Am I the only one with this issue? Can someone tell me where in the source files this is handled so I can change by myself?
Reply
#2
any help?
Reply
#3
I think the developers are in a great hurry to fix such kind of issues before the release / feature freeze of XBMC Frodo.
So there will be not so much help at the moment. Another possibility would be to put this bug into trac.xbmc.org.
Reply



Logout Mark Read Team Forum Stats Members Help
"Start Recording" not changing to "Stop Recording"1
This forum uses Lukasz Tkacz MyBB addons.