Tvheadend 3.2 beta
#16
(2012-10-01, 21:46)adamsutton Wrote: curl XMLTV_URL | nc -U PATH

where XMLTV_URL is the link you posted above and PATH is the path noted from the EPG grab config tab. Also netcat has a couple of variants which mean the -U can sometimes be -u. So might need to check the netcat manpage.

Thanks Adam, this worked great on my Ubuntu 12.04 x86_64.
I am now trying to do the same on my Synology NAS (Marvel Kirkwood ARM SoC), but I only have access to netcat - 1.10pl32-5 where "-U" is an invalid option. "-u" does not seem related to Unix Sockets, so perhaps you are aware of another method?

nc: invalid option -- U
nc -h for help
PYV-DiskStation> nc -h
[v1.10]
connect to somewhere: nc [-options] hostname port[s] [ports] ...
listen for inbound: nc -l -p port [-options] [hostname] [port]
options:
-c shell commands as `-e'; use /bin/sh to exec [dangerous!!]
-e filename program to exec after connect [dangerous!!]
-b allow broadcasts
-g gateway source-routing hop point[s], up to 8
-G num source-routing pointer: 4, 8, 12, ...
-h this cruft
-i secs delay interval for lines sent, ports scanned
-k set keepalive option on socket
-l listen mode, for inbound connects
-n numeric-only IP addresses, no DNS
-o file hex dump of traffic
-p port local port number
-r randomize local and remote ports
-q secs quit after EOF on stdin and delay of secs
-s addr local source address
-t answer TELNET negotiation
-u UDP mode
-v verbose [use twice to be more verbose]
-w secs timeout for connects and final net reads
-x tos set Type Of Service
-z zero-I/O mode [used for scanning]
port numbers can be individual or ranges: lo-hi [inclusive];
hyphens in port names must be backslash escaped (e.g. 'ftp\-data').
Reply
#17
Do I need to install the tvheadend-dbg package as well or will the standard tvheadend one suffice?
Reply
#18
Mmmm i have build HTS Tvheadend 3.3.7.gbe6c0, is that the latest or has my system somewhere acquired this from somewhere else ?
-= My Media Centre =-
ACER Revo R3610 | x2 1.5TB WD Caviar Green SATA Hard Drives (WD15EADS) | x2 2.0TB WD Caviar Green SATA Hard Drive ( WD15EARS ) | 3.5in Black eSATA USB Trayless SATA External Hard Drive Enclosure | Emprex 3009URF Wireless MCE Remote Control | XBMCLive Dharma Beta1
Reply
#19
@pvautrin as you point out it looks like your version of netcat does not support domain sockets Sad do you have python available on the synology? maybe I could provide a small python script that will perform the same function. I have considered changing the interface to something simpler like a pipe or more flexible like a TCP socket. However I've thus far avoided this as both have potential issues.

@PANiCnz the -dbg package includes the debugging symbols, its only necessary should you need to submit a crash report. I'd say you're fine to leave it off unless you experience problems and need to provide feedback to the developers.

@danz0l 3.3.7 is the latest development version (or was, I think it might be 3.3.10 now). I have another PPA (tvheadend-unstable) which contains development versions, but last entry there was 3.3.8. I believe the current beta release should be labelled 3.1.732, though that will change tomorrow as I'll do another beta to pick up the few bug fixes that have been applied in the last week.

You may have to force an update to get it to effectively downgrade to the beta build or uninstall and re-install (though if you do that back up your config, as I seem to remember it caused me some minor issues). Alternatively if it works use it, at the moment there is almost no difference between the dev releases and the betas as I'm working on some longer term stuff offline.

Adam
Reply
#20
Mmmm not sure how to downgrade adam ? Not getting any genres in the OTA for freeview or freesat and although i've manually added the mux for channel 5 in freesat i'm not getting a scan to service so i can map them.

How do i downgrade to the beta and keep all my data ?

Just to follow up i am definitely having issues saving a mux. Its there but as soon as I reboot its gone. I added the following

Frequency 10964000
Polarization H
Symbol Rate 22000000
FEC 5/6
QPSK

To try and get the freesat channel 5, channel 5+1 and 5USA channels but its not finding them, nor is it saving the mux on reboot. How weird.
-= My Media Centre =-
ACER Revo R3610 | x2 1.5TB WD Caviar Green SATA Hard Drives (WD15EADS) | x2 2.0TB WD Caviar Green SATA Hard Drive ( WD15EARS ) | 3.5in Black eSATA USB Trayless SATA External Hard Drive Enclosure | Emprex 3009URF Wireless MCE Remote Control | XBMCLive Dharma Beta1
Reply
#21
Scratch that, MUX held after reboot this time and now i have all the channel 5's etc. How weird Smile
-= My Media Centre =-
ACER Revo R3610 | x2 1.5TB WD Caviar Green SATA Hard Drives (WD15EADS) | x2 2.0TB WD Caviar Green SATA Hard Drive ( WD15EARS ) | 3.5in Black eSATA USB Trayless SATA External Hard Drive Enclosure | Emprex 3009URF Wireless MCE Remote Control | XBMCLive Dharma Beta1
Reply
#22
@danz0l, there is actually a bug that can cause C5 to not be received, unfortunately fix it is not trivial so it won't get fixed just yet, but there is a workaround. This can affect other channels as well, but on Freesat, this is the only one I've noticed.

I personally still haven't sorted my system out to receive C5 as I never watch it.
Reply
#23
(2012-10-04, 10:47)adamsutton Wrote: @pvautrin as you point out it looks like your version of netcat does not support domain sockets Sad do you have python available on the synology? maybe I could provide a small python script that will perform the same function. I have considered changing the interface to something simpler like a pipe or more flexible like a TCP socket. However I've thus far avoided this as both have potential issues.

Yes ,Python version 2.7.2-006 is available from Synology DSM 4.1 Package Center.
I have little knowledge of Python though, so any help is appreciated
Cheers,
PY
Reply
#24
(2012-10-04, 15:31)adamsutton Wrote: @danz0l, there is actually a bug that can cause C5 to not be received, unfortunately fix it is not trivial so it won't get fixed just yet, but there is a workaround. This can affect other channels as well, but on Freesat, this is the only one I've noticed.

I personally still haven't sorted my system out to receive C5 as I never watch it.

It held on reboot adam and i now have all the channel 5 channels. Weird as it was it seems to have corrected itself now,

-= My Media Centre =-
ACER Revo R3610 | x2 1.5TB WD Caviar Green SATA Hard Drives (WD15EADS) | x2 2.0TB WD Caviar Green SATA Hard Drive ( WD15EARS ) | 3.5in Black eSATA USB Trayless SATA External Hard Drive Enclosure | Emprex 3009URF Wireless MCE Remote Control | XBMCLive Dharma Beta1
Reply
#25
Hey guys, sorry to clog this up with EPG stuff, but i can't get the EPG to populate using Data Direct. It gives me...

Oct 08 21:17:12 pyepg: no output detected
Oct 08 21:17:12 /usr/bin/tv_grab_na_dd: grab returned no data

I have everything kosher with Schedules Direct and have run the command "/usr/bin/tv_grab_na_dd --configure" to set it up. Any ideas? Can provide additional information...
Reply
#26
The SD script should certainly work, indeed I specifically added support for dd_progid for a user of SD.

The "pyepg: no output detected" indicates that nothing was output by the script (ignore the "pyepg" that's a printing error).

Did you definitely configure the script as the right user? You must configure it as the user that will be running TVH.

If you did the above have you tried running the script manually and checking it does indeed output something.
Reply
#27
(2012-10-09, 11:03)adamsutton Wrote: The SD script should certainly work, indeed I specifically added support for dd_progid for a user of SD.

The "pyepg: no output detected" indicates that nothing was output by the script (ignore the "pyepg" that's a printing error).

Did you definitely configure the script as the right user? You must configure it as the user that will be running TVH.

If you did the above have you tried running the script manually and checking it does indeed output something.

adamsutton: thx for the help. I ran the command "/usr/bin/tv_grab_na_dd --configure" as the same user that I am logged into XBMC as and also the same user that I have in tvheadend's configuration page. If that makes sense...?
Reply
#28
Is it possible in this release to manually specify the LNB settings, e.g. LO/F, HI/F, and 22khz/voltage ?

Previously I have had to edit the source for NZ settings and then compile.
Reply
#29
adamsutton: is there a proper place to report bugs? I am trying to work out the situation I mentioned above in post #25. I purged all tvheadend files and re-installed but I am getting the same error. That way I can provide any information I can to help.
Reply
#30
Hi! I like the progress of TVH. I'd like to ask you if it is possible to use it with Ubuntu 8.04.4 LTS (Hardy Heron) and build also packages for it?


TNX
Reply



Logout Mark Read Team Forum Stats Members Help
Tvheadend 3.2 beta0
This forum uses Lukasz Tkacz MyBB addons.