•   
  • 1
  • 28
  • 29
  • 30(current)
  • 31
  • 32
  • 49
  •   
[FRODO release] Skin Widgets
(2012-11-17, 22:21)Hitcher Wrote: I've got an idea for the home screen and wondered whether you'd consider, if possible, adding RecommendedMovie.%d.NumItems, RecommendedEpisode.%d.NumItems, RecommendedMusicVideo.%d.NumItems, and RecommendedAlbum.%d.NumItems?

Thanks.

(2012-11-17, 22:25)Martijn Wrote: As in total in library or just the list?
Total in library will require additional queries which will slow it down. No idea how much

(2012-11-17, 23:18)Hitcher Wrote: No, just the list so I can show the number of unfinished movies, recommended episodes, etc.

ie 12 Unfinished Movies, 7 Ongoing TV Shows, etc.

It's no biggie if it slows things down too much.

Thanks.

Any chance this could still be added?

Thanks.
Reply
That's a very easy addition... can you test my fork? If it works fine, I can do a pull request.
Image
Reply
i already sent a PR for that 3 months back (would need to be updated)
https://github.com/XBMC-Addons/service.s...ets/pull/8
Donate: https://kodi.tv/contribute/donate (foundation), 146Gr48FqHM7TPB9q33HHv6uWpgQqdz1yk (BTC personal)
Estuary: Kodis new default skin - ExtendedInfo Script - KodiDevKit
Reply
(2013-04-23, 18:07)`Black Wrote: That's a very easy addition... can you test my fork? If it works fine, I can do a pull request.

Works perfectly, thanks.

Saves a lot of visible conditions!
Reply
(2013-04-15, 20:51)Manos Wrote: I hope this is in the right thread. It's been a few days since this occurred: when I play something through the widget (movie or tv show) it isn't removed after it is finished from the widget as it used to do. I have the "update each time you enter the home screen" option enabled. It is only after I update the library that the watched items get removed from the widgets. Is it a skin issue (aeon nox)?

Hi, Since this is my first message on this board I'd like to start with a big thanks to all the people contributing to this fantastic program with skins and addons. Very impressive!
The skin widget is amazing and was working great until a week ago or so for me. Since then I've been experiencing the same thing as Manos. Except that for me the status of the movie in question isnt being changed even if I update the library. For example, if I watch a movie and stop watching after lets say 40 percent and resume watching the next day, then when the movie comes to an end it should be removed from the widget and marked watched right ? It´s not for me. Its actually still says 40 percent partially watched. However it has been marked watched if I enter the movie library. The only way for me to have it removed from the widget is to actually delete the file from the library. Then update library and then move it back and update again and then have it marked as watched.

Is this a known bug or is it something on my side that can be done to have it working again?
cant really remember that I've changed anything to have it change behavior like this.
Thanks!

I´m running Frodo 12.1 witch Ace skin on a windows 7 machine.
Reply
Hi, thanks for this useful widget!

Just wondering, is there any chance to implement 'high-rated movie recommendations' on this widget ?
Sorta like random items but it's filtered based on the ratings..

e.g : filter only movies with ratings > 6.0 then randomize it...

Or is it implemented already ?
thanks
Reply
No and I don't think it's necessary because you can have it with a smart playlist + script.randomandlastitems.
Image
Reply
Just noticed:

*Episode.%d.mpaa

is only avaiable for RecommendedEpisode but not for RecentEpisode and RandomEpisode ...

Can someone confirm?

Using version 0.0.25 with XBMC 12.1
Reply
Yes confirmed because with the current implementation it's not possible to get mpaa without an extra request per episode.
Image
Reply
Thanx Black
Reply
folks, I'm having issues where addons are sometimes slow to start (taking 2 minutes to open) and the skin widgets service is possibly the cause.

I'm using openelec 3.0.3 x64 on an acer revo 3610 (have been having this issue since last year at least). Other things to note are that i use mysql and samba shares, and have a big library. This is a client pc, main xbmc runs on a headless pc.


I went through the following steps:

1) Installed Refocus Big skin and rebooted (this install skin.widgets and a few other scripts). When it restarted, i tried opening the iplayer addon which opened ok. Then i tried to open the Irish tv addon which took about 2 minutes 2 open.

Log: http://xbmclogs.com/show.php?id=20082

2) I then deleted the next show aired script and rebooted. When it restarted, i tried opening the iplayer addon, and it took about 2 minutes to open.

Log: http://xbmclogs.com/show.php?id=20108

3) I then deleted the randomlastitems script and rebooted. When it restarted, i tried opening the iplayer addon, and it took about 2 minutes to open.

Log: http://xbmclogs.com/show.php?id=20111

4) I then deleted the skin.widgets service and rebooted. When it restarted, i tried opening the iplayer addon, and it opened straight away. Rebooted about 5 times, and iplayer and the other addons i tried opened straight away.

Log: http://xbmclogs.com/show.php?id=20113


5) Reinstall Refocus Big (and in turn its dependencies), deleted skin.widgets service and rebooted. When it restarted, i tried opening the iplayer addon, and it opened straight away. Rebooted about 5 times, and iplayer and the other addons i tried opened straight away.

Log: http://xbmclogs.com/show.php?id=20119

Note, I have recentlyadded set to 100 instead of 10 on this client pc. And changed it back to 10 following a suggestion on IRC, unfortunately this made no difference.


When the addons are slow to open and eventually do open, they work fine for a while but if i go back to them later in an hour or so, they are slow again to open.

Scroll down towards the end of each log for the opening of the addons.


Any suggestions as to what might be causing issues for the skin widgets service?

Edit: from log 3 line 861, must be due to the amount of tv episodes! Wink

15:49:09 T:139864761595648 DEBUG: RunQuery took 118872 ms for 324 items query: SELECT * FROM tvshowview WHERE (tvshowview.idShow IN (select tvshowview.idShow from tvshowview where (watchedcount > 0 AND watchedcount < totalCount) OR (watchedcount = 0 AND tvshowview.idShow IN (select episodeview.idShow from episodeview WHERE episodeview.idShow = tvshowview.idShow AND episodeview.resumeTimeInSeconds > 0))))


thread here has the same issue:
http://forum.xbmc.org/showthread.php?tid=148657
Reply
The episodes query for ongoing tv shows is the problematic one and takes about 120 seconds on your system... I can't tell you why but since you are using a mysql db, I bet it has something to do with it although it should be much faster with frodo and take seconds instead of minutes (which it did with Eden and mysql databases).
Image
Reply
yes just spotted that and had updated my post just after you posted. This time equates to the time delay in addons opening.

looks like this person has same issue - http://forum.xbmc.org/showthread.php?tid=162370.
Reply
I've checked a few skins to see how they do this, but not having any luck...

When an episode is played and the user returns to the home screen, the 'Recommeded' episodes are not updated, this only seems to happen on library updates. Is there a simple way to have the script re-run when returning to the home screen?
Image
Reply
That is a problem if "adjust display refresh rate to match video" is enabled. You can't do anything about it for now if you prefer smooth playback over a fully working recommended episodes section.
Image
Reply
  •   
  • 1
  • 28
  • 29
  • 30(current)
  • 31
  • 32
  • 49
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[FRODO release] Skin Widgets58
This forum uses Lukasz Tkacz MyBB addons.