Release Load a configurable default profile on startup of XBMC
#1
Lightbulb 
For XBMC 13.x (Gotham) use Switch Profile When Idle


When using multiple profiles with the login screen disabled, XBMC will automatically login the user profile that was logged in during the last session.

This add-on allows you to override this behaviour and set a specific default profile which will always be used during login. When XBMC quits this add-on will overwrite the <lastloaded> value in profiles.xml with the profile id of the configured default profile.
Optionally, you can configure the add-on to either switch to the default profile or logout and show the login screen when XBMC has been idle for a configurable time.

Please be aware that this is a workaround. When XBMC crashes then during the next startup of XBMC a profile other than the configured default profile may be visible for a short moment. The add-on then automatically logs out this other profile and logs in the configured default profile.
If you use password protection on one or more of your profiles, then make sure that you lock the settings for all profiles using the Master Lock.


Installation and Configuration:
(instructions based on Confluence skin)

  1. Download the zip (see location below).
  2. If you are not logged in into XBMC using the Master user profile, then logout and login as Master user.
  3. Go to Settings->Add-ons and choose 'Install from zip file'.
  4. Lookup the downloaded zip file and press the 'OK'-button.
  5. Restart XBMC.
  6. Login using the Master user profile.
  7. Go to Settings->Add-ons->Installed Add-ons (Eden) or Enabled Add-ons (Frodo / Pre-Gotham) -> Services -> Load Default Profile Service
  8. Press the 'Configure'-button.
  9. Enter the default profile name you want to use when starting XBMC. Note that this field is case sensitive!
  10. Restart XBMC. XBMC should now log in using the configured default profile.


Add-on name: service.defaultprofile
Current version: v0.3.1
Download: service.defaultprofile-0.3.1.zip
Compatibility: Eden / Frodo

Changelog:
-------------
v0.3.1
- Fix dim screensaver bug

v0.3.0
- Added option to switch to default profile / logoff after resuming

v0.2.2
- Added option to automatically switch to default profile when idle (when not using login screen)
- Added option to automatically logout when idle (when using login screen)

v0.1.0
- Initial Release
Reply
#2
Love it, thank you!
Reply
#3
I'm glad that I'm not the only one using it Wink
Reply
#4
I also just stumbled across this. Thanks, very helpful.
Reply
#5
I have been using this for a while now. Very helpful to keep our 5 and 3 year old children out of the tv shows we would rather them not watch - Especially the auto switch feature! Thankyou!
Reply
#6
Thanks for your feedback. Good to hear that you like it. The auto switch feature wasn't actually my idea, but I stumbled on it in this thread Smile
Reply
#7
Big Grin 
Fantastic add-on, big thanks leechguy! Cool
Reply
#8
Love it.. I do however have an issue with the Idle Timeout not working. It always logs the user out if it is idle for 1 minute. I have it set at 15, and have moved it to 20 minutes.. but it still just logs out the profile after 1 min idle.

Thanks for the awesome plugin..
Reply
#9
I will check the Idle Timeout function to see what's going on there. I don't use that part myself, I only use the default profile feature (which is no longer required for Gotham Smile)
Reply
#10
I created two profiles: Master (with code), Kids (no code)
When I set the default profile = Kids and first launch XBMC, it prompts me for a code 3 times after which it sails failed attempts exceeded.

Not sure what I've done wrong but Kids has no code required so I'm confused.
| Frodo| Windows7 64b | Acer Aspire Revo 3610 3GB |
| Frodo | PeppermintOS 3 | Dell Dimension 3100 | 2GB |
Reply
#11
@dethknite Which version of XBMC do you use? I'm on a nightly build and for me it logs out after the configured amount of minutes.

@emagin The problem is the two profiles. I need to do some more testing with two profiles to explain what's wrong (I don't remember). If you setup 3 profiles, Master user (with code), Parents (with code) and Kids (no code) and set the default profile to Kids, then you should be fine.
Reply
#12
(2013-05-09, 16:14)emagin Wrote: I created two profiles: Master (with code), Kids (no code)
When I set the default profile = Kids and first launch XBMC, it prompts me for a code 3 times after which it sails failed attempts exceeded.

Not sure what I've done wrong but Kids has no code required so I'm confused.

I don't believe it is this script. I had the same issue and it was driving me nuts until I figured it out. On the kids profile I had locked down the scripts folder so they couldn't access it, but the skin had a bunch of built in scripts that it was trying to run at load, and so it need the master lock code. Allow access to the scripts folder and it should log right in.

Hope this helps.
Reply
#13
Just come across this - just what I was looking for. Installed in conjunction with xbmc launcher -working fine thank you great add on
Reply
#14
Great addon, serves as a good work around for parental controls.

Can get it to resume to the profile set as default, it just resumes to the last profile logged in? Any suggestions?
Reply
#15
Thank you very much! This addon is perfect for me and it works like a charm Wink
Thanks again Smile
Reply
 
Thread Rating:
  • 1 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Load a configurable default profile on startup of XBMC41