Tvheadend 3.2
#16
Us Kiwi's really need MHEG5 support.

Please, please, please add this for 3.4 Smile

Reply
#17
One feature that would be great to have is the option to export/import mapped channels. This is really annoying when there is a new version of tvheadend and you have to reorganize everything again.
Reply
#18
Upgraded from 3.2 beta (from your ppa, 3.1.769~g4303374~precise) to 3.2 (from the stable ppa, 3.2~precise). Wiped my ~/hts/.hts-directory clean! Lost all my configuration.

And of course, this system which is quite well backed up.. but not this directory!

So be careful, always backup your system! Lesson learnt. Again.
Reply
#19
(2012-10-28, 12:55)illiac4 Wrote: Is version 3.2 able to use CrystalHD card for HD decoding?

I kept getting crashes when I ran tvheadend directly on ATV1+BCHD, but when it did work it would stutter on most HD channels, but the codec info window shows it using the BCHD. However, I could record content and play it back later and it played fine.

I've since gotten Tvheadend working on a Pogoplug (which currently run for $20 in the US with free shipping), and now all HD channels play on the ATV1+BCHD. However, whenever something is on screen, like the player controls or EPG, it will stutter. It has little to no issues when it's just the video on screen.

So I think the answer here is, yes the BCHD is used for HD decoding, but there's a bottle neck somewhere else when both XBMC and TVheadend are used on the same box such as the ATV1 (I think it's something like a Pentium M processor and 256MB of RAM). I'm interested in seeing how something like a Raspberry Pi handles the task (I'm sure someone has tried this and posted about it, but I haven't really looked yet for those posts).

That being said, this is using a PVR build based on Eden for Crystalbuntu, so it's possible that a Frodo build will improve things and help the bottleneck.
Reply
#20
(2012-10-27, 00:01)Prof Yaffle Wrote: @beschmid - if you switch debugging on (in the web interface, small cog in the bottom right - click the up arrow if you can't see it), you'll get a debug message like this one when a recording starts:

Code:
Oct 23 21:58:30 revo tvheadend[9621]: Service: Subscription "DVR: Fresh Meat": Adding adapter "_dev_dvb_adapter1_Conexant_CX24116_CX2411810714000_H" for service "Conexant CX24116/CX24118/ASTRA: 10,714,000 kHz Horizontal (No satconf)/Channel 4"
Oct 23 21:58:31 revo tvheadend[9621]: dvr: /home/xbmc/Recordings/Fresh Meat.2012-10-23.22-00.mkv from adapter: "Conexant CX24116/CX24118", network: "ASTRA", mux: "ASTRA: 10,714,000 kHz Horizontal (No satconf)", provider: "BSkyB", service: "Channel 4"
Oct 23 21:58:31 revo tvheadend[9621]: dvr:  # type                 lang resolution       samplerate channels
Oct 23 21:58:31 revo tvheadend[9621]: dvr:  1 MPEG2VIDEO                704 x 576
Oct 23 21:58:31 revo tvheadend[9621]: dvr:  2 MPEG2AUDIO           eng                   48000      2
Oct 23 21:58:31 revo tvheadend[9621]: dvr:  3 TELETEXT             eng                                         <disabled, no valid input>
Oct 23 21:58:31 revo tvheadend[9621]: dvr:  4 DVBSUB               eng          
Oct 23 21:58:31 revo tvheadend[9621]: dvr:  5 TEXTSUB              eng


(this is lifted straight from my log, so has more than you need). You can see where it's putting the file, and the file name, right at the top, in the second line - in this case, /home/xbmc/Recordings/Fresh Meat.2012-10-23.22-00.mkv

You can also switch debugging-to-syslog on by changing the file /etc/default/tvheadend - look for the lines:

Code:
# TVH_DEBUG
#   if set to 1 will output debug to syslog
TVH_DEBUG=0

and change the last one to

Code:
# TVH_DEBUG
#   if set to 1 will output debug to syslog
TVH_DEBUG=1

... and all of your debug messages will then end up in /var/log/syslog. See what that shows you versus what you're expecting.

@Prof Yaffle: sorry for the delay and thank you for your response. Here is my debug message:
Quote:Nov 04 09:51:41 dvr: "Music and the Spoken Word" on "24/7" starting at 2012-11-04 09:29:00, scheduled for recording by "brad"
Nov 04 09:51:42 dvr: "Music and the Spoken Word" on "24/7" recorder starting
Nov 04 09:51:42 subscription: "DVR: Music and the Spoken Word" subscribing on "24/7", weight: 300, adapter: "Samsung S5H1409 QAM/8VSB Frontend", network: "", mux: "177,028 kHz", provider: "", service: "24/7-SD", quality: 100
Nov 04 09:51:42 TS: Samsung S5H1409 QAM/8VSB Frontend/177,028 kHz/24/7-SD: Transport error indicator
Nov 04 09:51:42 TS: Samsung S5H1409 QAM/8VSB Frontend/177,028 kHz/24/7-SD: MPEG2VIDEO @ #65: Continuity counter error
Nov 04 09:51:44 dvr: Recording unable to start: "Music and the Spoken Word": No descrambler
Nov 04 09:51:47 dvr: Unable to create directory "/home/brad/DVR/Music and the Spoken Word" -- Permission denied
Nov 04 09:51:47 dvr: Recording error: "Music and the Spoken Word": Unable to create directories
Reply
#21
My guess is that the user hts (under which tvhheadend is running) doesn't have write permissions to the directory /home/brad/DVR - hence the error message you're getting.

chmod that directory to 0777 (i.e. universally-writable to everyone) and then try again. Or, move the directory to somewhere where the hts user can write, e.g. /home/hts/DVR.
Reply
#22
@Novin, With regard to the lost config, I've never seen that before. Personally all my recent upgrades (to my live system version) have been via my PPA (since its always a good idea that I test these things before letting you guys loose on them Wink ). I have not experienced any loss of configuration and certainly the TVH DEB scripts shouldn't do anything to the existing (~hts/.hts) configuration.

Backing up before an upgrade is always recommended just in case something goes wrong, but this sounds like something very specific to your system. You sure it didn't simply overwrite some init script based config you had? and simply switched to using a different user account?

@beschmid I have to agree with Prof Yaffle, looks like you're trying to use a directory for which the user running tvh does not have permission to write.

Adam
Reply
#23
@Prof Yaffle & adamsutton: that worked guys. I changed permissions on the directory that I am saving my recording to 0777 and it works great. Thank you for you help.
Reply
#24
Hello,

I'm using a XBMCBuntu eden on a Xtreamer media center (ion2). I'm happy to see that TVHeadend (2.12) was pre-integrated with this version because I already use it with my previous installation.

I discover that a new version of TvHeadend is available (3.2) and I push it yesterday using the adam's PPA.

But unfortunately, tvheadend crash each time 20 seconds after the boot and I have to launch it again manually using a ssh. Because I shut down each day the device, I have to find a solution.

Have you an "always working" solution with XBMCBuntu ? Must I deal with init.d service order to fix it ?

My DVB device is USB.

Regards
Reply
#25
tvheadend starts first time, every time on my XBMCbuntu. Are you getting anything in any log file, from the operating system or the tvheadend process itself?
Reply
#26
Hi All,

I am running HTS Tvheadend 3.1.694. I am having problems with the EPG. I am using openTV :Sky UK. I believe it is picking up some information, but I am seeing big gaps in the schedule, i.e it is saturday 13:40, the first item in the EPG tab is sunday 00:10, Even with the sunday 00:10 item being the first item it is not a full day. it only goes untill lunch time, then displays monday at 18:00.

I have tried deleteing epgdb.v2 and restarting, It looks like it is processes the openTV sky uk, but it displays the same issues.

I am running Fedora 14, The rest of the TvHeadend functions are fine.

What is the best way to debug this?
Reply
#27
Hi guys!

Does anyone have an idea to cure my problem:
I am using a server - client machine arhitecture. TVheadend runs on a separate server.
If I am using the clients with wired network connection, everything works fine with no problem at all.
But if I use xbmc client over a 300MBps Wifi connection, I have serious lags, bufferings, stops, etc with XBMC.

Strange is, that my wifi connection is excellent. I mean I can transfer up to 16 MegaBYTES/s that is over the speed of a 100Mbps LAN connection.
And streaming of Bluray movies goes without a problem. Also the recorded material plays perfect, with the samee wifi connection. Only the live stream has this problem.

Anyone has any idea what can be done. Is there any cache working for xbmc with htsp streams ?

I am using :
TVHeadend Server 3.2.18
XBMC and PVR addons built from GIT today.

Thanks in advance,
Attila
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#28
@Prof Yaffle : Thanks for your answer.

I have to check specific tvheadend logs, you're right. I just saw a line in dmesg which say that tvheadend has crashed and is respawning.
I have temporary fixed the problem by restarting the service from rc.local. It works, but I prefer knowing the root cause.

Regards
Reply
#29
@flonews - probably best to pop over to the lonelycoder forums if it's a real tvheadend issue, then - the lead developer is very active over there and is more likely to be able to help. Although go gently, we don't want to keep him away from making the software perfect, so he needs some time to actually write code as well Smile
Reply
#30
I recently installed 3.2 also, i have in the past run tvheadend as my xbmc user to avoid permission issues with recordings etc.

After installation of 3.2 i found that it had reverted to running as hts user and hence the configuration i was using was not active, but not lost.

3.2 has be converted to an upstart job, a change from the init.d script in the past where you configured the tvheaded init script with the user to run as.

Code:
DAEMON_ARGS="-f -u xbmc -g video"

With 3.2 you need to edit /etc/default/tvheadend

Code:
# TVH_USER
#   if set to "" will run as root
TVH_USER="xbmc"

# TVH_GROUP
#   if set to "" will run as root
TVH_GROUP="video"

now tvheadend runs as user "xbmc" and uses the configuration in /home/xbmc/.hts/tvheadend and alls is well in TV land again..

Hope this helps anyone running tvheadend as a different user when upgrading.
Reply



Logout Mark Read Team Forum Stats Members Help
Tvheadend 3.20
This forum uses Lukasz Tkacz MyBB addons.