How do I make additional buttons on my Panasonic remote work?
#1
I'm using Raspbmc on my RPi . It is connected through HDMI cable with my TV and my pilot is basically working, the only question I have is ... Is it possible to make these buttons work with RPi aswell ?

Image

I've read about editing / creating files in .xbmc/userdata/keymaps but... how do I find out what "code" does these buttons have ? Any help would be appriciated.
Reply
#2
(2012-11-11, 11:45)Woferon Wrote: I've read about editing / creating files in .xbmc/userdata/keymaps but... how do I find out what "code" does these buttons have ? Any help would be appriciated.

You can find out buttons and codes if you enable xbmc debugging. From xbmc log you will see what button is pressed.
Reply
#3
Well, that might be a stupid question but... How exacly do I turn debug mode on ? In settings under "debug" menu I only have "screenshot folder" option avaiable ...
Reply
#4
I have the same question. Very similar remote.
Reply
#5
Debugging is found at Settings > System > Debugging

I'm not sure that will actually help you. It may do, if it doesn't this is what I believe the correct steps would be:

First find out if those buttons are supported by CEC . If they are not you will not be able to map them. If they are you can then worry about working out how to map them.

To find out if they work with the CEC you are going to have to:
1) Disable the CEC adapter in XBMC (this is required if using OpenElec, not sure about Raspbmc). Disable the CEC in XBMC via:
Settings > System > input devices > peripheral > disable the adapter

this will allow you to launch the CEC-client from the command line (if you don't do this it will complain about being locked)

2) SSH into the terminal and run the cec-client (http://libcec.pulse-eight.com/faq for help on this). Now press any of those buttons. If they cause the terminal to spew out some output it should mean they can be mapped.

3) map the relevant keys a xml file in the userdata folder

EDIT: I'm not sure if step 1 is required. It would be if you were using a pulse eight USB CEC adapter. As this functionality is build into the PI and I have not tested it, I dont know if it is required.
Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
Reply
#6
"Settings > System > Debugging " only has "screenshot folder" in it. nothing else.
Reply
#7
It doesn't look like this? Settings/System/Debugging (wiki)?
Reply
#8
(2012-11-12, 19:03)Ned Scott Wrote: It doesn't look like this? Settings/System/Debugging (wiki)?
No. Raspbmc adds:
Code:
<loglevel hide="true">0</loglevel>
to advancedsettings.xml which stops that option showing up.

However I believe the CEC comes out in log whatever debug settings you have, so:
Code:
tail .xbmc/temp/xbmc.log
after pressing a key should indicate if CEC saw it, and what the key was.
Reply
#9
no cec output in my log.
Reply
#10
In that case, edit your advancedsettings.xml file (in the userdata (wiki) folder) and remove the loglevel line so that we get that back in the GUI. There's no reason for that to be there.
Reply
#11
(2012-11-12, 20:51)popcornmix Wrote:
(2012-11-12, 19:03)Ned Scott Wrote: It doesn't look like this? Settings/System/Debugging (wiki)?
No. Raspbmc adds:
Code:
<loglevel hide="true">0</loglevel>
to advancedsettings.xml which stops that option showing up.

However I believe the CEC comes out in log whatever debug settings you have, so:
Code:
tail .xbmc/temp/xbmc.log
after pressing a key should indicate if CEC saw it, and what the key was.

That's just plain stupid they add that
no debug log no cec log
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#12
(2012-11-12, 20:51)popcornmix Wrote:
(2012-11-12, 19:03)Ned Scott Wrote: It doesn't look like this? Settings/System/Debugging (wiki)?
No. Raspbmc adds:
Code:
<loglevel hide="true">0</loglevel>
to advancedsettings.xml which stops that option showing up.

However I believe the CEC comes out in log whatever debug settings you have, so:
Code:
tail .xbmc/temp/xbmc.log
after pressing a key should indicate if CEC saw it, and what the key was.

Pretty dumb what raspbmc is doing there.
Reply
#13
no advancedsettings.xml in ~/.xbmc/userdata (or the raspbmc default installation)
Reply
#14
You can find it in /opt/xbmc-bcm/xbmc-bin/share/xbmc/system/advancedsettings.xml
or, if you are using a nightly: /home/pi/.xbmc-current/xbmc-bin/share/xbmc/system/advancedsettings.xml

I also don't understand why this option is not enabled be default, not even in nightly.
Reply
#15
Thank you, you are absolutely right.
Maybe its a performance issue, i dont know.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How do I make additional buttons on my Panasonic remote work?00