•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 29
  •   
Philips hue integration or add-on
It needs RenderCapture to be implemented.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2015-02-12, 14:22)fritsch Wrote: It needs RenderCapture to be implemented.

Who are you talking to? about what? Smile
Reply
which Nuc do you have ? My zotac ci540 (i5) works fine (software decoding), but for only 1 TV channel, it's not smooth

but for all other 1080p video, even a 15 Gb MKV, it's fine
Reply
I'm using this with my i5 Haswell NUC, with Helix 14.1. Every time I reboot I have to disable and re-enable the plugin for it to work!
Reply
(2015-02-06, 14:18)fabd Wrote:
(2015-02-03, 21:52)hardyt Wrote: Here's a solution for some people who cannot get this to work.

Discussion: this plugin requires the lights to be in an {"on":true} state before playback begins. The plugin is also not nice in that it does not restore the lights to their pre-video settings.

Impact: My lights are normally off, so the plugin appeared to not work. The plugin would also make the lights garishly bright, washed out green at the stop of the video.

Suggested improvement: I made some modifications so it now functions in my particular case. The changes begin with #th comments. https://github.com/hardyt/script.xbmc.hue.ambilight. Ambilight works when I play video. The lights are returned to their original state on stop, pause, or end. I may take the time to configure this as an option, but probably not anytime soon.

Just looking at the code, if i understand you, you add a check to verify if the light are ON or not ? If, not, you switch it on. That's it ?

To use your modification, we just have to replace lib/tools.py ?

Another question : can someone explain me the advanced function ? I'm french and don't really understand some off these function

Replace both tools.py and default.py.

The modification adds:
-check and save initial light state
-ensure lights are on
-on stop/pause/end the lights go to the initial light state

Example 1: Lights are off, movie plays, plugin functions (not tested with theater mode), movie ends, lights off
Example 2: Lights red, movie plays, plugin functions, movie ends, lights go red
Reply
(2015-02-11, 12:53)Oebel Wrote: Thank you fabd & bugzilla for the input and directions.

Turns out that testing with 1 lightbulb is not smart Smile When adding all 3 to my setup, I found that the lamp ID was not correctly set in Kodi. Therefore my Kodi setup was working, but not giving the correct signal to the right lamp ID.

For other people in the future: place all 3 lightbulbs in your resp. lights and start testing from there. Bulb 1 isn't always lamp ID 1 in KODI.

Thanks people for your help. Even 1080 movies work great on my NUC.

The plugin is awesome Wink (perhaps small request: could it be possible to use Ambilight plugin for Milkdrop visuals? ) Big Grin

Thanks.

You could give my music viz plugin a shot: 217183 (thread)
There are binaries for Windows x86, Ubuntu x86, and OpenELEC on imx6. Let me know if you try it!
Reply
Sooo... I got my lightstrips today. And just one word: amazing! Smile
Currently watching the Killers live in Royal Albert Hall while writing this. I really didn't expect it to work so well. Sure, there is a small delay but I don't think it will be annoying in most scenes.

Setup was super easy, no problems so far. FHD movies in hardware mode work just fine on my HP N54L with HD6450.
Just need to properly fix it behind my TV yet so that the single LEDs are not visible.

Great work!
Reply
Hey Guys,

This add-on works on ATV2 (Kodi v14.1)?
Reply
(2015-02-25, 13:34)nitspy Wrote: Hey Guys,

This add-on works on ATV2 (Kodi v14.1)?

Nvm, its work like a charm! Wink
Reply
(2015-03-02, 19:49)nitspy Wrote:
(2015-02-25, 13:34)nitspy Wrote: Hey Guys,

This add-on works on ATV2 (Kodi v14.1)?



Nvm, its work like a charm! Wink

Which addon are you referring to? The lights on/off or the ambilight?
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
(2015-02-15, 11:36)Marshalp Wrote: I'm using this with my i5 Haswell NUC, with Helix 14.1. Every time I reboot I have to disable and re-enable the plugin for it to work!

same prob here, any workaround?
LG OLED65C8 / Denon AVR-X3200W / KEF E305+ONKYO SKH-410 / Synology DS2415+ / Logitech Harmony Companion / ZOTAC MAGNUS EN1060K (Kodi DSPlayer x64) / LightSpace HTL, DisplayCal, HCFR, Calman / i1D3 OEM Rev.B, i1PRO2 OEM Rev.E
Reply
(2015-03-02, 20:54)nickr Wrote:
(2015-03-02, 19:49)nitspy Wrote:
(2015-02-25, 13:34)nitspy Wrote: Hey Guys,

This add-on works on ATV2 (Kodi v14.1)?



Nvm, its work like a charm! Wink

Which addon are you referring to? The lights on/off or the ambilight?

Ambilight
Reply
(2015-02-11, 15:31)bugzilla Wrote:
(2015-02-11, 14:38)theSilent Wrote: Is everyone reverting back to software decoding when using the addon? My Kodi is running on a home server with a small CPU so I am depended on hardware decoding on the GPU.
i'm runing kodi 14.0 on a Minix Neo X8-H X8H Plus.
with hardware acceleration = plugin doesn't work (only teather mode, not the ambilight)
with software acceleration = plugin works (both modes), but 1080p movies are not watchable (stuttering, pixel...)

i need to see if there's a way to tweak the software acceleration, but i'd rather than leave hardware acc. in future instead of using the ambilight plugin ConfusedSadUndecided
unless, there's a workarround?

Hi, if your box is S802 based chipset, it's basically the same issue with Hyperion addon as reported here : http://forum.kodi.tv/showthread.php?tid=219563

More people reporting it may be helpful.
Reply
Hey guys.

running kodi 14 on win7 64 bit os

I really followed the entire thread (read everything) but i still cant understand why i get "scrippt error" when i start KODI and hue script wont work :/

Autodetect bridge did not work, so i manually entered ip to bridge and the username created via "guide to create user"
------------------------------------------------------------------------------------
"xbmc script error hue"

19:45:02 T:2988 NOTICE: XBMC Hue: DEBUG creating Light instances
19:45:05 T:2988 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'requests.exceptions.ConnectionError'>
Error Contents: ('Connection aborted.', gaierror(11004, 'getaddrinfo failed'))
Traceback (most recent call last):
--------------------------------------------------------------------------------------
very grateful for some insights here. help
Reply
i solved it by adding my hue ip in .py file.

but it dims down to puickly. dim transition is nice when the movie stops. (10sec dim transition).
but how to make that slow fade also apply to the dim down transition?
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 29
  •   



Logout Mark Read Team Forum Stats Members Help
Philips hue integration or add-on0
This forum uses Lukasz Tkacz MyBB addons.