Linux [Frodo] Front contains rear channel
#1
Hi

I'm rugging Frodo Beta1 with Ubuntu12. Audio chip is a HDA ALC888 with analog 5.1 output.
speaker-test -c 6 -D surround51 -t wav
is running fine, I get correct output to all of my speakers.

I have a vob-file with ac3 encoded 5.1 sound. The problem is the rear channels are mapped to front and rear channel.
Center and LFE are fine. Also signal from front channels isn't mapped to rear channels.
In xbmc output is set to analog 5.1, Stereo to all speakers is disabled.
I use pulseaudio as playback device in xbmc

Any idea why the rear channel is also outputted to the front channels?
Reply
#2
The matter of apparently incorrect mapping is in a PR for AE that is not going anywhere atm and something else that maybe replated

https://github.com/xbmc/xbmc/pull/1784 << Also good

https://github.com/xbmc/xbmc/pull/1490 << thumbs up eventually

Audio Devs are busy building toys for xmas at north pole... So nothing is happening until the bugs are well inserted in Frodo. hehe

uNi

Reply
#3
lol - i will spread this statement to the team Smile
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#4
@ Memphiz

Now you getting me into trouble. Image
* un1versal prepares for a lump of coal.

uNi

Reply
#5
Thank you for your answer. Although I don't unserstand most of the used acronyms the linked thread was very helpfull to me.

For me it's broken the way it's implemented and I have some videos with rotary sound effects which are very strange now.
It would be great to have an option to disable the new behavior.
For me it's a bug and not a feature.
Reply
#6
Nobody doubts that ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#7
YOu cant disable AE, its built in and without you wouldnt get any sound in xbmc.

add streamsilence to your advancedsettings.xml to see if it helps.

http://wiki.xbmc.org/index.php?title=Aud...d_settings

Alternatively compile with the patches above and see.

uNi

Reply



Logout Mark Read Team Forum Stats Members Help
[Frodo] Front contains rear channel0
This forum uses Lukasz Tkacz MyBB addons.