• 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 12
Timeshift Support
i'm using HTS Tvheadend 3.3.216~g6755147-dirty
works ok.
Just a few general comments.

1. Timeshift buffer is currently a permanent ring buffer upto the specified limits. Much like a standard pvr. I'm going to eventually add an option for pause only.

2. Performance of timeshift seeking will be slightly quicker with local and/or SSD drive. But for most use cases it'll be negligible.

3. HD content is about 1-2MBytes per second. So 4-5GBytes an hour typically. So base space requirements on that.

4. Stuttering playback can occur depending on video playback settings. I'm still trying to figure optimal for my own machines.

5. There are definitely issues with playback after fd/rwd. Not sure where the fault lies at this stage.

6. I wouldn't call the code stable, but since its starting to be used and doesn't seem to be doing too badly I think I may merge to master in the next few weeks.

Finally there is definitely a long way to go for a truely seamless timeshift, both in tvh and xbmc. But I think by at least having something we can begin that progress.

Thank you for the explanation Adam!

Does that mean that even if i watch tv and no pauze is pressed yet, it will still writes the stream to disk?

Yes at the moment that's exactly what it means. I'll be adding some extra flexibility as we go.

I have been tasked with setting up timeshift for a friend on his box.

Almost identical setup to what I have.

I have cloned the git repo. Checked out the timeshift branch. And configured to enable timeshift.

When I then try to make and make install, I get an error 1.

CC              build.linux/src/timeshift.o
/tvheadend/tvheadend/src/timeshift.c: In function âtimeshift_initâ:
/tvheadend/tvheadend/src/timeshift.c:59:29: error: integer overflow in expression [-Werror=overflow]
cc1: all warnings being treated as errors
make: *** [build.linux/src/timeshift.o] Error 1

Any ideas what I am doing wrong?

Probably a bug in my last commits, code it's a still in flux.

Just checkout the same commit you're using.

Thanks for the advice Adam

I must still be doing something wrong, cos I have tried using the commit I used, and now I get no timeshift option.

Correct me if I am wrong but the steps below are what I am doing:

1. git clone https://github.com/tvheadend/tvheadend.git
2. git checkout a420c83a0e
3. ./configure --enable-timeshift
4. make
5. make install

Any help would be greatly appreciated. I am not quite au fait with git, but will have a crack.

using latest 3.3.218~g85bef87-dirty with timeshift.
and we have a brand new timeshift tab in tvheadend configuration.
enabled 'on demand'

works perfectly!
great work Adam.
I am using the new tab too, great work Adam. I have noticed that the fast forward and rewind option from the OSD have gone, pause still works.

Is this a xbmc, tvheadend-addon or tvheadend issue?

The on demand option doesn't do anything at the moment. I was just asking the new tab and thinking through some options I want to add.

In fact I've probably broken a few things with the new config at the moment.

Trying to get the timeshift to work from an old commit.

Cant understand where I am going wrong, if anyone can help would be extremely happy

why use an old commit?
makes no sense.
it's in development and i think Adam would me most helped with feedback on current status.
good luck with getting timeshift to work.
When I try to use the latest I get an error as listed earlier in this thread.

Adam told me to use the same commit I have on my other box (which works), which I have tried and get no timeshift option.

Have I missed anything from below:

~# apt-get install build-essential git pkg-config libssl-dev bzip2 wget

~# apt-get install libavahi-client-dev zlib1g-dev

~# git clone https://github.com/tvheadend/tvheadend.git

~# git checkout feature/timeshift

~# ./configure --enable-timeshift

~# make

~# make install

I'm not even sure if this is the correct way or if it is the way I did it on my own box.

Many thanks for your help.

Here is the error I get after trying the above steps:

[email protected]:~# git clone https://github.com/tvheadend/tvheadend.git
Cloning into 'tvheadend'...
remote: Counting objects: 17394, done.
remote: Compressing objects: 100% (4681/4681), done.
remote: Total 17394 (delta 13263), reused 16679 (delta 12643)
Receiving objects: 100% (17394/17394), 5.43 MiB | 623 KiB/s, done.
Resolving deltas: 100% (13263/13263), done.
[email protected]:~# dir
Downloads  Movies  Music  Pictures  tvheadend  TV\ Shows
[email protected]:~# cd tvheadend
[email protected]:~/tvheadend# dir
Autobuild     configure  data    docs  LICENSE   man     src
Autobuild.sh  contrib    debian  lib   Makefile  README  support
[email protected]:~/tvheadend# git checkout feature/timeshift
Branch feature/timeshift set up to track remote branch feature/timeshift from origin.
Switched to a new branch 'feature/timeshift'
[email protected]:~/tvheadend# ./configure --enable-timeshift
checking for cc execinfo.h ...         ok
checking for cc -mmmx ...              ok
checking for cc -msse2 ...             ok
checking for cc getloadavg ...         ok
checking for py module gzip ...        ok
checking for bzip2 ...                 ok
checking for pkg openssl  ...          ok
checking for pkg zlib  ...             ok
checking for pkg avahi-client  ...     ok
Fetching dvb-scan files... done

  Using C compiler:                    cc
  Build for arch:                      i686

  Using PYTHON:                        python

  cwc:                                 yes
  v4l:                                 yes
  linuxdvb:                            yes
  dvbscan:                             yes
  timeshift:                           yes
  avahi:                               yes
  zlib:                                yes
  bundle:                              no
  dvbcsa:                              no
  execinfo:                            yes
  mmx:                                 yes
  sse2:                                yes
  getloadavg:                          yes
  py_gzip:                             yes
  bin_bzip2:                           yes
  ssl:                                 yes

  openssl:                             1.0.1c
  zlib:                                1.2.7
  avahi-client:                        0.6.31

Installation paths:
  Prefix:                              /usr/local
  Binaries:                            ${prefix}/bin
  Libraries:                           ${prefix}/lib
  Data files:                          ${prefix}/share
  Man pages:                           ${datadir}/man

Final Binary:

Tvheadend Data Directory:

[email protected]:~/tvheadend# make
CC              build.linux/src/main.o
CC              build.linux/src/utils.o
CC              build.linux/src/wrappers.o
CC              build.linux/src/version.o
CC              build.linux/src/access.o
CC              build.linux/src/dtable.o
CC              build.linux/src/tcp.o
CC              build.linux/src/http.o
CC              build.linux/src/notify.o
CC              build.linux/src/file.o
CC              build.linux/src/epg.o
CC              build.linux/src/epgdb.o
CC              build.linux/src/epggrab.o
CC              build.linux/src/spawn.o
CC              build.linux/src/packet.o
CC              build.linux/src/streaming.o
CC              build.linux/src/teletext.o
CC              build.linux/src/channels.o
CC              build.linux/src/subscriptions.o
CC              build.linux/src/service.o
CC              build.linux/src/psi.o
CC              build.linux/src/parsers.o
CC              build.linux/src/parser_h264.o
CC              build.linux/src/parser_latm.o
CC              build.linux/src/tsdemux.o
CC              build.linux/src/bitstream.o
CC              build.linux/src/htsp_server.o
CC              build.linux/src/serviceprobe.o
CC              build.linux/src/htsmsg.o
CC              build.linux/src/htsmsg_binary.o
CC              build.linux/src/htsmsg_json.o
CC              build.linux/src/htsmsg_xml.o
CC              build.linux/src/misc/dbl.o
CC              build.linux/src/misc/json.o
CC              build.linux/src/settings.o
CC              build.linux/src/htsbuf.o
CC              build.linux/src/trap.o
CC              build.linux/src/avg.o
CC              build.linux/src/htsstr.o
CC              build.linux/src/rawtsinput.o
CC              build.linux/src/iptv_input.o
CC              build.linux/src/avc.o
CC              build.linux/src/huffman.o
CC              build.linux/src/filebundle.o
CC              build.linux/src/config2.o
CC              build.linux/src/lang_codes.o
CC              build.linux/src/lang_str.o
CC              build.linux/src/epggrab/module.o
CC              build.linux/src/epggrab/channel.o
CC              build.linux/src/epggrab/module/pyepg.o
CC              build.linux/src/epggrab/module/xmltv.o
CC              build.linux/src/plumbing/tsfix.o
CC              build.linux/src/plumbing/globalheaders.o
CC              build.linux/src/dvr/dvr_db.o
CC              build.linux/src/dvr/dvr_rec.o
CC              build.linux/src/dvr/dvr_autorec.o
CC              build.linux/src/dvr/ebml.o
CC              build.linux/src/dvr/mkmux.o
CC              build.linux/src/webui/webui.o
CC              build.linux/src/webui/comet.o
CC              build.linux/src/webui/extjs.o
CC              build.linux/src/webui/simpleui.o
CC              build.linux/src/webui/statedump.o
CC              build.linux/src/webui/html.o
CC              build.linux/src/muxer.o
CC              build.linux/src/muxer_pass.o
CC              build.linux/src/muxer_tvh.o
CC              build.linux/src/epggrab/otamux.o
CC              build.linux/src/epggrab/module/eit.o
CC              build.linux/src/epggrab/module/opentv.o
CC              build.linux/src/epggrab/support/freesat_huffman.o
CC              build.linux/src/timeshift.o
/home/ray/tvheadend/src/timeshift.c: In function âtimeshift_initâ:
/home/ray/tvheadend/src/timeshift.c:63:3: error: large integer implicitly truncated to unsigned type [-Werror=overflow]
cc1: all warnings being treated as errors
make: *** [build.linux/src/timeshift.o] Error 1
What os is this on? Could it be related to that? I using Ubnutu 12.04
Xbmcbuntu frodo rc2

My box is rc1.

But they are both based on Ubuntu 12.10, aren't they?
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 12

Logout Mark Read Team Forum Stats Members Help
Timeshift Support1
This forum uses Lukasz Tkacz MyBB addons.