•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 83
  • Next 
 
Thread Rating:
  • 11 Vote(s) - 4.73 Average
Work in Progress - Stereoscopic 3D support for half/full SBS, over/under, etc
#16
(2012-12-11, 12:28)pieh Wrote: If you feel like testing you can try out elupus changes + few of my fixes and tweakes (video playback shouldn't stutter as it did with just first patch): https://github.com/pieh/xbmc/commits/3d . I don't have 3dtv so all I could do is to check if GUI/subtitles are rendered side by side / top and bottom and they do: https://dl.dropbox.com/u/28792047/xbmc/no3d_home.png (no 3d mode) vs https://dl.dropbox.com/u/28792047/xbmc/3d_home.png (sbs mode).

There is no auto-detection so you have to switch 3d modes manually (I added to keymap 'y' key to cycle between 3d modes: https://dl.dropbox.com/u/28792047/xbmc/3d.xml - place it in userdata/keymaps directory).

Just tried to build openelec with your repository, it resulted in a flickering screen Sad.
Reply
#17
Is possible to add this code to master branch? Sorry i don't know how that get managed usually.
Reply
#18
(2013-01-21, 23:16)Nogler Wrote: Is possible to add this code to master branch? Sorry i don't know how that get managed usually.

Frodo is feature complete, so only bugfixes are accepted at the moment. New features like this won't make it in until after the final release of Frodo.
Reply
#19
(2013-01-21, 23:16)Nogler Wrote: Is possible to add this code to master branch? Sorry i don't know how that get managed usually.
What sialivi said plus this code is not ready to be added yet. There is at least one known problem when one "half" of the gui is not updated and is getting out of sync. There is also some flickering screen problem mentioned by zpon.
Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

My previous forum/trac nickname: grajen3
Reply
#20
(2013-01-22, 00:07)pieh Wrote:
(2013-01-21, 23:16)Nogler Wrote: Is possible to add this code to master branch? Sorry i don't know how that get managed usually.
What sialivi said plus this code is not ready to be added yet. There is at least one known problem when one "half" of the gui is not updated and is getting out of sync. There is also some flickering screen problem mentioned by zpon.

What do you mean by only one half of GUI being updated?
It is only with pieh's repository I'm having flickering. Ktrz's patch is working fine.
Reply
#21
(2012-12-11, 12:28)pieh Wrote: If you feel like testing you can try out elupus changes + few of my fixes and tweakes (video playback shouldn't stutter as it did with just first patch): https://github.com/pieh/xbmc/commits/3d . I don't have 3dtv so all I could do is to check if GUI/subtitles are rendered side by side / top and bottom and they do: https://dl.dropbox.com/u/28792047/xbmc/no3d_home.png (no 3d mode) vs https://dl.dropbox.com/u/28792047/xbmc/3d_home.png (sbs mode).

There is no auto-detection so you have to switch 3d modes manually (I added to keymap 'y' key to cycle between 3d modes: https://dl.dropbox.com/u/28792047/xbmc/3d.xml - place it in userdata/keymaps directory).

Pieh, Big GrinBig GrinBig GrinBig Grin My hat off to you!, well my 3D glasses anyway 8)

FOr the uninitiated etc. like me who cloned the git repo and wondered why it wasnt working....

Code:
git clone https://github.com/pieh/xbmc.git
cd xbmc
git checkout 3d

I am not sure if this is just half sbs or all sbs, but its all sbs I have tried so far, the aspect ratio is wrong by a factor of two. This is easily corrected by setting the pixel ratio to 2.
Can this be set automatically as part of sbs 3d mode? (and I guess it would be the other way for under over) Does this make sense?

Brilliant! Thank you.

Now the problem seems to be playing 2D movies in the SBS passive setup 8) Is there a workaound at this stage for this?
I guess 2D in sbs/ou gives the option of duplicate like it was sbs, great if you still wear the glasses, but minute pixel misalignment would make it awful if no glasses, or simply scale to leave one projector black, then watch without glasses. Both will work with one projector off etc. and only turn on the second one for sbs/ou.

no flickering or any defects so far.
Reply
#22
well, if you don't watch a 3D movie, turn 3D off. pieh/elupus implemented an action ("3dmode" IIRC) to cycle the 3D modes via your remote or keyboard by adjusting the keymap and bind a key/button with this action. I gave it a try a couple days ago and it worked just fine.
Reply
#23
da-anda. With two projectors setup with twinview (et. al) overlapping, the duplicated gui is essential, in as much as without it XBMC fullscreen (without sbs gui) spans both projectors creating a big mess. I have never used/seen a 3d TV, can you set them to stereo at any tim?
The way things are setup for me there is no disabling 3D. (Hence the question is nontrivial in my case)

Amazing work Pieh! (and the rest of the XBMC team) what a slick proggy this is!
Youve even restircted the mouse, so good!
Reply
#24
Stupid question perhaps, but is this patch intended to patch sourcecode before compiling it, or is it to patch ie a script in an already running system?

I'm running Xbian on my Raspberry PI and I'm very satisfied with it and the only thing I really miss, are subtitles for 3D movies.
Reply
#25
Chuck Norris patches binaries all the day - but as you are not Chuck Norris, try patching the source before compiling.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#26
(2013-02-18, 14:54)fritsch Wrote: Chuck Norris patches binaries all the day - but as you are not Chuck Norris, try patching the source before compiling.

Good answer to a perhaps not so good questionWink
Reply
#27
Hi guys,

I'm a little lost right now. All of my movies are Half-SBS or SBS, so which patch should a try on Frodo?
Reply
#28
I need some help here, I can't fetch pieh repository:

git clone https://github.com/pieh/xbmc.git
Initialized empty Git repository in /home/renato/xbmc/xbmc/.git/
Cannot get remote repository information.
Perhaps git-update-server-info needs to be run there?

Now it's working. The correct address is:

git clone git://github.com/pieh/xbmc.git

[]'s

Renato

(2013-02-26, 21:04)renatoriolino Wrote: I need some help here, I can't fetch pieh repository:

git clone https://github.com/pieh/xbmc.git
Initialized empty Git repository in /home/renato/xbmc/xbmc/.git/
Cannot get remote repository information.
Perhaps git-update-server-info needs to be run there?
Reply
#29
Hey guys,
I'm a newbie at this and also having a problem trying to get subtitles rendered in 3D.
As I understand it, I have to recompile XBMC in order to use the patch in the first post. Is this true? If so, I'm not sure I'll be able to do this, as my research tells me that you need experience in C++ and I have none.
Would someone be so kind as to offer an easier solution, or a step by step guide?

Anyone's help will be greatly appreciated. Smile
Reply
#30
@djcorvus: Go here.
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 83
  • Next 
 
Thread Rating:
  • 11 Vote(s) - 4.73 Average



Logout Mark Read Team Forum Stats Members Help
Stereoscopic 3D support for half/full SBS, over/under, etc4.7311