19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

  •   
  • 1
  • 53
  • 54
  • 55(current)
  • 56
  • 57
  • 83
  •   
WIP Stereoscopic 3D support for half/full SBS, over/under, etc
That's exactly how "ask me" is working. 1st entry is "preferred mode", second is "2D", third is "movie format", fourth is "other". I'm working on a patch that removes the third option in case it matches the preferred mode (it's part of my video playlist test compile I linked earlier).
Reply
What is the advantage of not using your preferred mode, if XBMC is changing it in a way that doesn't lose any information?
Here's a hypothetical situation:
I have a passive TV and all of my 3D movies are encoded in TAB format as that is the most efficient way on a passive TV.
One day, my friend decides to bring over a 3D movie encoded in SBS format because he has an active TV.
Why would it be an advantage to play it back in SBS mode rather than TAB mode if XBMC can convert between the two? Either way, the vertical resolution will be halved and the horizontal stretched, won't it?
Have I misunderstood anything fundamental, because I don't see why after setting your preferred mode you would ever need to switch, regardless of the input format.
Reply
The main intention of the "ask me" feature was to have an easy way to switch between 3D and 2D and have the "other" option in case you want to go all retro and use anaglyph or something. IIRC elupus was not happy with only these options and also added the fourth option showing the videos original format as an option. Personally I also don't see the need for this fourth option and would love to simplify it to simply "3D" (using preferred mode or if no preferred mode is defined movie format), "2D" and "other". So something like this:
Image
Reply
(2014-01-22, 10:59)da-anda Wrote: The main intention of the "ask me" feature was to have an easy way to switch between 3D and 2D and have the "other" option in case you want to go all retro and use anaglyph or something. IIRC elupus was not happy with only these options and also added the fourth option showing the videos original format as an option. Personally I also don't see the need for this fourth option and would love to simplify it to simply "3D" (using preferred mode or if no preferred mode is defined movie format), "2D" and "other". So something like this:
Image

That looks like a very elegant solution. Also, if I'm honest the 'other' option could be hidden for 99% of the time. Perhaps an option to hide it for the people who won't be using it?
Reply
Hi da-anda,

In recent nightlies, I'm finding the OSD isn't being displayed in 3D (sbs for me). Even if you set the gui to sbs, the OSD stays 2D. It's happening on a fresh install.

Is this a known issue to be fixed for the first Gotham beta? If not I can grab a debug log and log on trac.

Thanks
Reply
I recently figured out that the video scaling method on Windows has to be auto or DXVA in order to correctly display the OSD in 3D mode. Please check if this is the case for you.
Reply
(2014-01-22, 15:36)da-anda Wrote: I recently figured out that the video scaling method on Windows has to be auto or DXVA in order to correctly display the OSD in 3D mode. Please check if this is the case for you.

Ah, believe I've got it set to Lanczos3. I'll switch to DXVA.

Is that a requirement, or something in the works to be changed?

Thanks for your help!

Cheers Wink
Reply
(2014-01-20, 16:45)afedchin Wrote:
(2014-01-20, 16:23)Hasu0bs Wrote: Yes, but the problem presists: Which settings do I need to choose for XBMC to convert it to HalfSBS or HalfTAB to get the TV to display it correctly? (since frame packing is not suported yet)

To be honest, I find the 3D settings in XBMC very confusing. What is preferred mode for when the default behaviour for film stereo mode is "ask me"? Where can I select the 3D orientation the video file has if the auto detection fails?
For TV with passive 3D the TAB stereo mode is prefered in any way. You can set prefered mode then xbmc will be auto select this mode. If the auto detection fails you can set up correct stereo orientation at osd video settings dialog.

Ah thank you! I somehow missed the video OSD settings. Everything is fine now. Here is my status report after testing for an hour on my LG passiv TV:

First things first: I spent 30 minutes figuring out why over/under looked crappy. It turnes out (surprise) that it strongly relies on the resolution beeing pixel perfect. I somehow had to discover that the TV setting "Auto" and "16:9" are stupid (and setting gfx driver in windows to over/underscan even more so) and that the correct setting for LG TV is "Just Scan"! After that (ans after resetting the gfx settings) I now have the perfect resolution in XBMC resulting the GUI in 3D mode to be not at all 3D (which is a good thing because now the lines for left and right eye are strictly over each other) Huge success! Blush

Now my problems with 3D movies:
  1. When ever I stop a movie, XBMC does not remember the "current 3D" mode and the menu is displayed in 2D - TV stays in over/under mode = eye terror
  2. Watching a HalfSBS 1080p video was nice, it got changed to over/under quite nicely. After playing with video scaling and setting it to auto the right eye got screwed:
    Image
    picture with 3d disabled on TV:
    Image
  3. A fullSBS 1080p (3840x1080) movie I tried was displayed poorly: It detects it correctly as SBS 3D BUT: Skin displays 4K sign which is false AND (worst of all) the resolution gets messed up resulting in big bars over and under the video. Something like 30:9 resolution... So my question from above persists (highlighted)
Reply
pleas read a few pages back for the answer of how to fix FullSBS movies. in short: fix mkv headers and enter correct display resolution.
As for TV stays in 3D mode but XBMC is exiting it: Either enable "settings > video > playback > Adjust display refresh rate to match video" (which I'd suggest anyways) or disable "disable stereoscopic mode when playback is stopped" on same settings page. Both will achieve what you want.
Reply
(2014-01-22, 20:31)Hasu0bs Wrote: Ah thank you! I somehow missed the video OSD settings. Everything is fine now. Here is my status report after testing for an hour on my LG passiv TV:

First things first: I spent 30 minutes figuring out why over/under looked crappy. It turnes out (surprise) that it strongly relies on the resolution beeing pixel perfect. I somehow had to discover that the TV setting "Auto" and "16:9" are stupid (and setting gfx driver in windows to over/underscan even more so) and that the correct setting for LG TV is "Just Scan"! After that (ans after resetting the gfx settings) I now have the perfect resolution in XBMC resulting the GUI in 3D mode to be not at all 3D (which is a good thing because now the lines for left and right eye are strictly over each other) Huge success! Blush

It is always better to fix over/under scan on the TV than by adjusting either the graphics drivers or the XBMC video calibration. In fact, IMHO the calibration thing should have a great big warning "WARNING Do NOT do this unless you have exhausted every option to turn overscan off on your TV/monitor."

It has always been important, but is far more so now with 3D.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
(2014-01-22, 22:42)da-anda Wrote: pleas read a few pages back for the answer of how to fix FullSBS movies. in short: fix mkv headers and enter correct display resolution.
As for TV stays in 3D mode but XBMC is exiting it: Either enable "settings > video > playback > Adjust display refresh rate to match video" (which I'd suggest anyways) or disable "disable stereoscopic mode when playback is stopped" on same settings page. Both will achieve what you want.

Thanks for the tip. I set the 3D flag to 1 and the resolution to 1920x1080p. This makes the file playable in xbmc but it now displays like HalfSBS in vlc. Is this the desired behaviour? Makes the file somewhat watchable with vlc in windows though.. Angel
So If I get this right, the resolution set in mkv header should be the desired resolution for the film and has nothing to do with the resolution of the stream?

I don't get the sense of the setting "disable stereo mode when playback is stopped". When I was in active stereo mode before I started I probably want to stay there when I finish watching.

Any idea about the right eye thing shown i the pictures?

Thank you for your answers. This is just amazing!
Reply
(2014-01-23, 01:50)Hasu0bs Wrote: Thanks for the tip. I set the 3D flag to 1 and the resolution to 1920x1080p. This makes the file playable in xbmc but it now displays like HalfSBS in vlc. Is this the desired behaviour?
Yes, it is desired behavior. Full SBS/OU cannot be displayed as is.
Reply
(2014-01-23, 01:50)Hasu0bs Wrote: Thanks for the tip. I set the 3D flag to 1 and the resolution to 1920x1080p. This makes the file playable in xbmc but it now displays like HalfSBS in vlc. Is this the desired behaviour? Makes the file somewhat watchable with vlc in windows though.. Angel
So If I get this right, the resolution set in mkv header should be the desired resolution for the film and has nothing to do with the resolution of the stream?
You define two resolutions in MKV header - the streams "physical" resolution and the resolution it should be played in. For FullSBS/OU this is 1080p.

(2014-01-23, 01:50)Hasu0bs Wrote: I don't get the sense of the setting "disable stereo mode when playback is stopped". When I was in active stereo mode before I started I probably want to stay there when I finish watching.
Some want to stay in 3D mode, some not. I f.e. don't want to stay in 3D mode because I see no benefit in browsing the GUI in 3D mode. To please everybody we have that setting. Also it makes more sense once we can force the TV into stereomode from within XBMC.

(2014-01-23, 01:50)Hasu0bs Wrote: Any idea about the right eye thing shown i the pictures?
Sorry, no. elupus or afedchin would have to check that.
Reply
(2014-01-23, 08:14)afedchin Wrote:
(2014-01-23, 01:50)Hasu0bs Wrote: Thanks for the tip. I set the 3D flag to 1 and the resolution to 1920x1080p. This makes the file playable in xbmc but it now displays like HalfSBS in vlc. Is this the desired behaviour?
Full SBS/OU cannot be displayed as is.

Hey afedchin,

That is until your hardware based option (Intel Stereo Driver, AMD HD3D, and NVidia 3d Vision) hits master! Then the 3840x1080 resolution will be packaged and passed to the TV correctly, right?

Cheers Wink
Reply
(2014-01-23, 13:24)liquidskin76 Wrote: Hey afedchin,

That is until your hardware based option (Intel Stereo Driver, AMD HD3D, and NVidia 3d Vision) hits master! Then the 3840x1080 resolution will be packaged and passed to the TV correctly, right?

Cheers Wink
Yes, you are right. Using Full SBS/TAB has meaning only for frame-packing 3D
Reply
  •   
  • 1
  • 53
  • 54
  • 55(current)
  • 56
  • 57
  • 83
  •   
 
Thread Rating:
  • 11 Vote(s) - 4.73 Average



Logout Mark Read Team Forum Stats Members Help
Stereoscopic 3D support for half/full SBS, over/under, etc4.7311