•   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 41
  •   
Release Viki.com Video Add-on - Asian Drama MOVIES & TV Shows
(2020-10-30, 10:23)AManEatingDuck Wrote: is anyone else getting a plugin must be rewritten error when using plugin.video.vikir-0.18.4.8.zip?

it was working fine until this evening.

Same Here! Maybe this is due to kodi's upgrade to 18.9
Reply
Does this add-on work with a paid Viki account (VikiPass)? If so, how do I enter the login credentials in the add-on? Apologies if this question is not permitted, I'm just curious why I didn't see any postings about logins and paid Viki account.

Also, I noticed that this add-on's Settings page doesn't show any settings in a CoreElec box (standalone XBMC box running minimal Linux and Kodi). It does work on my Android device. Seems like there is a missing library or add-on to make the Settings page dispay the settings in CoreElec.

Thanks!
Reply
(2020-10-31, 08:12)Frendyonline Wrote:
(2020-10-30, 10:23)AManEatingDuck Wrote: is anyone else getting a plugin must be rewritten error when using plugin.video.vikir-0.18.4.8.zip?

it was working fine until this evening.

Same Here! Maybe this is due to kodi's upgrade to 18.9
I don't think so, I've been running libreELEC 9.2.4 since the 12th of August 2020 which still has Kodi 18.8.

I have a feeling something has changed with the service since the plugin still works up till the point when you select a stream for playback.
Reply
(2020-10-31, 21:47)AManEatingDuck Wrote:
(2020-10-31, 08:12)Frendyonline Wrote:
(2020-10-30, 10:23)AManEatingDuck Wrote: is anyone else getting a plugin must be rewritten error when using plugin.video.vikir-0.18.4.8.zip?

it was working fine until this evening.

Same Here! Maybe this is due to kodi's upgrade to 18.9
I don't think so, I've been running libreELEC 9.2.4 since the 12th of August 2020 which still has Kodi 18.8.

I have a feeling something has changed with the service since the plugin still works up till the point when you select a stream for playback.

Why does it seem like no one else is having an issue with this addon? It's been a while and still no one brings it up or come up with a fix.
Reply
(2020-10-31, 20:11)EBAL Wrote: Does this add-on work with a paid Viki account (VikiPass)? If so, how do I enter the login credentials in the add-on? Apologies if this question is not permitted, I'm just curious why I didn't see any postings about logins and paid Viki account.
No, this add-on is not design for premium users.
Reply
(2020-10-31, 22:37)Frendyonline Wrote:
(2020-10-31, 20:11)EBAL Wrote: Does this add-on work with a paid Viki account (VikiPass)? If so, how do I enter the login credentials in the add-on? Apologies if this question is not permitted, I'm just curious why I didn't see any postings about logins and paid Viki account.
No, this add-on is not designed for premium users.
Reply
Hadn't used this plugin in a while, and then when I started again, it suddenly stops working. I can reach the point where I select the playback stream, but then it stops...
Reply
looks like the plugin is borking at this bit of code. it's not finding 360p in the json file.


            if '360p' in jsonrsp:
                if (quality == '3' or quality == '2'): #MPEG-DASH DYNAMIC MOBILE
                    stream = jsonrsp['mpd']['http']['url'] #.replace('https','http')
                    xbmc.executebuiltin("Notification(VIKI,Dynamic Mobile Streaming: MPEG-DASH,2000)")
                #elif quality == '2': #MPEG-DASH 480p
                    #stream = jsonrsp['480p']['https']['url'].replace('https','http').replace('v4.viki.io','http')
                    #xbmc.executebuiltin("Notification(VIKI,DASH Streaming: 480p,2000)")
                #elif quality == '1': #Direct MP4 360p
                    #domain = re.search('//(.+?)/', jsonrsp['360p']['https']['url']).group(1)
                    #stream = jsonrsp['360p']['https']['url'].replace(domain,'content.viki.com').replace('https','http')
                    #xbmc.executebuiltin("Notification(VIKI,MP4 Progressive Download,2000)")
                else: #Direct MP4 480p
                    #domain = re.search('//(.+?)/', jsonrsp['480p']['https']['url']).group(1)
                    stream = jsonrsp['480p']['https']['url'] #.replace(domain,'content.viki.com') #.replace('https','http')
                    xbmc.executebuiltin("Notification(VIKI,MP4 Progressive Download,2000)")
                    
            else:
                xbmc.executebuiltin("Notification(VIKI,The addon needs rewriting!!!,2000)")
Reply
(2020-05-17, 12:38)Majide Wrote:
(2020-05-17, 12:08)rainbatt Wrote: Where to find v0.18.4.8? I was using v0.4.7
 From HERE you can manual download the actual version 0.18.*.* <-the second number indicates with which Kodi version the add-on will work. Future versions of the addon for Kodi 19 will be numbered 0.19.*.* Only the current Kodi version is supposed to work with the addon.


Hi Majide,
Are you still fixing the viki addon.

It just working recently after the kodi update.

Thank you for your help.
Reply
I came here to say thanks for the add-on and saw this issue. I've submitted a fix to your repo.

And thank you for this add-on.
Reply
(2020-11-08, 13:12)chriskillian Wrote: I came here to say thanks for the add-on and saw this issue. I've submitted a fix to your repo.

And thank you for this add-on.
Do you have a link to the Repo?

what part of the code did you change to make it work?
Reply
(2020-10-31, 08:12)Frendyonline Wrote:
(2020-10-30, 10:23)AManEatingDuck Wrote: is anyone else getting a plugin must be rewritten error when using plugin.video.vikir-0.18.4.8.zip?

it was working fine until this evening.

Same Here! Maybe this is due to kodi's upgrade to 18.9
Same here, also upgraded to latest LibreElec a few days ago which uses Kodi 18.9
Reply
(2020-11-05, 20:44)tsukihim3 Wrote:
(2020-05-17, 12:38)Majide Wrote:
(2020-05-17, 12:08)rainbatt Wrote: Where to find v0.18.4.8? I was using v0.4.7
 From HERE you can manual download the actual version 0.18.*.* <-the second number indicates with which Kodi version the add-on will work. Future versions of the addon for Kodi 19 will be numbered 0.19.*.* Only the current Kodi version is supposed to work with the addon.


Hi Majide,
Are you still fixing the viki addon.

It just working recently after the kodi update.

Thank you for your help.

Have you had any luck with this addon problem. The latest file at mega.nz is plugin.video.vikir-0.18.4.8. Latest Kodi release is Kodi v18.9 "Leia".

Thanks for all your work on this addon. Looking forward to viewing Korean dramas again.

Cheers
Reply
(2020-11-08, 13:12)chriskillian Wrote: I came here to say thanks for the add-on and saw this issue. I've submitted a fix to your repo.

And thank you for this add-on.

Hello
The same for me with kodi 18.8 and. 9
Can you share you're fix?
Thanks for for job
It's my favorite add-on.. 🤪
Reply
I noticed that when I tried the regular viki app the movies/drama works but when I use kodi and viki 0.18.4.8. I get a message. Add on need rewriting!!! The addon cannot play this video.

Any advice?

Thanks for a great addon
Reply
  •   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 41
  •   



Logout Mark Read Team Forum Stats Members Help
Viki.com Video Add-on - Asian Drama MOVIES & TV Shows4
This forum uses Lukasz Tkacz MyBB addons.