Thread Rating:
  • 0 Vote(s) - 0 Average
Frodo Video Stuttering
Ok so I purchased a Foxconn nT535 and have been using it with XBMC 11 with one slight problem of every couple minutes the video would totally go black, then the TV would pop on with the indicator of what HDMI 1080 was being used like it lost the video signal all together. Then I was like ok lets try XBMC 12 and see if the problem got fixed. Well now I'm not having that problem with TV/Movies anymore but I have another more annoying problem of when I play any Blu-Ray quality movie the video just stutters, the audio is fine but video is complete and utter crap. DVD Rips are fine, TV Shows are fine but anything that is encoded in like H.264, DTS, or etc is just unwatchable. I've went through the Frodo FAQ about looking at audio drivers to see what "Supported Codecs" are installed and I have none. I've instead the Intel Graphics Drivers and Motherboard Chipsets and nothing has change. I removed the Realtek audio drivers like the FAQ says now I just have a High Def Audio listed in device Manager. Here is the computer specs hopefully someone can get me working again I've messed with all the settings that I can think of. Let me know what more information you need and I'll provide it have this week off due to holidays and wife is at home recovering from back surgery so the pressure is on to get this working!

Foxconn Machine:

eries Atom
Dimension 190(W) x 135(D) x 24(H)mm
Processors Supported Intel D525 Dual core 1.8GHz
Chipset Intel NM10 Chipset
Memory Supported 1x SO-DIMM Socket Support DDR3 800 up to 4GB
VGA Graphics Intel Graphics Media Accelerator 3150
Storage Interface 1x 2.5" SATA II 3Gb/s
LAN IEEE 802.11b/g/n up to 300Mbps (Dual Antenna)
Front I/O 1x SD/SDHC/MS/MS Pro/MMC 5 in 1 Card Reader
2x USB 2.0
1x Mic in (support S/PDIF-IN)
1x Headphone
Back I/O 1x RJ-45 (10Base-T/100Base-T/1000Base-T)
4x USB 2.0
1x Line-out jack.(support S/PDIF-OUT)
1x VGA
1x DC in

Windows 7 32 Bit
4gig DDR3 Ram
60 gig SSD

Dynex Dx-32L 152A11

Current setup goes TV -> HDMI Cable -> TV HDMI Port 2

As I've said done a ton of reading, I've tried all the settings changes that I could find to trya nd only Blu-Ray Quality Movies are giving a problem. Could us some help to walkthrough what drivers/codec packages/etc I should have installed that I might not. I'm very computer savvy just stumped.
Well I did a fresh remove/install of XBMC Frodo and it looks like only certain files are giving this problem as I started my Blu-Ray of G.I. Rise of Cobra and there is no problem. Play my Just Go With it, or Jack and Jill and its a stutter frenzy!
Can you post 3 screenshots? One from Video>Playback, one from System>Video Output and one from System>Audio Output? See the Wiki for capturing a screenshot.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(2012-12-28, 09:12)OrcD3vil Wrote: Play my Just Go With it, or Jack and Jill and its a stutter frenzy!

Have a little sympathy for the program, man... XBMC can't take that much Adam Sandler... Big Grin

This is what I have now I've been doing a lot of messing around because the wife wanted to watch Jack and Jill so I was going off the movie that I was trying to play. I have played the .mkv file from my desktop via VLC and it plays fine. But XBMC stutters alot on the video the audio is fine. We are watching "Flight" which is a DVDSCR .mkv file just fine right now.[/php]
An Intel Atom is far to weak for Software Rendering. Maybe it works with SD material, but not with HD movies.
You should keep Renderer to Auto and enable DXVA2 (hardware accel.)
A10-5700 APU @Gigabyte A88xm
Marantz AV7702/MM8003 Combo
Philips 55PFL8007k/12
Sharp Z18000
All the posts I have been reading say that intel does not play well with DXVA and it has been working just fine and is working just fine except on a couple movies.
You've obviously been very lucky thus far as your hardware is not good enough for reliable decoding of HD video, some HD rips at 720p may work depending on bitrate but to get guaranteed playback you'll need to stick to SD rips.

The Atom is too underpowered to do reliable software renderings and needs the help of hardware acceleration from a discrete graphics device (since in built graphics isn't good enough either), this is why Nvidia ION is so popular for low powered systems as it pairs an Atom processor with Nvidia graphics on a small single board. Most well know of these Nvidia ION devices is the Acer Revo but there are many others.

Hmm sorry its just weird that Eden worked fine except every couple minutes the video would flicker on/off and now all the sudden only a couple movies stutter while a mass majority of my collection are 1080/720 movies and have always played fine. Just not sure why only a couple movies would do this stutter while all the others play just fine. While I do understand this is not a powerful PC and the Nvidia chipsets have a ton more power I do agree on that factor. I'm just not convinced that this box is that "underpowered" seeming as this has been working literally almost flawless I think its a tweak or setting in Frodo not the box itself. While I'm not a developer or expert this is just my opinion on having the box and using it for so long.

Did you check what was the status of your buffer when the shutter happened by pressing O?

I had the same issue and in fact the shutter occurs each time the buffer was near 0%. It seems frodo doesn't pause the playback end fill the buffer as eden did.

Good luck.
OP, did you resolve this?

I am having the same problem. Majority of my movies are blu-ray rips 1080p. 95% of them play fine with Frodo, but a few stutter like crazy. It's like the movies are being played at 100x slow motion.

Hey Guys,

I had that problem as well, that some video would play in uberslowmotion. The fix which worked for me was to go to the System -> System -> Audio Settings and turn off all the audio receiver things like DolbyDigital, AAC, DTS. Hope it helps!
Samsung LE40A656, MS Tech MC-1200, Asrock FM2A75M-ITX, AMD A4-5300, Kingston HyperX Blu 4GB, Samsung 830 Series 128 GB SSD
I reverted to Eden, since there was no way to get back smooth video playback on Frodo. My Audio is Pass-Thru SPDIF, no decoding / recoding on the HTPC....
I hope they find a way to make it as good as Eden was already, hopefully they can make an "opt-out" for this new fancy audio stuff making video playback awfull :-(
If you get smooth playback on Eden then you should get smooth playback on Frodo, you just need to know how to configure you audio correctly.

If you've no clue then set:

Audio Output: Analog
Speaker configuration: either 2.0 (if connected to TV) or 5.1 (if connected to AVR)
Audio Output Device: Directsound - SPDIF or HDMI

There's a sticky containing all you need to know to get things configured correctly, see
I have tried everything with the audio. I do not use any decoding on the HTPC, I let audio pass-thru to my SPDIF ouutput and let my dedicated Amplifier do the work (same as in EDEN).
I have tried different audio options too. Even if I degrade to stereo output (downmix all channels to stereo, output via optical SPDIF - I do not have analog stereo speakers connected to
my htpc - devices), video is not working the same way as in Eden (and to compare both versions I use exactly the same settings: DirectSound Realtek SPDIF to Amp - no WASAPI
involved, nor video card doing audio decoding magic, no HDMI - input is AC3 5.1 audio stream, same video file for both Frodo and Eden).

See my post:

Quote:Hallo everybody,

first of all, thank you for the hard work making xbmc awesome!

Well I have upgraded / fresh installed several PC's running xbmc on Windows 7 and there is one big issue with playback
of recorded HD content (satellite TS 1080i), that was working flawless before in EDEN.

I use to cut out the Ads out of the stream on I-Frame transitions and store the resulting TS.

This transitions were on Eden almost invisible or just small hick-ups for a few frames and always less than a second.
Playing te same sequence on FRODO the decoding of the Video stops and stutters for 10 to 15 seconds before
the video continues to play back normally, while audio works flawless.

BTW. Same issue when starting a TS stream, while Eden starts immediately, Frodo's video takes some seconds (5-10) to
sync Video while audio is playing right.

Also the playback looks not that smooth and clear as in Eden. I have tried different settings for de-interlacing,
also turned it completely off. Still Eden's play back is ways better than Frodo's.

There seem to be major changes in video decoding inside XBMC, since the underlying hardware and the video drivers
are the same (DXVA enabled).

I found hints to ajust audio settings. Well I use pass-thru direct audio to SPDIF realtek optical. I also tried different settings there
with no success in regard of video playback improvement.

Please check the issues. Maybe there is a way to chose between "old playback engine" vs. "new engine" via settings
to circumvent this issues while keeping the nice new features of PVR and Live-TV.

Frodo Video Stuttering00