SOLVED: Advanced Launcher Issue - Launching Any Rom File within v12
Hello all,

I've been working on setting up emulators (specifically zsnes and fceux) from XBMC v12 RC 2 (via xbmcbuntu install) - the forum and misc wikis have been extremely helpful and if I missed a post or bug on this I apologize! Taking zsnes as an example, i've reviewed the following two posts:

I have everything working perfectly within the desktop environment (testing the same rom files) of xbmcbuntu, though when I attempt to launch via the launcher within xbmc I receive the message in the lower right hand corner "Error Script failed!" which generated following message (I get the same thing from fceux as well) in ~/.xbmc/temp/xbmc.log:

22:15:10 T:2787441472  NOTICE: Thread XBPyThread start, auto delete: false
22:15:10 T:2787441472  NOTICE: -->Python Interpreter Initialized<--
22:15:10 T:2787441472  NOTICE: Launcher: found 3 launchers
22:15:10 T:2787441472   ERROR: EXCEPTION: Unimplemented method: executehttpapi::executehttpapi(...)
22:15:10 T:2787441472   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.RuntimeError'>
                                            Error Contents: Unimplemented method: executehttpapi::executehttpapi(...)
                                            Traceback (most recent call last):
                                              File "/home/ryan/.xbmc/addons/plugin.program.advanced.launcher/", line 19, in <module>
                                              File "/home/ryan/.xbmc/addons/plugin.program.advanced.launcher/resources/lib/", line 174, in __init__
                                                self._run_rom(launcher, rom)
                                              File "/home/ryan/.xbmc/addons/plugin.program.advanced.launcher/resources/lib/", line 1281, in _run_rom
                                            RuntimeError: Unimplemented method: executehttpapi::executehttpapi(...)
                                            -->End of Python script error report<--

I'd love to hear any suggestions on what I may have done to cause this or what I could do to rectify this!

Thank you!

My fault, I didn't realize that the addons weren't the latest and greatest.

Per the post:

I download the zip:

And added it via the addons page.

Logout Mark Read Team Forum Stats Members Help
SOLVED: Advanced Launcher Issue - Launching Any Rom File within v120
This forum uses Lukasz Tkacz MyBB addons.