• 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  • 23
Comskip for Linux released
(2015-09-10, 02:51)tmm1 Wrote:
Quote:Can we rebuild a linux version off the latest windows?

I've ported the latest version of comskip to be POSIX compatible, and it now works on both mac and linux.

Furthermore, Erik has graciously accepted my patches back into the official version. This means all three major platforms can now use the latest and greatest comskip features.

You can build comskip for linux or mac directly from the git repository under Erik's account: https://github.com/erikkaashoek/Comskip

Holy crap, that's awesome news. Thanks for your work on this!
Reply
awesome, now waiting for a synology package. ( i hope so)AngelAngel
Reply
(2015-09-10, 02:51)tmm1 Wrote:
Quote:Can we rebuild a linux version off the latest windows?

I've ported the latest version of comskip to be POSIX compatible, and it now works on both mac and linux.

Furthermore, Erik has graciously accepted my patches back into the official version. This means all three major platforms can now use the latest and greatest comskip features.

You can build comskip for linux or mac directly from the git repository under Erik's account: https://github.com/erikkaashoek/Comskip

Great news! Thank you Smile
Reply
(2015-09-10, 02:51)tmm1 Wrote:
Quote:Can we rebuild a linux version off the latest windows?

I've ported the latest version of comskip to be POSIX compatible, and it now works on both mac and linux.

Furthermore, Erik has graciously accepted my patches back into the official version. This means all three major platforms can now use the latest and greatest comskip features.

You can build comskip for linux or mac directly from the git repository under Erik's account: https://github.com/erikkaashoek/Comskip

Hallo,
great news.

Unfortunately I'm not able to build it with linux. I tried up-to-date Arch as well as Ubuntu 14.04 LTS and Ubuntu 15.04 (x64 on a standard PC).
In Arch I installed argtable2 before and when I make I get the following errors:
ccextratorwin/general_loop.c: Auf höchster Ebene:
ccextratorwin/general_loop.c:513:14: Fehler: expected »=«, »,«, »;«, »asm« or
»__attribute__« before »process_block« LONG __cdecl process_block (unsigned char
*data, LONG length) ^ ccextratorwin/general_loop.c: In Funktion »general_loop«:
ccextratorwin/general_loop.c:1201:9: Warnung: Implizite Deklaration der Funktion
»process_block« [-Wimplicit-function-declaration] got = process_block (fbuffer, inbuf);
^ Makefile:79: die Regel für Ziel „ccextratorwin/general_loop.o“ scheiterte make:
*** [ccextratorwin/general_loop.o] Fehler 1

In Ubuntu (after installing libargtable2-dev libavformat-dev) I get the following warnings / errors:
In file included from comskip.c:15:0:
comskip.c: In function ‘LoadFile’:
platform.h:118:29: warning: ignoring return value of ‘getcwd’, declared with attribute warn_unused_result [-Wunused-result]
#define _getcwd(x, y) getcwd(x, y)
^
comskip.c:8124:5: note: in expansion of macro ‘_getcwd’
_getcwd(cwd, 256);
^
comskip.c: In function ‘LoadCutScene’:
comskip.c:9397:14: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result [-Wunused-result]
fread(&csbrightness[i], sizeof(int), 1, cutscene_file);
^
comskip.c: In function ‘InputReffer’:
comskip.c:12721:10: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
fgets(line, sizeof(line), raw); // Read first line
^
comskip.c:12740:10: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
fgets(line, sizeof(line), raw); // Skip second line
^
comskip.c: In function ‘ProcessCSV’:
comskip.c:13342:10: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
fgets(line, sizeof(line), in_file); // Skip first line
^
comskip.c:13344:14: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
fgets(line, sizeof(line), in_file); // Skip second line
^
make: *** [comskip.o] Fehler 1

Do I need special compiler options or something else? What linux system you have used?
Any suggestion?

Thanks
Reply
I've pushed some fixes, can you try `git pull` and building again on both arch and ubuntu?

On ubuntu, you'll need libavformat-ffmpeg-dev instead of libavformat-dev
Reply
I've also added instructions to the README to build on ubuntu 14.04 using an ffmpeg PPA.
Reply
Thanks for the quick reply as well as for the fixes and instructions
I have tested it on Ubuntu 15.04 and Arch (not yet Ubuntu 14.04).
The good part of the news is that I can build it without problems (just some warnings).
When I now start comskip (with some basic comskip.ini) the program crashes on both systems with segfault error:

On Arch:
[mpegts @ 0x3913d40] PES packet size mismatch
Input #0, mpegts, from '/media/Win10/PVR-HP8540w/Zug um Zug.ts':
Duration: 01:35:30.43, start: 19266.123244, bitrate: 2204 kb/s
Program 28724
Metadata:
service_name : arte
service_provider: ARD
Stream #0:0[0x191]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv), 720x576 [SAR 64:45 DAR 16:9], max. 15000 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0:1[0x192](ger): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 192 kb/s
Stream #0:2[0x193](fre): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 192 kb/s
No Program
Stream #0:3[0x194]: Audio: mp3, 12000 Hz, mono, s16p, 48 kb/s
[mpeg2video @ 0x39188a0] gray decoding requested but not enabled at configuration time

Initial pts = 1.000
Frame Rate set to 25.000 f/s
Format changed to [720 : 576]
Speicherzugriffsfehler (Speicherabzug geschrieben)

On Ubuntu 15.04 (other video, comskip.ini from Windows version of comskip)
[ac3 @ 0x42a7da0] frame sync error
[mpeg @ 0x42a5aa0] decoding for stream 1 failed
[mpeg @ 0x42a5aa0] Could not find codec parameters for stream 1 (Audio: ac3, 0 channels, fltp): unspecified sample rate
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, mpeg, from '/media/Daten-3TB/PVR-GA/Zimt und Koriander.mpg':
Duration: 00:00:04.52, start: 16685.585000, bitrate: 4254 kb/s
Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p(tv), 720x576 [SAR 64:45 DAR 16:9], max. 7000 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0:1[0x20]: Audio: ac3, 0 channels, fltp
Stream #0:2[0x80]: Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
Frame Rate set to 25.000 f/s
Format changed to [720 : 576]
Speicherzugriffsfehler (Speicherabzug geschrieben)

On Ubuntu there is also a missing codec, but that shouldn't be the root cause.
I will do some more test tomorrow.

Thanks again for your effort.
Reply
Thanks for testing, I just pushed some changes to fix the segfaults you're seeing.
Reply
Really quick answer / changes

Just tested on Ubuntu 14.04
Before your latest changes I got the segfault error at the "same location" as in 15.04 and Arch:
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/media/test/Win10/PVR-HP8540w/Das geheime Leben unserer Hunde.mp4':
Metadata:
major_brand : mp42
minor_version : 1
compatible_brands: isommp42
creation_time : 2015-05-23 08:23:34
copyright :
copyright-eng :
Duration: 00:43:43.02, start: 0.000000, bitrate: 2356 kb/s
Stream #0:0(deu): Video: h264 (Main) (avc1 / 0x31637661), yuv420p, 1024x576 [SAR 1:1 DAR 16:9], 2205 kb/s, 25 fps, 25 tbr, 1k tbn, 50 tbc (default)
Metadata:
creation_time : 2015-05-23 08:23:34
handler_name : GPAC ISO Video Handler
Stream #0:1(deu): Audio: aac (HE-AAC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 56 kb/s (default)
Metadata:
creation_time : 2015-05-23 08:23:34
handler_name : GPAC ISO Audio Handler
Stream #0:2(und): Data: none (rtp / 0x20707472), 84 kb/s (default)
Metadata:
creation_time : 2015-05-23 08:23:51
handler_name : GPAC ISO Hint Handler
Stream #0:3(und): Data: none (rtp / 0x20707472), 4 kb/s (default)
Metadata:
creation_time : 2015-05-23 08:23:52
handler_name : GPAC ISO Hint Handler
[h264 @ 0x5856fa0] gray decoding requested but not enabled at configuration time
Frame Rate set to 25.000 f/s
Format changed to [1024 : 576]
Speicherzugriffsfehler (Speicherabzug geschrieben)

Now, with your latest changes still segfault, but earlier:
Comskip 0.81.088, made using avcodec
Donator build
The commandline used was:
./comskip "/media/test/Win10/PVR-HP8540w/Zug um Zug.ts"
Using comskip.ini for initiation values.
Speicherzugriffsfehler (Speicherabzug geschrieben)

Happy to continue testing
Reply
Good news.
I just tested on Arch and evrything seems to work fin there.
Will do some more testing (e.g. Ubunut 15.04) tomorros.
Thanks again.
Reply
Interesting, I'm not able to reproduce any segfaults on ubuntu now. If you get a chance, run it under gdb and get a backtrace:

$ sudo apt-get install gdb
$ gdb --args ./comskip file.ts
> run
....
(seg fault)
> backtrace
Reply
I rebooted the 14.04 system and the problem / segfault disappeared.
So comskip is now working under Arch / Ubuntu 14.04 LTS / Ubuntu 15.04 (all x64).
Thanks for your quick fixes.

But I haven't managed to get a debugwindow in any of the above systems. Is the debugwindow working in principle on linux systems?

I also have one more issue (as well with the windows as the linux version of comskip). The timecount in the created .edl file started with the time 0 (zero), as also described e.g. in the mplayer description (http://www.mplayerhq.hu/DOCS/HTML/en/edl.html).
When I try to use the edl file with mplayer (mplayer -edl video.edl video.ts) it does not work.
When I use mplayer to create an .edl file (mplayer -edlout video.edl video.ts) by watching the video and set the edl-marks with "i", the timecount starts with a very high number (e.g. 234567). This .edl file do than properly work playing back the video with mplayer. I guess that mplayer is using the embedded PCR value in the ts-stream (the ts-stream was recorded using tvheadend from a german DVB-C source)? Any solution / workaround for that problem? What video player do you use?
Reply
Can this also be (cross) compiled for a Synology DS715 (alpine) ?
Reply
(2015-09-18, 09:44)Pit80333 Wrote: I rebooted the 14.04 system and the problem / segfault disappeared.
So comskip is now working under Arch / Ubuntu 14.04 LTS / Ubuntu 15.04 (all x64).
Thanks for your quick fixes.

Awesome!

Quote:But I haven't managed to get a debugwindow in any of the above systems. Is the debugwindow working in principle on linux systems?

debugwindow doesn't work yet but I have a branch in progress which adds support using SDL (https://github.com/erikkaashoek/Comskip/pull/1)

Quote:I also have one more issue (as well with the windows as the linux version of comskip). The timecount in the created .edl file started with the time 0 (zero), as also described e.g. in the mplayer description (http://www.mplayerhq.hu/DOCS/HTML/en/edl.html).
When I try to use the edl file with mplayer (mplayer -edl video.edl video.ts) it does not work.
When I use mplayer to create an .edl file (mplayer -edlout video.edl video.ts) by watching the video and set the edl-marks with "i", the timecount starts with a very high number (e.g. 234567). This .edl file do than properly work playing back the video with mplayer. I guess that mplayer is using the embedded PCR value in the ts-stream (the ts-stream was recorded using tvheadend from a german DVB-C source)? Any solution / workaround for that problem? What video player do you use?

edl is a time-based format, and the timestamps comskip outputs are definitely based on 0=beginning of stream. You can work around this using edl_offset= in the ini file, but it sounds like in your case the offset is variable. Maybe there's a way to tell mplayer to use relative timestamps? I'm not sure- I would bring this up on the comskip forums.

(2015-09-18, 19:04)schumi2004 Wrote: Can this also be (cross) compiled for a Synology DS715 (alpine) ?

Yes, but you will have to cross-compile ffmpeg first to link against.
Reply
(2015-09-18, 19:21)tmm1 Wrote: edl is a time-based format, and the timestamps comskip outputs are definitely based on 0=beginning of stream. You can work around this using edl_offset= in the ini file, but it sounds like in your case the offset is variable. Maybe there's a way to tell mplayer to use relative timestamps? I'm not sure- I would bring this up on the comskip forums.

Also try enable_mencoder_pts=1 in your ini file and see if that makes any difference.
Reply
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  • 23

Logout Mark Read Team Forum Stats Members Help
Comskip for Linux released6
This forum uses Lukasz Tkacz MyBB addons.