script.common.plugin.cache error
#1
i get this when starting my XBMC. i cant use hardly anything
Navi-x works which is nice

tried to google everything to try and fix it but nothing

it was working fine for the last few days or so......but no, nothing
I am using a macbook pro with Mountain Lion

I am completely new to all this so be gentle

Blush

any help or direction would be greatly appreciated

cheers
jamie
Reply
#2
Same here on OS X, restored previous version and the error was gone.. No problems on W7 and iOS.
Reply
#3
Welcome to the XBMC forums.

(2013-01-05, 11:27)JamieL123 Wrote: i cant ice hardly anything
What does that mean?

Quote:any help or direction would be greatly appreciated
Enable debug log (wiki)ging in XBMC, exit XBMC, restart XBMC and, when you get that error, exit XBMC again. Locate the debug log (wiki) (xbmc.log), upload its entire contents to http://www.xbmclogs.com and post the assigned URL for your uploaded log here with your reply.

Reply
#4
ಠ_ಠ

edit: alright, since the root issue here isn't directly about any icefilms/1channel/etc add-ons, then this thread is fine.
Reply
#5
(2013-01-05, 11:38)artrafael Wrote: Welcome to the XBMC forums.

(2013-01-05, 11:27)JamieL123 Wrote: i cant ice hardly anything
What does that mean?

Quote:any help or direction would be greatly appreciated
Enable debug log (wiki)ging in XBMC, exit XBMC, restart XBMC and, when you get that error, exit XBMC again. Locate the debug log (wiki) (xbmc.log), upload its entire contents to http://www.xbmclogs.com and post the assigned URL for your uploaded log here with your reply.

sorry, but how do you do that..?

Reply
#6
First, what does "ice" mean?
Reply
#7
it has been edited to "use"

is this what you are after...(from last night)

http://xbmclogs.com/show.php?id=25965
Reply
#8
Same here on OS X. I posted in the os x thread

With Frodo RC3 : I get the following message at startup : script failed: script.common.plugin.cache
This error was not present in RC 2 ( or rc1 and the betas)
I reproduced the error by launching the script manually. Can somebody explain me how to resolve this ?

http://xbmclogs.com/show.php?id=25923

system : Frodo RC3 with Aeon Nox 4.0 on mac mini 2011 HD3000 8GB RAM OSX 10.8.2


How to post a debug log ; MacOS acces the hidden userdata folder ; How to post a question ; How to fix gatekeeper issues
Reply
#9
Hmm, seems this might be the issue: http://forum.xbmc.org/showthread.php?tid...pid1286592
Reply
#10
This solution posted by jarryd solved it for me. Thank you for pointing it out

(2013-01-05, 05:38)jarryd Wrote: I too was having some 100% CPU usage randomly out of nowhere, and after having a snoop around the code itself I found a few 'bug fixes' for OSX 10.8 with Frodo RC2/3:

- ~/Library/Application Support/XBMC/userdata/addon_data/script.common.plugin.cache/ needed to be created
- Turns out the default path used for POSIX does not relate to a usable socket file on OSX. What I've done is instead of creating a socket in the user's profile dir (which like above results in a long-ass folder structure), I've created a socket in XBMC's temp dir which should return ~/.xbmc/temp.

All it requires is to edit lib/StorageServer.py and replace line 140:
Code:
self.socket = os.path.join(self.xbmc.translatePath(self.settings.getAddonInfo("profile")).decode("utf-8"), 'commoncache.socket')

With this:
Code:
self.socket = os.path.join(self.xbmc.translatePath('special://temp/').decode("utf-8"), 'commoncache.socket')
How to post a debug log ; MacOS acces the hidden userdata folder ; How to post a question ; How to fix gatekeeper issues
Reply
#11
This seems to have solved it for me to.
Thanks!
Reply
#12
Fixed for me as well. Thanks.
Kodi 17, Transparency Skin
PogoPlug v4 running Arm Linux 4.4.63 as MySQL (mariadb) server.
Mac OS 10.12.5
2015 27" iMac 3.3 GHz Quad, 16GB RAM, 1TB SSD
2015 13" Macbook Pro, 8GB RAM, 256GB SSD
AppleTV 4 TV OS 10
Reply
#13
Damn i can't find the lib folder
Reply
#14
It's in ~/Library/Application Support/XBMC/addons/script.common.plugin.cache/lib/StorageServer.py
Reply
#15
Thanks a ton, i must have just missed that folder. I guess i'm more tired than i thought.
Thanks again.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
script.common.plugin.cache error51