Thread Rating:
  • 0 Vote(s) - 0 Average
Dependencies Not Met??
#1
Anybody run into this problem while trying to add something from zip (Quartz reloaded theme in my case)?

Got the error pop up while trying to install the skin in raspbmc (used whatever version of rasp the windows installer pulls), also got the same message when trying to do the same with the latest version (r12823) of openelec and again when I rolled back to a known good install I have on a different SD card.

I've tried some fixes that have been posted in other threads, but no joy.
Reply
#2
Turn on debugging, and check your debug log - there should be an explanation of what dependency is not being met.

Could be that the version of the OpenELEC GUI isn't as expected. I tried to install a skin (Aeon MQ4) in an OE nightly on Raspberry Pi from earlier this week and the skin complained about the XBMC GUI not being v3.0, so presumably it's some sub-3.0 level at the moment, and which may not change until final release.

This is the reason for the "Dependency not met" error with Aeon MQ4 and the latest OE nightly:
Code:
23:01:56 T:3042931216   DEBUG: GetZipList - Processing zip://%2fstorage%2fdownloads%2fskin.aeonmq.4-1.7.0.zip/
23:01:58 T:3042931216   DEBUG: Addon skin.aeonmq.4 requires xbmc.gui version 3.00 which is not available
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#3
Actually, it looks like xbmc.gui is 4.00 in OE so maybe a problem with the skin?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#4
Has this been resolved or is there a work around, i am also trying to install MQ4 on the latest nightly with openELEC..?
Reply
#5
You can always install manually.
Unzip and put it in addon folder.
Reply
#6
There is a good reason dependencies are not met. That skin will look semi broken when you use it so simply don't.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#7
(2013-02-15, 13:18)Martijn Wrote: There is a good reason dependencies are not met. That skin will look semi broken when you use it so simply don't.

Huh? Quartz reloaded (even in Eden version) run perfectly on every alfa/beta/rc of frodo i've tried. On frodo release too.
Reply



Dependencies Not Met??00