MySQL populating but no movies or TV shows visible in XBMC
Hi, I've managed to set up Mysql with XBMC, I'm busy re-scanning but there seems to be something wrong.

Checking the Mysql db with PHP my admin I'm able to see that it is being populated however nothing is visible in XBMC when I go to titles, recently added etc....

As I said I know XBMC is connecting to and writing to the database because I'm able to view the data when directly connecting to the db.

So far the Movie table has 180 movies in it yet nothing is visible in XBMC.


Frodo, latest Nightly

Any Ideas?

Debug log (wiki) needed.
Thanks for coming back to me Ned...

Here you go:
There's no MySQL settings being loaded, according to the log. Are you sure you've added them to the advancedsettings.xml file, and that file is in the correct location for the userdata folder on Raspbmc?
Hi Ned, arrrrrghhhh that's because I've since removed the advancedsettings.xml file, the info is probably deeper back in the log.

Sorry to have messed you around.

I know XBMC was defintely connecting to mysql because it was able to create the myvideos75 and the mymusic32 databases.
It was able to set up the fields within each database and it was able to populate those fields.

I will delete the log file and repopulate (already tried this but still could not access the data) and I'll post a new log file along with a MySQL export file so you can see what is in the db.

I used to be a php developer so the MySQL part is not new to me ;-)
Hi Ned, I've let it run again, here is a screenshot of the db in PHPmyadmin:

Here is the new logfile: (NB! It's 28MB)

Same file as above zipped for convenience:

Screenshot of what I see in Movie Titles window:

Screenshot of Movie mouseover, xbmc recognises there is some content but can't display it:

Very odd. Can you make a Trac bug report for this, so we can make sure it gets to a dev? Just click on "Bugtracker" at the top of the forum and log in using your forum username and password, say what you said here, along with the logs and screen shots.
Sure :-) Will do.
Also posted this in the bug tracker but wanted it to be available here as well in case anyone with the same problem comes across this thread:

Hi Ned!

I have managed to get it working.... there were tables missing from the Windows database.

The MySQL server I'm using is based in windows, for some reason there were 4 tables not created by XBMC when connecting to the server for the 1st time, this seemed to be a consistent error since I deleted the MyVideo75 database entirely and tried again.

I found this out because I set up MySQL on Wheezy version with an extra RaspberryPi

There are 43 Tables created in the Linux MySQL server as opposed to 39 on the windows server. This was the same with MyMusic32. 16 Tables created in MySQL windows yet 20 tables created on the MySQL linux version...

MySQL versions I'm using:
Windows: 5.5.8 Wheezy: 5.5.28-1

My Install of MySQL (Windows) is also within WAMPSERVER which I doubt would make a difference but I could be wrong.

Using a dump from the working database in Linux and exporting to windows works perfectly. I'm currently using the windows database.

This is certainly not a perfect solution but it's working perfectly now nonetheless.

Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
MySQL populating but no movies or TV shows visible in XBMC00