Win HP MCE remote Guide button (and some others) not working
#1
Wink 
Hi guys

I have XBMC Frodo RC3 installed on Windows 8, 64 bit.

I use HP MCE remote like this.

It works well out of the box, but still have problem with some multimedia buttons:
- Teletext ("T" button)
- Red, Green, Yelow, Blue buttons
- DVD menu
- Recoreded TV
- Guide
- Live TV
- Aspect
- Slide show
- More info ("i" button)
- DVD

Other multimedia buttons (Play, Stop, Pause...) works well.

Tested with "Guide" button:
In my keyboard.xml there is tag <g mod="ctrl">XBMC.ActivateWindowAndFocus(MyPVR, 31,0, 10,0)</g>,
In my remote.xml there is tag <guide>XBMC.ActivateWindowAndFocus(MyPVR, 31,0, 10,0)</guide>

but "Guide" button is still not working.

When i press "Ctrl-G" on the keyboard, it works well and open EPG

ShowKey.exe doesn't react to these buttons.

When I run WIndows Media Center, these buttons works without any problem.

Can anybode show me the right direction, please ? Blush

Reply
#2
Would like to bump this one up - same problem.

I use a Harmony 200 remote, and it was working fine. Now, the WMC controls don't work, and on the MCE Keyboard controls, the "i" button does not work. The "i" button still works fine on the keyboard, just not on the remote.

Confusing!
Reply
#3
Install xbmccustomregis and restart pc for the change to effect.
Reply
#4
Tried that, and it didn't work.

Also, that wouldn't make sense to have to do that, because I've had this remote working with XBMC for months, including the Frodo releases. This was more of a "suddenly it stopped working"-type thing, as opposed to it never working.

Any other thoughts? Anyone?
Reply
#5
(2013-01-12, 05:00)baijuxavior Wrote: Install xbmccustomregis and restart pc for the change to effect.
For me it works wery well, thank you Blush

As I like "clean solutions", I didn't use auto installer, only change reg keys and used keyboard.xml, and many of buttons are working now.

Still four or five buttons not working (even not reaction in ShowKey.exe) but this opened my eyes and I thing, fiddling with register keys will solve it.

ShowKey.exe is good tool, but it show the final result, after remaping defined in registers. Is it existing any tool, which can read the codes, sent by remote, direct on USB interface?
Reply
#6
I'm using EventGhost and having the same GUIDE button issue... when I click it I get a message at the bottom saying 'no PVR clients have been started'.
Operating System: CoreElec with Kodi 18
System: Beelink GT1 Ultimate - Android 7.1, Amlogic S912 Octa-Core 1.5 GHz, 3GB DDR4
Storage: WD MyCloud EX2 Ultra NAS - 2x4TB WD Blue (WD40EZRZ)
Display: 55" TCL 55R615-CA 4K TV
Reply
#7
^^ The GUIDE button is sending keypress Ctrl+G. Change it to something else or change the keyboard xml to use Ctrl+G for something else.
Reply
#8
Any ideas how to do that with EventGhost? I know only the basics about this stuff, which is why I used EventGhost, pretty much a drag/drop deal.

Operating System: CoreElec with Kodi 18
System: Beelink GT1 Ultimate - Android 7.1, Amlogic S912 Octa-Core 1.5 GHz, 3GB DDR4
Storage: WD MyCloud EX2 Ultra NAS - 2x4TB WD Blue (WD40EZRZ)
Display: 55" TCL 55R615-CA 4K TV
Reply
#9
In eventghost, it will be showing as GUIDE button and not Ctrl+G. You can drop this button to any other action you need.
Reply
#10
That's where I'm stuck, I posted in the EventGhost forum as well... though I find their forum to be more often than not useless... lots of posts with 0 replies on that site.

Typically, I click the remote to get the action in the log, then on the right side I find the macro under XBMC2/Buttons/Remote... then drag/drop the action under the event.

I figured I could simply right click and configure, but, not a lot of options...

The GUIDE EVENT shows "MceRemote.Mce.Guide" which I can edit, the action shows nothing to edit at all.
Operating System: CoreElec with Kodi 18
System: Beelink GT1 Ultimate - Android 7.1, Amlogic S912 Octa-Core 1.5 GHz, 3GB DDR4
Storage: WD MyCloud EX2 Ultra NAS - 2x4TB WD Blue (WD40EZRZ)
Display: 55" TCL 55R615-CA 4K TV
Reply
#11
Someone in the EventGhost posted a reply... easy fix...

I use to have under the xbmc2/remote/buttons/guide setup for when I hit the guide button. I switched the event for my 'guide' button to xbmc2/remote/buttons/title which seems to function the same as guide did in EDEN. Big Grin
Operating System: CoreElec with Kodi 18
System: Beelink GT1 Ultimate - Android 7.1, Amlogic S912 Octa-Core 1.5 GHz, 3GB DDR4
Storage: WD MyCloud EX2 Ultra NAS - 2x4TB WD Blue (WD40EZRZ)
Display: 55" TCL 55R615-CA 4K TV
Reply
#12
Smile 
Sorry for my english, I can only hope, you will understand me.Blush

First try to use ShowKey.exe (Google). This is simple tool, no install needed. It will show you, how Windows reacts to pressed button.

In Windows it works like this: when you press button on your remote, it will send some code to your PC (like: "0x21" for "Right" button)
Windows contains list of this codes in Registry. According to this list, it will translate the code to another code.

Example:
For "Right button there is the row: 21,00,00,00,04,00,4f,.
As result of it, the code 21 sent by your remote is translated (remapped) to code 4f. Code 4f mean "Right Arrow",

This is what Windows can understand, what "Showkey.exe will show you. This is, what any program in Windows can handle.

Problem is, the codes sent by some buttons (very often Info or Guide, or Red, Blue... button) are not same on all "MCE compatible" remotes. It can happen, showkey wil not react to some of the buttons on your remote (this was also my problem). It mean, the code sent by your remote doesn't exist in Registry, therefore it cannot be translated and Windows ignore it.

Then you must :

1/ find in internet list of codes sent by your remote (I mean exact your remote control, according to YOUR model number)
It wil contain something like this:
....narrow 0x27
info 0x0F
up 0x1E
right 0x21
left 0x20
down 0x1F
ok 0x22...

...one row for every button on your keyboard.

2/ run "regedit", open [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\HidIr\Remotes\745a17a0-74d3-11d0-b6fe-00a0c90f57da]

3/ check whether the code of not working buttons (f.i. Guide button) exist. If not, you must edit registry key - the best way is to export registry key, be sure to make backup of exportet file, edit exported file in text editor and then import it back to Registry.

Maybe it sounds complicated, but it is not.

Good source of informations is here http://wiki.xbmc.org/index.php?title=Usi...in_Windows.

If need any help, let me know.
Reply
#13
Hi KoMiko,
I have the same remote as you but I've lost the sticker with the product number,
could you post a link to the list of codes or maybe copy the list up onto here?
I've tried to find them online but I've not had much luck! Sad
Reply
#14
My remote is RC1804912/06. This codes works for me: http://lirc.sourceforge.net/remotes/hp/RC180491206

Enjoy
Reply
#15
where to add codes ?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
HP MCE remote Guide button (and some others) not working00