•   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 52
  •   
  Thread Closed
libstagefright - Experimental hardware video decoding builds
(2013-01-25, 16:27)eviltuna Wrote: hddvd mkv 1080p vc1 ap l3 18mbps ac3 none Direct hddvd remux - 9-11 FPS, very choppy, some artifact on start, sound stuttering, CPU0- 30-60% CPU1-70-100%
Monsters mkv 1080p h264 high profile 4.1 10mbps dts Unstyled subs Typical recompressed 1080p - 15-18FPS, a bit choppy, no artifact, CPU0-50-70% CPU1-70-100%, froze up on second run
VC-1 does not work in this build. Known issue.
I don't see a run with "Monsters" in your log...
Latest build is working pretty good for me, except very large m2ts files.

One problem I'm having is that analog audio out doesn't seem to be working (it only passes audio by HDMI). Latest regular Android nightly works fine (passes audio over 2ch analog if cable is plugged), and HDMI audio works always as mentioned. Need a log for this one?

[edit] another problem I've found that seems to be only on this build, cover images and banners seem to go blank sometimes. On reboot they'll all be back again, but they just sometimes vanish mysteriously. Maybe some of these can be fixed by updating to the latest nightly then adding the libstagefright magic? Don't know enough about it, so sorry if I'm just wrong! Smile
Re-ran Monsters. Here's the log

Logfile:
http://xbmclogs.com/show.php?id=30224

Also forgot to mention that the subtitles also work great, and sound seems fine as well.

(2013-01-25, 17:22)Koying Wrote:
(2013-01-25, 16:27)eviltuna Wrote: hddvd mkv 1080p vc1 ap l3 18mbps ac3 none Direct hddvd remux - 9-11 FPS, very choppy, some artifact on start, sound stuttering, CPU0- 30-60% CPU1-70-100%
Monsters mkv 1080p h264 high profile 4.1 10mbps dts Unstyled subs Typical recompressed 1080p - 15-18FPS, a bit choppy, no artifact, CPU0-50-70% CPU1-70-100%, froze up on second run
VC-1 does not work in this build. Known issue.
I don't see a run with "Monsters" in your log...

(2013-01-25, 16:27)eviltuna Wrote: Hardware: iMito MX2 (RK3066)
Firmware: Stock November Firmware (v411)

Using version from 2013-1-21

hddvd mkv 1080p vc1 ap l3 18mbps ac3 none Direct hddvd remux - 9-11 FPS, very choppy, some artifact on start, sound stuttering, CPU0- 30-60% CPU1-70-100%
Planet mkv 720p h264 high profile 5.1 6mbps ac3 Unstyled subs Typical recompressed 720p - Everything playing great, constant 24fps, didn't see any issues CPU- both at 30-55%
Monsters mkv 1080p h264 high profile 4.1 10mbps dts Unstyled subs Typical recompressed 1080p - 15-18FPS, a bit choppy, no artifact, CPU0-50-70% CPU1-70-100%, froze up on second run

Logfile:
http://xbmclogs.com/show.php?id=30183


EDIT: Also tried some 720P Youtube videos and they worked great, didn't try 1080p youtube yet. Keep up the good work guys

No artifacts that's interesting Monsters and some other 1080p streams definitely show for me this strange line on the top i posted the screenshot of http://forum.xbmc.org/showthread.php?tid...pid1306840 on my RK 3066 and when this artifact appears the frame stucks and speed goes down.
Crash everytime on an mp4 file, here's the log:
http://xbmclogs.com/show.php?id=30284

m2ts framerate lag doesn't seem to be related to file size, some smaller files still don't play smoothly. Must just be the encoding. You can see some I tried to play in the log file above. Notably: Underworld.Evolution.2006.BluRay.m2ts plays just fine, whereas most others don't.

BTW as to my problem mentioned above about 2CH audio...the above log should show something if it's there. Basically my headphones jack is plugged in, and works in regular XBMC releases automatically.

[edit] last file played here also gives video decoding glitches every few seconds:
http://xbmclogs.com/show.php?id=30286
(2013-01-26, 09:36)fouad796 Wrote: Device :Gbox I tv box
Cpu : Rockchip Rk2908
Gpu : Mali 400
Ram :1gb
Tried running latest xbmc hw build ,only sound work for couple seconds then crashes xbmc .Using full debug apk hw not good at all neither 720p or 1080p
Log :
http://pastebin.com/vNGuJFk5


Thank you
Old build. Please use apk from 1) in OP
(2013-01-26, 02:47)droshi Wrote: Crash everytime on an mp4 file, here's the log:
Pour les crashes, j'ai besoin d'un logcat.
Voor crashes, ik heb een logcat nodig.

(2013-01-26, 02:47)droshi Wrote: m2ts framerate lag doesn't seem to be related to file size, some smaller files still don't play smoothly. Must just be the encoding. You can see some I tried to play in the log file above. Notably:
Known issue

Builder is fixed. It should now have touched skin included.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
(2013-01-25, 20:46)eviltuna Wrote: Re-ran Monsters. Here's the log
Strange... I should get a rockchip in a while, so I'll be able to debug more on this one. It runs perfect on tegra3.
Device : Mele A2000G
Allwinner A10 ARM Cortex A8 1GHz

http://xbmclogs.com/show.php?id=30364

Received my MK808 and performed some tests with Jan 23rd build (will update and re-run tests)
All 720p are fine, and all 1080p are lagging.

Native player is fine with 1080p.

MK808 with Finless 1.6 ROM (Android 4.1.1)

Logs: http://xbmclogs.com/show.php?id=30348

XBMC looks really promising thanks to your help !

V.
(2013-01-26, 18:08)droshi Wrote: I checked post #1, and did what it asked, so I'm not sure what a logcat is. I thought that's what I posted Sad I know it must be frustrating to keep asking the same thing, and I want to give you the info. I just don't know how.

logcat is Androids logging

you can get it in 2 ways - use ADB - if you know what this is and how to use it then just hook up your android device to a computer and...

Code:
adb logcat -d > logcat.txt

another option - look in the play store for a logcat app that will catch and output the logcat file from the android device directly
XBMC Running on:
- Intel i5 & GTX 980
- Intel NUC i3 Thunderbolt Edition
- Sony Xperia Z3 & Z3 Tablet
- Pivos XIOS DS M1
- Raspberry Pi 3

If my post was helpful please click the +Reputation button.
(2013-01-26, 18:08)vthinsel Wrote: Received my MK808 and performed some tests with Jan 23rd build (will update and re-run tests)
All 720p are fine, and all 1080p are lagging.
It's wonderful. Just that you are not using the apk specified in OP, and thus are not testing the libstagefright build...

(2013-01-27, 03:58)wallaceff Wrote: Other than actually seeing improved performance and gluessing its because stagefright is working, is there any way to confirm its running while watching a video file?

logcat or xbmc debug log

you will see when the codec gets called and accepts the input if it fails you will see that it fallsback to ffmpeg software decoders there also, though in most situations it isn't needed to check that the Render Speed allready says much unless of course it is a bug so if you unsure check the logs Smile

Of course you could also make that accept/fail visible in the Debug OSD which would be much easier then to make sure what is currently being used in Realtime without needing to check the log if you just want to know that information, i guess sooner or later this Hardware/Software OSD will become part of XBMC as it is now with most of the external Player that use ffmpeg as backup (MX Player,BS Player ect).

Btw i wonder when i used XBMC on the Desktop i was able to see the Codec Format being used for the Video currently playing now on Android i only see Resolution and Audio Codec and Channels but not the Video Codec as a information part of the Nav Bar OSD (icons) ?

No VP8,H.264,H.263 or anything else icons why has this information been removed from the OSD ?
(2013-01-27, 04:06)CruNcher Wrote:
(2013-01-27, 03:58)wallaceff Wrote: Other than actually seeing improved performance and gluessing its because stagefright is working, is there any way to confirm its running while watching a video file?

logcat or xbmc debug log
That (search for "stf-xxx" and check the messages there) or bring up the codec osd ("o", if you have a hard keyboard) and check if , e.g., "stf-h264" is used in place of "ff-h264" as a video codec..
The "Quartz" skin, although not touch friendly, has a "codec" menu item in osd config menu.
  •   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 52
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
libstagefright - Experimental hardware video decoding builds4.510