Due to maintenance, our forum will be offline for a short while on Monday June 1st, around 22:00 UTC.

  •   
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  • 52
  •   
  Thread Closed
libstagefright - Experimental hardware video decoding builds
Yep RockChip is sadly not Amlogic though i hope they see how great it would be to have support for XBMC in comparison to their competition i guess that can make some impact in their minds, lets wait and see Wink

Btw Koying the 4.0.4 ics source is released if you mean the Android source you can find it here http://service.i-onik.de/a09_source_1.5/ics/ Smile

and here are their patches for CTS passing

http://service.i-onik.de/a09_source_1.5/...atch_V1.1/

i think the changes are pretty low level hardware generic and should work on any RK 3066 Device no matter which ODM base

RockChip also already ported 4.1.1 though they don't released the source yet and who knows if they ever will Wink

Also the Kernel Sources are already in Public in different versions
Hi,

I tested 20130202 on my system.

Creative HanZpad
Android 4.0.4
Kernel 3.0.8

Initially I ran h264_720p_hp_5.1_6mbps_ac3_planet.mp4 (on sdcard) using the Gallery app and that played fine with smooth video and good audio.

I then tried to play the same file with XBMC 20130202, the video didn't start properly, the screen was completely black but the audio played for about 10 seconds and then went off.

Here is the logcat :-
http://xbmclogs.com/show.php?id=33715

Many thanks,

zpadguy
Hui nice a Zii ZMS-40 tab Smile

I/OMXCodec( 2841): [OMX.ZiiLABS.H264.Decoder] AVC profile = 100 (High), level = 51
I/OMXCodec( 2841): [OMX.ZiiLABS.H264.Decoder] video dimensions are 320 x 240
I/OMXCodec( 2841): [OMX.ZiiLABS.H264.Decoder] Crop rect is 320 x 240 @ (0, 0)

the container/bitstream parser seems to get something wrong here Wink

also try some standard youtube and or apple .mov file for testing first see my link above for a 1080p youtube file

zpadguy Antutu benchmark result ?

and Creative says it can do H.265 decoding is there an OMX.ZiiLABS.H265.Decoder or a OMX.ZiiLABS.HEVC.Decoder Huh

Could you also release a XBMC Render Performance Result System->System Info
(2013-02-07, 21:14)Koying Wrote: I've received the rockchip device (a minix neo x5) and ran a quick test.
Indeed, I see that 720p is running fine but 1080p is not. From my tests, it seems getting back a 720p frame is ~5ms while getting a 1080p one is ~50ms Sad

I've opened a thread on the minix forums and I hope those friendly guys might allow me to get access to their android sources and directly to rockchip, so that we might solve this.

Rockchip engineer Herman Chen has relesed user mode vpu drivers in slatedroid forum for rk3066 devices.

http://www.slatedroid.com/topic/41654-pr..._p__532370

Hope this might help you.

/Chandan
(2013-02-08, 06:31)chandankp Wrote: Rockchip engineer Herman Chen has relesed user mode vpu drivers in slatedroid forum for rk3066 devices.

http://www.slatedroid.com/topic/41654-pr..._p__532370
Thanks. Very interesting stuff...

Hi there,

I have followed this thread with great interest and recently tried the 02.02 build on a NEO G4 RK3066 stick.
I have only tested it with streaming video, but all of them have been scrambled with hardware accelleration active.

So, I have experimented a bit with the other settings under video while I await a working HW accel version, and the settings in this screenshot gives me a pretty decent experience:
http://dl.dropbox.com/u/2933487/Screensh...-12-52.png

Audio is nearly always in sync with the picture. Once in a while the picture skips several frames, but it is definately watchable with the things I have tried:

DR NU video add-on
cnet video add-on
Project Free TV video add-on
TWIT video add-on

(some videos a little more choppy than others)
I hope this may be of use to someone else as well.

I have my NEO G4 set to 1280x720 60 Hz, so I'm not trying full 1080p playback here...

Regards,

/Martin.
(2013-02-08, 12:36)Koying Wrote:
(2013-02-08, 06:31)chandankp Wrote: Rockchip engineer Herman Chen has relesed user mode vpu drivers in slatedroid forum for rk3066 devices.

http://www.slatedroid.com/topic/41654-pr..._p__532370
Thanks. Very interesting stuff...

I take back what I said, very interesting indeed.
I assuming folk read further on in the thread and noted Hermans reply on the 26th, and I quote:

Hi all, this is user mode vpu driver, but no On2 HW codec driver. If someone wanna to use rk3066 Vidoe Process Unit (VPU) hardware for acceleration, On2 HW codec driver is needed

For rk3066 users, it actually seems *some* 1080p work, while others basically crashes the vpu. I'll work on that this WE.
Koying what I've noticed - I re-ripped a dozen of my blu rays last weekend especially to run tests on my 2 RK 3066 TV sticks (UG 802/MK802-III) - ripped using MakeMKV to DD 5.1 or DTS 5.1, (no hi def audio) blu rays sizes ranged from 19gig to over 34gig.... I removed all crap (subs/titles, etc) so just retained movie & English sound track. Uploaded to my Qnap NAS.... both sticks struggle.

I then ran these rips through Handbrake, left at default.... (MKV/high profile) resulting in 5gig to 9gig files... these all stream fine from my NAS. Though no 5.1 just stereo. As yet no pass-thru on HDMI with the RK3066, just down mixed.

I've measured my network thru put, my wireless network is well capable of streaming 35gig ISO's that play @ 40mbps ... (dune/netgear neo media streamers) so I'm struggling to understand why the RK3066 is struggling with straight rips using MakeMKV but having transcoded them with handbrake they work fine?
(2013-02-08, 16:16)Koying Wrote: For rk3066 users, it actually seems *some* 1080p work, while others basically crashes the vpu. I'll work on that this WE.

yet have to find a 1080p bitstream that works without freeze.crash or reboot somewhere @ playback but it's nice that you trying to debug this you should look @ the 18.01 build and the changes after it Smile

Btw where those 50 ms delay on screen rendering results with downscaling involved (1080p->720p) ?
(2013-02-08, 16:16)Koying Wrote: For rk3066 users, it actually seems *some* 1080p work, while others basically crashes the vpu. I'll work on that this WE.

Thanks for trying to fix issues on rk3066 devices...
(2013-02-08, 18:57)CruNcher Wrote:
(2013-02-08, 16:16)Koying Wrote: For rk3066 users, it actually seems *some* 1080p work, while others basically crashes the vpu. I'll work on that this WE.
yet have to find a 1080p bitstream that works without freeze.crash or reboot somewhere @ playback but it's nice that you trying to debug this you should look @ the 18.01 build and the changes after it Smile

Btw where those 50 ms delay on screen rendering results with downscaling involved (1080p->720p) ?
Well, tried the 18.01 version and it doesn't work any better (on Monsters, at least -> freeze).

I've found some kind of patterns, though. All 1080p 4.1 I've tried with ReFrames = 5 do work (I didn't find one with > 5 in my lib). All < 5 basically crashes the vpu...
You can check the value of a given file with MediaInfo.



Correction, the pattern seem to be that full size frames, i.e. 1920x1080, vs. cropped frames, e.g. 1920x800, make the vpu crash.
Furthermore, there something strange in the logcat:
Code:
I/OMXCodec( 1851): [OMX.rk.video_decoder.avc] video dimensions are 1920 x 1080
I/        (  90): init done status 0
I/        (  90): Width 1920 Height 1088
I/        (  90): videoRange 0, matrixCoefficients 1

No idea where the 1088 come from
(2013-02-09, 10:12)Koying Wrote:
(2013-02-08, 18:57)CruNcher Wrote:
(2013-02-08, 16:16)Koying Wrote: For rk3066 users, it actually seems *some* 1080p work, while others basically crashes the vpu. I'll work on that this WE.
yet have to find a 1080p bitstream that works without freeze.crash or reboot somewhere @ playback but it's nice that you trying to debug this you should look @ the 18.01 build and the changes after it Smile

Btw where those 50 ms delay on screen rendering results with downscaling involved (1080p->720p) ?
Well, tried the 18.01 version and it doesn't work any better (on Monsters, at least -> freeze).

I've found some kind of patterns, though. All 1080p 4.1 I've tried with ReFrames = 5 do work (I didn't find one with > 5 in my lib). All < 5 basically crashes the vpu...
You can check the value of a given file with MediaInfo.



Correction, the pattern seem to be that full size frames, i.e. 1920x1080, vs. cropped frames, e.g. 1920x800, make the vpu crash.
Furthermore, there something strange in the logcat:
Code:
I/OMXCodec( 1851): [OMX.rk.video_decoder.avc] video dimensions are 1920 x 1080
I/        (  90): init done status 0
I/        (  90): Width 1920 Height 1088
I/        (  90): videoRange 0, matrixCoefficients 1

No idea where the 1088 come from

i wouldn't count on that you should first try to get the Zelda Medley (Film Framerate) stable as it is much lower complexity and the chances if it runs are good that anything else will be more stable overall Wink

Complete name : G:\dropbox\Zelda Medley - YouTube.mp4
Format : MPEG-4
Format profile : Base Media / Version 2
Codec ID : mp42
File size : 177 MiB
Duration : 4mn 8s
Overall bit rate mode : Variable
Overall bit rate : 5 996 Kbps
Encoded date : UTC 2011-11-16 05:29:03
Tagged date : UTC 2011-11-16 05:29:03
gsst : 0
gstd : 248290
gssd : BADC21241HH1349561247919422
gshh : o-o---preferred---sn-4g57ln7s---v21---lscache2.c.youtube.com

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : [email protected]
Format settings, CABAC : Yes
Format settings, ReFrames : 1 frame
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 4mn 8s
Bit rate : 5 841 Kbps
Maximum bit rate : 14.1 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 23.976 fps
Minimum frame rate : 23.762 fps
Maximum frame rate : 24.341 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.117
Stream size : 173 MiB (97%)
Tagged date : UTC 2011-11-16 05:29:06

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 4mn 8s
Bit rate mode : Variable
Bit rate : 152 Kbps
Maximum bit rate : 181 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 44.1 KHz
Compression mode : Lossy
Stream size : 4.50 MiB (3%)
Title : IsoMedia File Produced by Google, 5-11-2011
Encoded date : UTC 2011-11-16 05:29:06
Tagged date : UTC 2011-11-16 05:29:06

and yes 1080 is mostly handled as 1088 but this especially for broadcast and blu-ray hardware encoder you will see that the bitstreams are 1088 but the 8 pixels aren't shown @ playback Smile

Tough what makes me curios about this 1 user here said he could playback this without problems with his finless rom based mk808 Sad

So here it is again and i please everyone with RK 3066 to test it and report results if it crashes or doesn't, the firmware you use and if it's HDMI out and which output resolution and screen refresh rate.

https://dl.dropbox.com/s/18ys53m6npnmbju...e.mp4?dl=1

also you should maybe first fix the SD stride issue first (squished output) from non width MOD8 bitstreams by padding those additional pixels @ playback so the renderer/decoder thinks it's mod8/mod16 and not mod2 which he seems can't handle
(2013-02-10, 01:00)CruNcher Wrote:
(2013-02-09, 10:12)Koying Wrote: Correction, the pattern seem to be that full size frames, i.e. 1920x1080, vs. cropped frames, e.g. 1920x800, make the vpu crash.
i wouldn't count on that you should first try to get the Zelda Medley (Film Framerate) stable as it is much lower complexity and the chances if it runs are good that anything else will be more stable overall Wink
I'm speaking about frame size, not framerate. Zelda is full 1920x1080 frame size and crashes. QED Wink

BTW, Zelda also shows this
Code:
I/        (   90): Width 1920 Height 1088
I somewhat assume it would show in mediainfo if it was encoded as such...

  •   
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  • 52
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
libstagefright - Experimental hardware video decoding builds4.510
This forum uses Lukasz Tkacz MyBB addons.