• 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 52
libstagefright - Experimental hardware video decoding builds
Finally got my iMito MX2 up and running. I downloaded the 1/21 build and tried to start it. It crashes on the "Starting first run" screen. Not really sure what's happening.

Here's my logcat:
Device : G Box I
CPU : Rockchip Rk2908
GPU : Mali400
OS : Android 4.0
Plays audio only on a 720p file then crashes xbmc ,no picture at all.
le system crashe apres quelques seconds pendant que xbmc lit un fichier de 720p j`ai inclus le logcat

Logcat :

thank you
XBMC Fever..
@CruNcher, please stay focused, no other issues except the what the topic says... And subs are fixed already, see mainline commits.
That goes for everyone else too, post something in this thread that is off-topic and it will get deleted without warning.... Consider this your only warning.
Sorry again
i tried the Zelda Medley again that got stuck this time with resampling (Sync playback to Display) on and it doesn't crashed yet @ cpullup but it shows a lot of strange decode artifacting white fog/clouds now (though maybe i didn't saw them yet because it crashed before those could appear )





though it runs absolute flawless Performance wise, you can also see the strange decoding line on the top again hehe almost like the old analog line Wink

i guess the crashes before are related playing more different files and it becomes unstable because the decoder is wrong used it isn't the tegra 3 VPU afterall.

Though it might be that the resampling really fixes the Cpullup crashes i will try to reforce the crash, but it's cool anyways seeing this playing without crash and @ full Performance even heavily decoding artifacted.

Playing Monsters though doesn't show the same white fog/cloud artifacting issues as the Youtube Bitstreams but the same line on the top

even the higher 1080p complexity Streams play suddenly fine Performance wise though with this white fog/cloud issue since i enabled resampling, either that or its pretty unstable and these are more random issues based on the memory behavior maybe ?.

Also the Sintel Trailer doesn't crash anymore


Ok retried without "Sync playback to Display" these Samples crash as soon as Cpullup sets in(see previous released logcat of the issue), with it enabled they don't though they show the strange artifacting white fog/clouds

I would say it is generally more stable with Sync playback to Display enabled on my RK 3066 tablet

Ok another test another reboot and even with Resampling now the Medley crashes though not as fast so this is pretty random stuff

I will try to concentrate more on 720p and try to find streams which show problems as every 1080p stream shows problems currently

These 1080p Random issues go really far it crashed to Home and now restarting XBMC and selecting any file crashes it immediately to Home again
As I said, I should get a rockchip device in the coming weeks, Having something else than tegra3 to test will be a big step-forward as to at least have consistent behaviour on 2 different VPU.
As to crashes, I should release a new build later today. I've spent yesterday night watching some files end-to-end with the build, and besides slowdowns at times (that having a 2nd device will tell me more about it), it went on without crashes.

Great, as i said 720p H.264 seems pretty stable though i didn't test much different complexity's yet but 1080p is very unstable even in rather low complexity cases (Youtube)
I hope you find a good way to balance it out (or if necessary different paths) to get the best performance of both SOCs (VPUs), im going forward testing the 27 jan build now Smile

Im also going to try to in the end to get rid off some background apps (as you can see on the Nav Bar, and some not visible @ all (services)) though i really hope those aren't the reasons for those more random 1080p crash instabilities.
This build seems to be the most stable of all the ones I've tried so far. First time logging and hope this helps with the development.

Board: Odroid-U2
eMMC: 16GB
ROM: CM10.1 Nightly 20130127 build
Kernel: Stock CM
CPU & GPU settings: Stock@interactive
XBMC: 12.0-RC3 Git:20130121-3fa9c6 Built on Jan 21 2013
Output: TV (1080p@60fps native)


I've just re-read the first post and installed the log uploader add-on in XBMC. Does this mean I can try every type of files for testing and just upload it directly without having to write any updates here?
As some already found out, there is a new build available. The OP link has been updated.

This one *should* work with VC-1 (as in everything is in place), but I didn't manage on tegra3. It just drains the input buffers without providing frames.
I'd be more than interested to get your feedback on different VPU
(2013-01-27, 18:53)dj_ghosie Wrote: I've just re-read the first post and installed the log uploader add-on in XBMC. Does this mean I can try every type of files for testing and just upload it directly without having to write any updates here?
You'd still have to give us the link Wink
But if everything is working fine, no real need to provide a log...

Latest build from today seems to have re-introduced the video stuttering issue from a few builds back on my ODROID-U2 running ICS

logs: http://xbmclogs.com/show.php?id=30674
MK808 Rockchip 3066 dual core.
Fineless 1.6 Rom
JB 4.1.1

Standard JB Video player plays all Videos in Lib. (iso, mkv, xvid, h.264, .avi with ac3, dts, stereo) perfectly.

Movie was played off a directly attached external_USB 1 TB drive.

Started through Universal logo with sound then locked up. Had to reboot to free. Errors look to be sound related. While running the first 30-60 seconds 76% CPU usage. Prior to the 1_21_13 image 100%. Lots of dropped frames also.


Device: ODROID-U2 running CM 10.1

Experiencing similar issues as LtDan, last build worked OK, only m2ts (i think they are all h264) low framerates. This build has full m2ts framerates, but rendering jerkiness is there in all files I tried.

The only log I know how to give:
Rockchip 3066 dual core
mali 400
\same test as the one above but with the 1_27_13 release. Video and audio play but 350+ dropped frames during first 2 minutes. CPU load around 77% total.

1080P, DTS-HD MA, MKV format, 30GB file.
From codec menu (o) stf-h264, Mb/s:3360, drop: 1756+, pc:none, 5 minutes into film.

better concentrate testing 720p stability on RK 3066 for now 1080p H.264 is pretty unstable yet (random crashes/reboots/restarts,decoding errors, performance issues) just wait for Koying to get his RK 3066 based Device Smile

All subs issues are gone with this build, they are shown correctly now Smile
The latest 1_27_13 build is a Major improvement. Great job!!! I tested all the movies that CrunCher said were failing both in 720P and 1080P from Utube and they are flawless! locked in at 23.98/24 fps stf-h264 with total CPU usage around 36-42%. Note: I don't much like testing across a wireless network using addon/plugin's for testing anyway (way to many variables), so downloaded them to the usb attached mass storage device. (720p streaming worked great though)

My previous samples were using a BD rip to MKV with USB mass storage attached for best performance. This is a HDDVD X264 AC3 that drops frames still using the USB attachment, but not as bad as 1_21_13 release. It pretty much locks at 24 fps with CPU usage around 71-74% for the first 3-5 minutes. Then when fps drops occur pc:1 becomes pc:none (codec o) and fps is erratic (13, 18, 21, 14.5, etc) and cpu usage 70-87%.

You are almost there with the rockchip 3066 dual core, again kudos for doing a fantastic job with achieving hw acceleration on these low end devices.


  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 52

Logout Mark Read Team Forum Stats Members Help
libstagefright - Experimental hardware video decoding builds10
This forum uses Lukasz Tkacz MyBB addons.