XBMC process running but does not load
#1
After i rebooted, it looks like XBMC isn't loaded on my Ubuntu 12.04 machine.

However, with I list running processes I see it running.

I kill those processes and re-open XBMC, but again, nothing happens, yet I can see xbmc.bin running as a process on the computer.

I've tried doing a "apt-get purge xbmc" and then re-installing it... but same thing...

Sad

Reply
#2
Debug log file?
Reply
#3
Here is the xbmc.log

I don't see anything unusual.

https://www.dropbox.com/s/f6g5cxe1zck5dgp/xbmc.log
Reply
#4
I don't think that's a debug log

http://wiki.xbmc.org/index.php?title=Log_file

Als you tried launching xbmc from the terminal? Might be some info there.
Reply
#5
When I launch from command line it says:

Code:
Running DIL (3.22.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed

and is just hung there without returning to command prompt.
Reply
#6
Crap... turns out it was an IP address change. The router broke and was replaced a few days ago and it changed my XBMC's IP.

I changed the advancedsettings.xml file to look for the NFS shares on the new IP, and changed mysql's bind-address to the new IP, and XBMC at least opens now...

Now it's stuck saying "Preparing..." and there are no thumbnails, but at least it opened... big step forward.
Reply
#7
hmm... looks like the NFS entries in the mysql database are all set using the old IP address... grrr...

I used IP so there would not be name resolution problem with other devices... they would just all use the IP.

But my router craps out and gets a memory error when I use the old IP address range...

So I'll now need to figure out how to edit the mysql tables to replace all those entries...
Yep, that did it...

I needed to edit sources.xml to use the hostname I set in the /etc/hosts file.

Then dumped the mysql DB: mysqldump -u root -p MyVideos75 > ./MyVideos75
Edited the MyVideos75 file to search and replace the old IP.
Then re-imported that mysql backup: mysql -u root -p MyVideos75 < ./MyVideos75
Reply
#8
get your router (or whatever is handling dhcp) to hand out the same ip address to the nfs server every time, or set it manually to have the same IP address every time
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC process running but does not load00
This forum uses Lukasz Tkacz MyBB addons.