•   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 31
  •   
[RELEASE] ITV Player 1.10
(2021-05-07, 21:47)chamchenko Wrote:
(2021-05-07, 20:49)dr_torch Wrote: I updated live TV to take an HLS stream and I get a stream returned from ITV however when Kodi attempts to play this stream it gets a 404 back which I find odd.  I'm happy to take some advice on how to move forward with that one Smile
Try to download the hls manifest in the browser, some streaming platform may return a 404 code to kodi and ffmpeg user-agent
The first time I tried to watch a show it worked, but now the same show and all other shows will not work they just give me a log error message. I haven't checked the log yet.
Reply
(2021-05-07, 20:55)dr_torch Wrote: You can download my changes with this link https://github.com/mcowell/catchup4kodi/..._3.0.0.zip

You MUST remove the old add-on first as I have externalized the dependencies so Kodi will pull them in on the first use.

Let me know if you have any problems and please post a log in debug mode so I can take a look.  Thanks Smile
The shows work great unless you switch on the subtitles in the settings, then nothing will play. Kind of a shame for me because that's the main reason I use this add-on. Good work though but would be even better if you can fix the subtitles.
Reply
(2021-05-07, 23:45)chrissxuk Wrote:
(2021-05-07, 20:55)dr_torch Wrote: You can download my changes with this link https://github.com/mcowell/catchup4kodi/..._3.0.0.zip

You MUST remove the old add-on first as I have externalized the dependencies so Kodi will pull them in on the first use.

Let me know if you have any problems and please post a log in debug mode so I can take a look.  Thanks Smile
The shows work great unless you switch on the subtitles in the settings, then nothing will play. Kind of a shame for me because that's the main reason I use this add-on. Good work though but would be even better if you can fix the subtitles.

I'll add it to my to do list. Unfortunately my most free days are Thursday and Friday so it may have to wait until next week.

The other feature I liked was Favorites which is also broken. It's on my list too.
Reply
I have updated it so that it no longer crashes when you turn on the subtitles Smile

https://github.com/mcowell/catchup4kodi/..._3.0.1.zip

However, I get nothing on my TV.  I have never attempted anything with subtitles before so I am not sure if I need to turn on something else in Kodi.

You are welcome to give this one a go.  If this does not work then I can try a more in-depth look into this issue next week.

Cheers!
Reply
(2021-05-08, 00:46)dr_torch Wrote: I have updated it so that it no longer crashes when you turn on the subtitles Smile

https://github.com/mcowell/catchup4kodi/..._3.0.1.zip

However, I get nothing on my TV.  I have never attempted anything with subtitles before so I am not sure if I need to turn on something else in Kodi.

You are welcome to give this one a go.  If this does not work then I can try a more in-depth look into this issue next week.

Cheers!


You only have to turn on the subtitles in the add-on's settings and you should see them automatically displayed. I just tested on 3.0.1 with the subtitles turned on and it's picking them up as you can see from this image, but is not displaying them on the screen. 

Image
Reply
(2021-05-08, 00:46)dr_torch Wrote: I have updated it so that it no longer crashes when you turn on the subtitles Smile

https://github.com/mcowell/catchup4kodi/..._3.0.1.zip

However, I get nothing on my TV.  I have never attempted anything with subtitles before so I am not sure if I need to turn on something else in Kodi.

You are welcome to give this one a go.  If this does not work then I can try a more in-depth look into this issue next week.

Cheers!
I replaced the default.py file in the 3.0.1.zip file with the new one in your fork and the subtitles work. You are a genius!
Reply
(2021-05-08, 17:34)chrissxuk Wrote: I replaced the default.py file in the 3.0.1.zip file with the new one in your fork and the subtitles work.
I switched default.py contained in 3.0.1.zip and updated addon in Kodi19 Matrix and confirm catchup with subtitles is working
RPi4, (LibreELEC 10.0 Nightlies) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver
Reply
(2021-05-08, 19:33)MikeKL Wrote:
(2021-05-08, 17:34)chrissxuk Wrote: I replaced the default.py file in the 3.0.1.zip file with the new one in your fork and the subtitles work.
I switched default.py contained in 3.0.1.zip and updated addon in Kodi19 Matrix and confirm catchup with subtitles is working
The only issue now with subtitles is that previously any configuration you did in the Kodi player language settings, ie colour and size, was reflected in the subtitles in the add-on,  but this no longer happens
Reply
I agree. I went to change the colour of the subtitles and nothing changes. Honestly I have no idea how those settings in Kodi work however.

I have noticed that the subtitles that come from ITV have an XML format that includes a colour code but they only get rendered in white on Kodi.

I see a ticket open here that may be related : https://github.com/xbmc/xbmc/issues/18917

Based on that link I could try to remove the alpha from the hex colour code.

If somebody knows more about subtitles I'm happy to try making changes.
Reply
(2021-05-07, 22:37)FXB78 Wrote: Just a couple of minor things I've noticed, in Shows we have duplicate listings where the show starts "The", so for "The Chase" it is listed under both "C" and "T".

Also, in Main Page & Shows view the Date is returned as either "2012" or Blank. Main Page should always be Blank & ideally Shows should be the correct year, or if this is not possible just Blank.

But aside from these slight cosmetic issues the streams all seem to work perfectly fine.

Thanks for the detailed information. The duplication is because that is how it is on the ITV Hub site. Not much I can do about it.

I'll look into fixing the date issue. Not sure what the issue is there.
Reply
(2021-05-09, 00:57)dr_torch Wrote: I agree. I went to change the colour of the subtitles and nothing changes. Honestly I have no idea how those settings in Kodi work however.

I have noticed that the subtitles that come from ITV have an XML format that includes a colour code but they only get rendered in white on Kodi.

I see a ticket open here that may be related : https://github.com/xbmc/xbmc/issues/18917

Based on that link I could try to remove the alpha from the hex colour code.

If somebody knows more about subtitles I'm happy to try making changes.
Previously in the ITV Player the subtitles were always white, but you could customise the size and colour in the Kodi player language settings. This is the same in UKTVPlay in the Catch-up and more addon. Now only the Kodi subtitle size setting works, the colour is always white regardless of any colour selected in the settings. 

In iPlayer WWW subtitles are different they have colours that relate to the speaker and only the size is affected by the Kodi settings.

I assumed this was related to what information was contained in the subtitles downloaded,  but maybe it is just due to the programming. 

Image
Reply
(2021-05-09, 02:22)dr_torch Wrote:
(2021-05-07, 22:37)FXB78 Wrote: Just a couple of minor things I've noticed, in Shows we have duplicate listings where the show starts "The", so for "The Chase" it is listed under both "C" and "T".

Also, in Main Page & Shows view the Date is returned as either "2012" or Blank. Main Page should always be Blank & ideally Shows should be the correct year, or if this is not possible just Blank.

But aside from these slight cosmetic issues the streams all seem to work perfectly fine.

Thanks for the detailed information. The duplication is because that is how it is on the ITV Hub site. Not much I can do about it.

I'll look into fixing the date issue. Not sure what the issue is there.
For some reason the original ITV Player always showed this date of 2012. I think the duplication of shows is done internally by ITV to aid those searching.
Reply
Is there a way to capture the streams for ITV Hub via Amazon channels? I read somewhere that all catch-up there is 1080p HD, as opposed to the normal Hub SD. I've not actually checked this I was just checking the feasibility first.
Reply
So for the Live Streams we have more of an issue.  You can see when I request a catchup stream I get the following:

{"Href": "1-0694-10315-001/20/2/VAR005/1-0694-10315-001_20_2_VAR005.ism/.m3u8?hdnea=st=1620747986~exp=1620769586~acl=/1-0694-10315-001/*~data=nohubplus~hmac=7c12411217395486b604a1a3d09134a98f1cd7078cc9ab0fe2b2aceb9053d27c",
"KeyServiceUrl": null{

And when I request a live stream I get the following:

{
"Href": "/playout/itv2/cenc.isml/.mpd?hdnea=st=1620748074~exp=1620769674~acl=/*~data=nohubplus~hmac=09f1ab6a7bdc0adcf035babb777088e31a9becf7c8c386e105fc1bcfa83de881",
"KeyServiceUrl": "https://itvpnp.live.ott.irdeto.com/Widevine/getlicense?CrmId=itvpnp&AccountId=itvpnp&ContentId=itv2"
}

The big difference here is the keyServiceUrl.  The live streams are encrypted with Widevine DRM.  So the browser goes and fetches a decryption key and passes that along in the payload to get the video file.  I'm not sure how we an do this in Kodi but I'm open to suggestions at this point.

Catchup is looking pretty solid right now though.
Reply
(2021-05-11, 17:55)dr_torch Wrote: So for the Live Streams we have more of an issue.  You can see when I request a catchup stream I get the following:

{"Href": "1-0694-10315-001/20/2/VAR005/1-0694-10315-001_20_2_VAR005.ism/.m3u8?hdnea=st=1620747986~exp=1620769586~acl=/1-0694-10315-001/*~data=nohubplus~hmac=7c12411217395486b604a1a3d09134a98f1cd7078cc9ab0fe2b2aceb9053d27c",
"KeyServiceUrl": null{

And when I request a live stream I get the following:

{
"Href": "/playout/itv2/cenc.isml/.mpd?hdnea=st=1620748074~exp=1620769674~acl=/*~data=nohubplus~hmac=09f1ab6a7bdc0adcf035babb777088e31a9becf7c8c386e105fc1bcfa83de881",
"KeyServiceUrl": "https://itvpnp.live.ott.irdeto.com/Widevine/getlicense?CrmId=itvpnp&AccountId=itvpnp&ContentId=itv2"
}

The big difference here is the keyServiceUrl.  The live streams are encrypted with Widevine DRM.  So the browser goes and fetches a decryption key and passes that along in the payload to get the video file.  I'm not sure how we an do this in Kodi but I'm open to suggestions at this point.

Catchup is looking pretty solid right now though.
Live has always been an issue with this add-on but as you say catch-up is really good. I wish I could help but I'm still learning this stuff.
Reply
  •   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 31
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] ITV Player 1.100
This forum uses Lukasz Tkacz MyBB addons.