Export Video Library & Poster art - Possible bug?
#1
Hey all,

I've been using XBMC to create all of the nfo files and I noticed that when I import my media the poster art isn't what I selected when I exported the library. I opened the nfo files and I see that the first thumb is not the poster I selected (is that how it's chosen?). The fanart works just fine, but I wanted to see if anyone else has noticed this.

Directory Layout:
Movies/Genre/Movie.{mp4,nfo}

Version: Frodo RC3
Reply
#2
Should work fine assuming your settings have been correctly configured. Can you get a small reproducible case/dummy filesystem?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#3
I'm not sure of exactly what you are asking, so I'll just try to describe in more detail my configuration & the steps I follow to produce this problem.

I have a local Ubuntu-based server hosting my media. I'm accessing the media through CIFS on my primary workstation where I've been working to build my library. I've fixed all of my incorrect matches and have even selected the fanart images with the sharpest details. After doing this, I exported the library to individual files with no art. All of the nfo files were saved to the server and I imported the library on my HTPC. Everything appeared to import just fine until I noticed that several of my posters were not the same ones I had selected on the workstation.

Upon further investigation, I learned that if I shift the order of the posters in the nfo file that I could influence which poster would be displayed in XBMC. As a test I switched the fanart for 2001: A Space Odyssey on my workstation and copied the nfo file on the server to a backup location. I then exported the library again (selecting overwrite old files) and compared the new nfo to the backup. The only thing that differed between the two files were with the streamdetails tag (really weird...file didn't change...).

So that test left me wondering if I removed the nfo file if it would change the order of the posters in the nfo. I removed the nfo file from the server and exported the library again. Diff'd the files again and the same streamdetails tag was the only thing that differed.

You mentioned that my settings could be misconfigured. If I provided the guisettings.xml file would that help in tracking down the problem?
Reply
#4
No. The order in the .nfo file is only an issue if the local art isn't there. The local art is exported as <moviename>-poster.jpg so should be reimported no problem at all. You've checked these files and they're what is being imported, right?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#5
I'm not exporting the art. That's what the internet is for Smile
Reply
#6
Right - if you choose not to export art, then no information regarding art will be exported.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#7
Well that's half correct right? I mean my fanart is updated and that led me to believe that the poster art should have been updated as well. I guess it's just a consistency issue.
Reply
#8
I'll make fanart consistent with posters/banners after Frodo (not the answer you were after, right?)
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Export Video Library & Poster art - Possible bug?00
This forum uses Lukasz Tkacz MyBB addons.