Linux -  AMD Driver no overscan option
#1
KUbuntu and also tried Ubuntu 12.04 LTS
AMD Sempron 140 with 785 and 880 chipsets
AMD HD 4200 and 4250 onboard graphics
XBMC 11.0 GIT:unknown
TV: Panasonic TC-P50U50

Ok I think its a toss up to post this problem here but I'm sure someone must have run into this problem to at somepoint. I bought a new TV and for some reason the AMD catalyst driver does not give me the option to adjust the overscan. I have taken the same HTPC to my friends house and to hotels and the option is always there, just not when connected to my new TV. Any advice would be appreciated. Also the driver recognizes the TV as a projector if that helps things at all.

Thanks in advance
Reply
#2
Most decent TVs these days have the ability to turn off overscan, and that is always the first option.

Often it is hidden in something like "Ratio - Just Scan". My panasonic certainly has the option, I can't recall what it is called, will look tonight.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
(2013-01-29, 05:07)nickr Wrote: Most decent TVs these days have the ability to turn off overscan, and that is always the first option.

Often it is hidden in something like "Ratio - Just Scan". My panasonic certainly has the option, I can't recall what it is called, will look tonight.

I have taken the unit travelling and know about the Just Scan option. I have looked high and low in the TV's menus and can find only one option. That sort of enlarges the picture but i'm still getting a black border about an inch thick all the way around. This is why i'm wondering if there is a file I just have to edit or something.
Reply
#4
Interesting. So the picture is smaller than the screen? Overscan usually goes the other way - ie bits of the picture are off the edge of the screen.

Sorry I don't know much about amd drivers, despite typing this on an amd graphics machine.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#5
(2013-01-29, 06:47)nickr Wrote: Interesting. So the picture is smaller than the screen? Overscan usually goes the other way - ie bits of the picture are off the edge of the screen.

Sorry I don't know much about amd drivers, despite typing this on an amd graphics machine.

It has been my experience that AMD's drivers underscan a little bit making the picture slightly smaller in order to make sure that when you boot up you aren't missing a critical part of the screen. Then the user just has to overscan a little to get the picture to fit. I do it all the time in hotel rooms because I travel a lot.
Reply
#6
Tried this? Disable fglrx's underscan.

Code:
aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
Reply
#7
Also worth knowing, I believe you have to stop X before you do this.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#8
(2013-01-29, 07:14)chrisyu Wrote: Tried this? Disable fglrx's underscan.

Code:
aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0


Cool, this is the sort of fix I imagined. But where do I add in this line of code?
(2013-01-29, 07:16)nickr Wrote: Also worth knowing, I believe you have to stop X before you do this.

Or can you just add that line in, save, and reboot and the change will take affect for the next session?
Reply
#9
When you run aticonfig it changes the xorg.conf file as I understand it, so next (and every) time you start X it should take effect.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#10
(2013-01-30, 03:28)nickr Wrote: When you run aticonfig it changes the xorg.conf file as I understand it, so next (and every) time you start X it should take effect.

I tried typing that into the terminal and nothing happened. Are you sure all the spaces are correct. I've never used aticonfig like this so I'm not sure of the correct syntax
Reply
#11
What do you mean nothing happened? I assume you checked xorg.conf before and after? Are you saying that there was no change?

Changes to xorg.conf do not take effect until after you restart X. Did you restart it?

PS I didn't specify the line, another poster did. I guess you could read aticonfig --help if things are unclear. Pipe it through a pager like less as it's quite long.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#12
Use SSH (wiki) and just copy and paste

As it was already indicated to you, both X and XBMC cannot be running otherwise this does not get saved.

Code:
sudo killall -9 X
sudo killall -9 xbmc
aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

uNi
Reply
#13
aticonfig does not store its settings in xorg.conf, so you won't see any change there

uni: killing X that way will most probably not work, as its respawned by upstart. Stop it properly with sudo service lightdm stop (or whatever upstart script launches X)
Reply
#14
Uni if X is killed xbmc will certainly die, so killing it once X is killed should not be necessary Smile

The usual way to stop X is via the display manager, not by killing the X executable.

Code:
sudo service lightdm stop

is the usual way (or substitute whatever dm you are using - if in doubt
Code:
ls /etc/init.d/*dm
should give some clues).

Also I have done some more research on aticonfig

1. aticonfig--set-pcs-val must be run as root, so needs to be preceded by sudo

2. --set-pcs-val seems to work, in that it changes the PCS database, even when X is running. I haven't tried restarting X to see if the changes stick with an X restart, but the database values certainly change, as can be seen with aticonfig --get-pcs-key

3. --set-pcs-val is actually deprecated and --set-pcs-u32 should be used instead. It should work the same
Quote:Note that --set-pcs-val is deprecated and --set-pcs-u32 should be used instead. --set-pcs-val will be removed soon.


4. Correcting what I said in post #11 you will not see a difference in xorg.config after changing the overscan setting via the commands we are discussing
Quote:Persistent Configuration Store (PCS) Options: Following options will not change the config file. They are used to manipulate the PCS database. Due to their nature, these. commands may only be run by the root user. Note that the prefix and key names are not case-sensitive.

(I got all this from aticonfig --help)

But the point remains, the changes from aticonfig will probably need a restart of X to take effect, unlike setting overscan in nvidia-settings.

aww sheet wsnipex beat me to some of that! <pedantmode>Actually wsnipex, I think SOME of aticonfig's settings are stored in xorg.config, just not the ones we are discussing.</pedantmode>
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
AMD Driver no overscan option00