Win XBMC 12.0 - TV channel switching takes longer than in 11.0 (with PVR)
#1
Hello,

Since I have updated from XBMC 11.0-pvr-margro to XBMC 12.0, tv channel switching takes much longer than before.
With 11.0 it was about 2 seconds and now with 12.0 it's about 6-7 seconds.
Maybe that seems not significiant to you in numbers, but trust me it feels like it's taking ages Smile

OS is Windows 7 32-Bit, backend is MediaPortal 1.2.3
XBMC MediaPortal Addon is configured default (TSReader).
Source is a DVB-S2 card.

I had the same issue while using 10.0.
Back then, I got rid of it when updating to 11.0 and using the new ability of defining the paths for timeshift buffer directory
in the XBMC - MediaPortal PVR Addon (in XBMC) and on the XBMC - MediaPortal Plugin on the backend (MediaPortal).
But there is again no possibility to define these paths in the (new, official) XBMC MediaPortal Addon...
I still see the two old XBMC MediaPortal addons (1.2.2.111, seperate addon for TSReader and ffmpeg, ability to define paths) in the list,
but they don't work anymore with the same configuration as in 11.0.

Does somebody have any idea what could be the issue?
Do I have to update to MediaPortal 1.3.0 Beta??
Is there a new PVR Plugin for the backend available?

Please tell me if you need any additional info.

Thanks
Moe
Reply
#2
Known issue. Can't be fixed easily.

The reason for the additonal delay of 5 sec is the added "stream change detection" on a channel switch. Channel switching could fail under Eden if the new channel had different streams (e.g. SD->HD or 2.0 audio to 5.1 audio), therefore the pvr developers added some code to restart the demuxing process on every channel switch. As a result, the channel switching is slower than under Eden.

I know where the delay comes from (ffmpeg library), but I can't solve it at the addon side. I'm currently testing several changes to both XBMC and the MediaPortal pvr addon to speed-up the channel switching again, but it is not stable enough yet to publish a modified Frodo build with these changes.

With respect to the shares: You will need to upgrade your TVServerXBMC plugin to 1.2.3.120 (or 1.2.200.120 for 1.3.0 beta). I've moved the share settings to the TVServerXBMC addon side. The MediaPortal PVR addon will now import the defined shares from the TVServerXBMC plugin.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#3
Hi Margro,

Thanks for the info!

As I understand your explanation, this delay occurs with every backend,
which means that it wouldn't be an option to change the backend to solve the issue?

I think I will then downgrade back to eden till a modified frodo build is available,
since I'm using XBMC mainly for Live TV.

Thanks
Moe
Reply
#4
I must follow this. I am trying to swtich from Media center/media browser/cluster f*** but working installation to XBMC pvr.
I noticed the channel delay and well that doesnt work for the wife! As stated it seems to affect all head ends, is one better than the other?
Reply
#5
As far as I know, all backends except VDR and TVHeadend (both Linux backends) show this behavior. VDR and TVHeadend do the demuxing process already at the backend side. All other backends like MediaPortal supply a raw stream to XBMC and XBMC is responsible for the demuxing.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#6
(2013-02-01, 23:33)margro Wrote: The reason for the additonal delay of 5 sec is the added "stream change detection" on a channel switch. Channel switching could fail under Eden if the new channel had different streams (e.g. SD->HD or 2.0 audio to 5.1 audio), therefore the pvr developers added some code to restart the demuxing process on every channel switch. As a result, the channel switching is slower than under Eden.
Excuse my igonorance, but wouldn't the demuxing processing have to be restarted on every channel switch anyway, unless the channel you switched to was in the same transponder as the previous channel?
Reply
#7
(2013-02-01, 23:33)margro Wrote: I know where the delay comes from (ffmpeg library), but I can't solve it at the addon side. I'm currently testing several changes to both XBMC and the MediaPortal pvr addon to speed-up the channel switching again, but it is not stable enough yet to publish a modified Frodo build with these changes.

margro, is there a thread that follows the MediaPortal pvr addon development?

Also, is this where I can get your latest code on git hub:
margro / xbmc-pvr-addons / addons / pvr.mediaportal.tvserver
Reply
#8
@steamroller16: No, I haven't started a development thread yet...
I'm currently quite busy, so no real news to tell...

Yes, the latest version of the pvr addon sources is my development branch at Github: https://github.com/margro/xbmc-pvr-addon...evelopment.

Most recent developments are around the slow channel switching. I managed to get it down to 2-4 {s} (unencrypted) with a small change in XBMC, which I'm testing on my HTPC. This change is included in my XBMC fork on github.
Note that this fix is only a workaround. Fernetmenta has already developed a better fix. I haven't tested it yet, but it is already included in the upstream ffmpeg library.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#9
@margro: thanks for the information and your efforts. I will try to compile Fernetmenta's fork (unless he posts builds somewhere).

I am currently experiencing 4-7s in XBMC versus 2s in MediaPortal directly.
Reply
#10
Hi margro,

can you confirm this? : http://forum.xbmc.org/showthread.php?tid...pid1357620

Is this really done with taking the tvserver.exe out of the virus scanning?

BR

Juro
Reply
#11
Tried this today, no change for me.
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC 12.0 - TV channel switching takes longer than in 11.0 (with PVR)0
This forum uses Lukasz Tkacz MyBB addons.