•   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 76
  •   
Release Picture Slideshow Screensaver
Thanks for this great addon!

If you admit one little suggestion, I think it would be great to give zoom&scroll life to background image while the front picture stands still.
Reply
Sad

I have not been able to get this addon to work at all. Running Kodi 15, pictures are on smb share and come up fine via pictures and manual kodi slideshow, but if I configure the addon to point to the smb share it does work. Launch never shows up (greyed out), via plugin and if I try preview in system settings it just shows a black screen.
Reply
One suggestion: select minimum image size / not show thumbnails.
I have image folders with thumbnails and original images, and I don't want to show the thumbnails.
Reply
Have been running this for sometime but something has changed recently - it seems like it is causing my TV to flicker/re-sync rate regularly. It seems to be because it's taking my tv out of 24p mode for some reason.

This repetitive re-syncing with this addon is running, not occurring at any other time (well except when it should, i.e. starting a new show).

Does this addon use the UI sync, or the sync of the currently play mode?

I'll try and get a debug log happening but just wanted to see if anyone had any ideas....
Addons I wrote &/or maintain:
OzWeather (Australian BOM weather) | Check Previous Episode | Playback Resumer | Unpause Jumpback | XSqueezeDisplay | (Legacy - XSqueeze & XZen)
Sorry, no help w/out a *full debug log*.
Reply
(2015-10-31, 06:16)bossanova808 Wrote: Have been running this for sometime but something has changed recently - it seems like it is causing my TV to flicker/re-sync rate regularly. It seems to be because it's taking my tv out of 24p mode for some reason.

This repetitive re-syncing with this addon is running, not occurring at any other time (well except when it should, i.e. starting a new show).

Does this addon use the UI sync, or the sync of the currently play mode?

I'll try and get a debug log happening but just wanted to see if anyone had any ideas....

nope this addon doesn't use anything like that. i doubt it's even possible for addons to mess with sync.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Yeah that's what I figured.

I noticed last night it doesn't do it with my projector so I suspect the HDMI cable between my amp and TV. Just odd that it only kicks in when the addon is running but probably has something to do with the type/amount of signal (I would have though it was always sending all frames so much the same with still and video - but there's no doubt there something different between the still image and video side of things when it comes to the resulting behaviour anyway!)

Thanks
Addons I wrote &/or maintain:
OzWeather (Australian BOM weather) | Check Previous Episode | Playback Resumer | Unpause Jumpback | XSqueezeDisplay | (Legacy - XSqueeze & XZen)
Sorry, no help w/out a *full debug log*.
Reply
I Cant get this to work with DX11 versions on Kodi, either versions 15.2 (DX11 version) or the alpha versions of 16.0. Is this expected and is it anticipated a version that supports DX11 will be released (I hope so as I really like this!!)

When I preview it, or it kicks in after 2 mins I just get a blank screen

Thanks
Reply
no idea. i'm not using windows.
there's a dx11 thread on the forum where you can report bugs though.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Just upgraded to Kodi 16 (alpha 4) from 15.2 and it doesn't work anymore.. log file

11:25:44 T:920 DEBUG: ADDON: Dll Initializing - Picture Slideshow Screensaver
11:25:44 T:920 ERROR: ADDON: Could not locate
Reply
(2015-11-03, 03:45)ferni Wrote: Just upgraded to Kodi 16 (alpha 4) from 15.2 and it doesn't work anymore.. log file

11:25:44 T:920 DEBUG: ADDON: Dll Initializing - Picture Slideshow Screensaver
11:25:44 T:920 ERROR: ADDON: Could not locate

please post a full Debug Log
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
My Jarvis simply lists the plugin as Broken / Disabled (don't know what the English translation is, but you get the idea.) Did an upgrade from Kodi Isengard, in which it worked splendidly.
Reply
If I try it through the Settings window, I also get the black screen. Pressing a random key gets me back into the Settings (like it would've done if pictures had actually been shown).

I upgraded Isengard to Jarvis alpha 4, Windows 8.1 x64. It worked before.

This is, I think, the relevant debug log piece. There are some irrelevant lines like those concerning the PVR plugin, but I didn't want to delete any. This is the part from where I pressed Enter in the Screensaver Settings, up to the point where I pressed a key and returned to that window.

Code:
20:29:56 T:4876   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
20:29:57 T:4876   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
20:29:57 T:4876   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
20:29:57 T:4876   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
20:29:57 T:4876   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - Announce(flag=GUI, sender=xbmc, message=OnScreensaverActivated)
20:29:57 T:4876   DEBUG: Activating window ID: 12900
20:29:57 T:4876   DEBUG: ------ Window Deinit (SettingsCategory.xml) ------
20:29:57 T:4876   DEBUG: ------ Window Init () ------
20:29:57 T:4876   DEBUG: ADDON: Dll Initializing - Slideshow
20:29:57 T:4876   ERROR: ADDON: Could not locate
20:29:58 T:4876   DEBUG: SECTION:UnloadDelayed(DLL: special://xbmcbin/system/ImageLib.dll)
20:30:03 T:2420    INFO: Platinum [neptune.http]: NPT_CHECK failed, result=-20014 (NPT_ERROR_TIMEOUT) [(result)]
20:30:03 T:4876    INFO: Previous line repeats 1 times.
20:30:03 T:4876   DEBUG: Keyboard: scancode: 0x39, sym: 0x0020, unicode: 0x0020, modifier: 0x0
20:30:03 T:4876   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
20:30:03 T:4876   DEBUG: ------ Window Deinit () ------
20:30:03 T:4876   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
20:30:03 T:4876   DEBUG: ------ Window Init (SettingsCategory.xml) ------




Alright, so I found out there's a new plugin 'Picture Slideshow' instead of just 'Slideshow'. I guess that's the one I should have been using, so I installed that one.

Unfortunately, that gives me the exact same problem. Black screen, no pictures. 'ADDON: Could not locate' in the log.
I can however get into the plugin's settings, so it does exist on my system..?

Code:
20:57:26 T:4156   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
20:57:26 T:4156   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
20:57:26 T:4156   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
20:57:26 T:4156   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
20:57:26 T:4156   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - Announce(flag=GUI, sender=xbmc, message=OnScreensaverActivated)
20:57:26 T:4156   DEBUG: Activating window ID: 12900
20:57:26 T:4156   DEBUG: ------ Window Deinit (SettingsCategory.xml) ------
20:57:26 T:4156   DEBUG: ------ Window Init () ------
20:57:26 T:4156   DEBUG: ADDON: Dll Initializing - Picture Slideshow Screensaver
20:57:26 T:4156   ERROR: ADDON: Could not locate


Okay, what's the next step?
Reply
(2015-11-03, 22:04)willemd Wrote: Okay, what's the next step?

double check if you've selected the 'Picture Slideshow Screensaver' in:
Settings > Appearance > Screensaver > Screensaver mode
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Yep, it's there!

Seeing the posts above, I guess it's a combination of the addon, Jarvis and Windows?



Here is a full log if that helps more: http://xbmclogs.com/pjy0fpokb
Reply
yeah that may well be the case.
it didn't occur to me some people would still be using the old screensaver.

i marked that one as broken a few years ago and everyone using it should've gotten a notification they should disable it.

thanx for the heads-up!
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
  •   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 76
  •   



Logout Mark Read Team Forum Stats Members Help
Picture Slideshow Screensaver4
This forum uses Lukasz Tkacz MyBB addons.