Thread Rating:
  • 0 Vote(s) - 0 Average
XBMC not starting after upgrade.
#1
Running ubuntu 12.04.1 and after the upgrade to v12 xbmc wont start anymore.
I have tried to search for people with the same problem but havent found anything
useful.

/usr/lib/xbmc/xbmc.bin: symbol lookup error: /usr/lib/xbmc/xbmc.bin: undefined symbol: _ZTIN6TagLib5ID3v219Latin1StringHandlerE

I would appreciate if someone could direct me to a solution to my problem.
Reply
#2
I'm using OpenSUSE 12.2 and using packman repository. Getting exactly same error after upgrading.

Edit: The below URL suggested that this could be due to repo (in OpenSUSE's case, packman):

http://forum.xbmc.org/showthread.php?tid=154096
Reply
#3
Clearly libtag problem, you need libtag 1.8 or greater and 12.04, doesn't have it. Otherwise it needs to be compiled from source as in XBMC source.
See my signature 2nd link for how to compile in Ubuntu derivatives. As for Suse the packager has to provide libtag 1.8 or compile from sources whatever that is.

You guys are lucky none of you pastebin a debug.log or trace or anything. If that one single line error is anything to go by, its libtag.

uNi
Reply
#4
Yeah - it became obvious once you pointed it out Smile

I built from the source using the official wiki (section 2.2.1.2 onwards): http://wiki.xbmc.org/index.php?title=How...SUSE_Linux

The build failed with taglib error (it has been few years since I had to build from source so had forgotten how painful dependency issues are). Anyway, I updated the taglib from 1.7 to 1.8 (that required switching repos as well for taglib):

Quote:....
replacement of libtag1-1.7.2-2.1.2.i586 with libtag1-1.8-47.2.i586
....
The following package is going to change vendor:
libtag1 openSUSE -> http://packman.links2linux.de

Once that was done, the build completed and I'm now running the new, shiny XBMC!
Reply
#5
@noisyboy

Good stuff, you know the wiki needs updating specially these parts IIRC that looks like written for V11.

You could register and confirm email in wiki and have a go cleanup and update hehe Wink

unfortunately I know nothing about suse :/

uNi
Reply
#6
I was unable to solve this problem on ubuntu lucid in an easy fashion, so i went the hard way


download the 6 files listed under "built filed" here: https://launchpad.net/~nathan-renniewald...ld/3792956

dpkg -i them all


everything will now work
Reply
#7
For those working on ubuntu x86_64 LTS;
the following worked for me;
sudo apt-get install libtag1-dev

(The origin of the issue was using nightly-builds to get
the latest stable updated mythtv working again)

sudo add-apt-repository ppa:nathan-renniewaldock/xbmc-nightly
sudo apt-get update
sudo apt-get install xbmc

then /usr/lib/xbmc/xbmc.bin: symbol lookup error: /usr/lib/xbmc/xbmc.bin: undefined symbol: _ZTIN6TagLib5ID3v219Latin1StringHandlerE

(fixed using libtag1-dev above)
Reply



XBMC not starting after upgrade.00