•   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
I'm curious as to why anyone was looking to add Margro's pvr patches to these dsplayer builds?

margro's pull request is targeting a work around to play "growing" files with ffmpeg without sampling them for such a long duration that subsequent channel changes cause freeze up

Doesn't dsplayer's filter config effect live tv playback as well? Or does live tv still default to the dvdplayer core?

If it's "effected" then you should be able to get the channel "zapping" effect during live tv by using the PDVD12 or MS DTV-DVD video decoders for mpeg2. All my live tv is mpeg2, but that isn't universal. LAV video is not great for channel zapping, much longer pause on channel change than the other two I mentioned. Has anyone tried these instead of margro's patch? Or does live tv playback in dsplayer builds bypass the filters config?
Reply
DSPlayer still uses XBMC dvdplayer for stream source & PVR.
Reply
Great to see DirecShow support on XBMC, the only reason i switched from linux to windows was the LAV filters, my cpu can't decode the h.264 10bit with dvdplayer but on LAV it takes about 40-60% on intese scenes where dvdplayer would drop the frames and go 100%.

Still there is some downsides too, it takes incredible long time to play big video files over ftp and sometimes the video won't even start where dvdplayer starts immediately. Also lack of wasapi on dsplayer was a bummer too, had to install reclock for that.

Any plans for madVR? tried it but the video pops up into seperated window, did i misconfigure avsplitter or it simply does not work yet?

Anyway thank you for your great efforts!
Reply
(2014-01-10, 23:56)oldpoem Wrote: DSPlayer still uses XBMC dvdplayer for stream source & PVR.

in some cases it is possible to use the "real dsplayer" for live tv / pvr:
http://forum.xbmc.org/showthread.php?tid...pid1557059

but i realy dont know if this will only work with dvbviewer recording service. i reckon you have to stream via http
Reply
I've an odd mkv bug.

Almost all MKVs play fine in dsplayer-xbmc, except some that stutter (missing frames here and there, making the screen flicker). Only certain MKVs do it, and they play fine in everything else (windows media player, vlc, etc.)

Tried playing with the codecs, no luck. Tried fullscreen true/window, nothing. DXVA on/off, nothing. Only fix is Use EVR instead of VMR9, but then it pops up the video in a new window where I can't use the remote control anymore.

I don't really know where to look to debug anymore, any ideas?
Reply
EVR is the way to go, and my video does not pop up in any new window.
Are u sure u're using DSPlayer or an external player instead?
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
My apologies, I'm on EVR, that's the one giving me issues (but only with certain MKVs, everything else is flawless). I confirm that DSPlayer is the player, not an external one.
Reply
Is it really popping up in a window where you can't use the remote? If it is, something is very wrong.

If you really want to chase this, download and install graphstudionext (https://code.google.com/p/graph-studio-next/ and the Windows SDK and register proppage.dll (Instructions for this part here).

Then while playing the video, 'attach' to the running graph and screenshot the graph and post here.

Alternatively, setup vlc or mpc-hc as an external player (see the wiki) and when you want to play one of those problem videos, when the title is highlighted in XBMC, press C and then select Play using and chose your external player.
Reply
(2014-01-19, 00:55)KenV99 Wrote: Is it really popping up in a window where you can't use the remote? If it is, something is very wrong.

If you really want to chase this, download and install graphstudionext (https://code.google.com/p/graph-studio-next/ and the Windows SDK and register proppage.dll (Instructions for this part here).

Then while playing the video, 'attach' to the running graph and screenshot the graph and post here.

Alternatively, setup vlc or mpc-hc as an external player (see the wiki) and when you want to play one of those problem videos, when the title is highlighted in XBMC, press C and then select Play using and chose your external player.


Thank you! You've given me many things to investigate. The second I've time to (code for when the kids decide to sleep hehehe), I'll try all of this and report back.
Reply
I haven't tried DSPlayer in over a year, but I downloaded the newest version and I'm still having the exact same problem as before. If I have PC speakers selected as my default Windows audio, it will output XBMC audio to those speakers rather than my home theater speakers which are the selected audio source in the XBMC settings. Does anyone have a fix for this?

EDIT: I have tried changing the audio renderer under the DSPlayer menu, but it doesn't fix it. It shows the correct audio renderer if I bring up the video stats information, but it still will only output out of my PC speakers unless I manually change the default audio via windows.
Reply
(2014-01-19, 03:41)Gabeloooooo Wrote: Thank you! You've given me many things to investigate. The second I've time to (code for when the kids decide to sleep hehehe), I'll try all of this and report back.

Also, if you installed over a previous non-DSPlayer Frodo build, I would back up your settings (especially any changes you made to the XML files located in the Program Files (x86)/XBMC directory) and then uninstall XBMC and reinstall with only the XBMC-DSPlayer package.
Reply
(2014-01-19, 06:46)tr0nllam Wrote: I haven't tried DSPlayer in over a year, but I downloaded the newest version and I'm still having the exact same problem as before. If I have PC speakers selected as my default Windows audio, it will output XBMC audio to those speakers rather than my home theater speakers which are the selected audio source in the XBMC settings. Does anyone have a fix for this?

EDIT: I have tried changing the audio renderer under the DSPlayer menu, but it doesn't fix it. It shows the correct audio renderer if I bring up the video stats information, but it still will only output out of my PC speakers unless I manually change the default audio via windows.

Can you explain your setup a bit more... Do you have a 5/7.1 setup via your AVR? Do you have HDMI/Optical connection?
Optoma HD Projector, Panasonic TX-P65VT65 Plasma, Pioneer SC2023 AVR, Kef Q65 main, iQ8ds rear, XQ2C centre, XBOX 360 Elite, Samsung LE40C650, SKY HD, Lutron Lighting, Crestron AV2 control

(Server)CPU - AMD Phenom ii 560, MB - M4A78LT-M, 32GB Corsair SSD, 4GB Corsair DDR3, 6x 1.5TB HDD's

XBMC Clients x2 (DSPlayer)
Reply
(2014-01-19, 06:46)tr0nllam Wrote: I haven't tried DSPlayer in over a year, but I downloaded the newest version and I'm still having the exact same problem as before. If I have PC speakers selected as my default Windows audio, it will output XBMC audio to those speakers rather than my home theater speakers which are the selected audio source in the XBMC settings. Does anyone have a fix for this?

EDIT: I have tried changing the audio renderer under the DSPlayer menu, but it doesn't fix it. It shows the correct audio renderer if I bring up the video stats information, but it still will only output out of my PC speakers unless I manually change the default audio via windows.

The issue with selecting a non-default audio-renderer is known. Unfortunately, there's no solution so far. Sometimes selecting a non-DirectSound audio-renderer helps, but not always.
Reply
(2014-01-19, 06:46)tr0nllam Wrote: I haven't tried DSPlayer in over a year, but I downloaded the newest version and I'm still having the exact same problem as before. If I have PC speakers selected as my default Windows audio, it will output XBMC audio to those speakers rather than my home theater speakers which are the selected audio source in the XBMC settings. Does anyone have a fix for this?

EDIT: I have tried changing the audio renderer under the DSPlayer menu, but it doesn't fix it. It shows the correct audio renderer if I bring up the video stats information, but it still will only output out of my PC speakers unless I manually change the default audio via windows.

If you want to have XBMC playing audio to one set of speakers and have a different program playing audio to a different set of speakers at the same time, then you are out of luck. Microsoft doesn't seem interested in allowing this.

If you are on Windows 7 and just want to automatically change the default device on XBMC startup, there is a command line program that can be used to change the default audio device. You can find it here (download link at the bottom of the page): http://www.daveamenta.com/2011-05/progra...windows-7/. I don't have Windows 8 so I can't say if this still works using it.

In the downloaded zip, all you need is the EndPointController.exe under the release directory. You could put that in a convenient location and create a script to run that program from the command line prior to launching XBMC. To sort out how your audio devices are enumerated, open a cmd window and navigate to where you placed the exe and just run the exe without any options. This will give you back the numbers corresponding to your devices. Then you could write the batch script with the number of the device that you want to have as the default when XBMC runs as the option for the exe (i.e. EndPointController.exe 2) and then launch XBMC. If you want to switch back after XBMC programmatically, you could use something like autohotkey for the script and launch XBMC with the RunWait command and then use EndPointController.exe a second time with the option set to switch back to whatever device you want as default when XBMC isn't running. Hope this helps.
Reply
(2014-01-06, 16:43)deh2k7 Wrote:
(2014-01-06, 06:44)deh2k7 Wrote:
(2014-01-04, 19:36)deh2k7 Wrote: I've been away for quite some time and want to take advantage of some of the latest improvements. Currently I use a full LAV setup, splitter and decoders.

I'd like to update my setup to have DSPlayer with FFDShow RAW scaling to improve image quality. I assume I should also switch from LAVSplitter to AVSplitter. From my research, it looks like this is a good guide for setting up FFDShow RAW: http://www.ezoden.com/684/tutorial-htpc/7

Can someone confirm this and comment if any steps are unnecessary or anything else needs to be done for FFDShow RAW postprocessing? I am planning on using the AVISynth part of the setup.

As far as mediasconfig and filters config, can someone post their current XML for such a setup?

Finally, I have some questions about SVP. I'm just learning about it today. It looks like it also uses AVISynth in order to work. Does anyone have suggestions for how AVISyth should be set up with FFDShow RAW post processing? Maybe a pointer to another guide?

Are there any drawbacks to using SVP?

All of my files are either mkv or mpg, most are direct rips, but I have used x264 to re-encode my some of my larger BR Rips from my collection. Thanks again for the help!

OK, after digging around some more, i think i have found what I need for getting FFD in RAW mode and Avisynth working with my setup. I'll post my config once it's all complete.

I have a question, however. I set up multiple profiles for FFDShow for different processing based on qhat the original source material. FOr example 1080p material gets a lot let 'stuff' than 480 DVD rips. Unfortunately, whenever XBMC plays a file, only the standard 'default' profile is ever used, despeite me configuring for different profiles based on incoming resolution. Does anyone have any recommendations on how to use a profile other than default?

i realize that I may have been a bit unclear.

For ALL media files, regardless of resolution, in DSPlayer, I use the following config: AVSplitter, LAV for Audio/Video, and extra Filter for FFDShow RAW. I have separate profiles configured in FFDShow for different resolutions, i.e. don't want scaling resizing for 1080p, but i do for other incoming resolutions. I can't seem to get FFDShow to select the appropriate profile when XBMC calls the FFDShow RAW filter. Is this possible? If so, can someone provide an example on the FFDShow front to help me do this?
Did you get it to work, and made a guide?

I would like use LAV filters to all + use FFDShow RAW only.

I anyone has a guide to SVP with FFDShow RAW only it would be very helpful.
Reply
  •   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58