•   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
(2014-02-01, 09:39)gregh77 Wrote: i tried but im not sure if im doing it right. thanks for the help. in the media config file i have this..

<rule filetypes="avi|divx|ogm|flv|mp4|mov|m4v|m2v|ts|mpeg|mpg|m2ts|mkv">
<source filter="haali" />
<splitter filter="haali" />
<video filter="lavvideodec" />
<audio filter="lavaudiodec" />
<extra>
<extra filter="ffdrawvid" />
</extra>
</rule>

the file plays in DSPlayer, it just isnt activating SVP, says its still waiting

Constructing that filter graph on my work machine works with SVP without a problem (as it should):
Image

Once you get it playing in DSplayer you can pause it and open graphstudionext and then click File->Connect to Remote Graph and unless you have something else also playing using DS, just click on the only thing that comes up.
You need to have Windows SDK installed and have registered proppage.dll. Instructions are here for using it with MediaPortal, but it works the same with XBMC.
Reply
(2014-02-01, 12:59)KenV99 Wrote:
(2014-02-01, 09:39)gregh77 Wrote: i tried but im not sure if im doing it right. thanks for the help. in the media config file i have this..

<rule filetypes="avi|divx|ogm|flv|mp4|mov|m4v|m2v|ts|mpeg|mpg|m2ts|mkv">
<source filter="haali" />
<splitter filter="haali" />
<video filter="lavvideodec" />
<audio filter="lavaudiodec" />
<extra>
<extra filter="ffdrawvid" />
</extra>
</rule>

the file plays in DSPlayer, it just isnt activating SVP, says its still waiting

(2014-02-01, 11:47)steelman1991 Wrote: If your using KenV99's mediasconfig and filtersconfig as a template, then your 'extra' filter is incorrect - it should be <extra filter="ffdrawdec" />

Indeed, it depends on how you named it in filtersconfig.xml. Can you post that or a link to that in pastebin?

http://pastebin.com/zfer2hrv

thanks for taking the time to help Ken

(2014-02-01, 11:47)steelman1991 Wrote: If your using KenV99's mediasconfig and filtersconfig as a template, then your 'extra' filter is incorrect - it should be <extra filter="ffdrawdec" />

i did try his config files but i couldnt even get a video to play....
edit - i got his config files to work, i didnt have avsplitter registered Sad. but FFDRaw still isnt starting. getting closer!!
Reply
It looks OK. I think the next step really is to use graphstudionext (gsn) to connect to the filter graph while dsplayer is playing the video. I will assume that the graph will show that ffdshowraw isn't loading. I would check the information about that filter in gsn by clicking on Graph->Insert Filter and scrolling down to ffdshow raw video filter. Make sure the GUID matches the one in filtersconfig.xml, that the file actually exists in the path given, etc. And, as I mentioned, then restart gsn and construct the graph manually and make sure that it connects to SVP.
Reply
(2014-02-01, 19:08)KenV99 Wrote: It looks OK. I think the next step really is to use graphstudionext (gsn) to connect to the filter graph while dsplayer is playing the video. I will assume that the graph will show that ffdshowraw isn't loading. I would check the information about that filter in gsn by clicking on Graph->Insert Filter and scrolling down to ffdshow raw video filter. Make sure the GUID matches the one in filtersconfig.xml, that the file actually exists in the path given, etc. And, as I mentioned, then restart gsn and construct the graph manually and make sure that it connects to SVP.

the GUID was different, changed but still no go... Sad

i tried it in MPC-HC and SVP is working well.... not that it matters with DSPlayer.
Reply
(2014-02-01, 20:27)gregh77 Wrote: the GUID was different, changed but still no go... Sad

i tried it in MPC-HC and SVP is working well.... not that it matters with DSPlayer.

Can you screenshot the graph that you get in gsn when you connect to DSPlayer/XBMC?
Check your XBMC.log to make sure there isn't something we're missing.
Reply
got it working! when i added XBMC to the whitelist for some reason it wasnt saving it. thanks guys for all the hellp. now i am getting SVP performance is too low. i tried to lower SVP all the way to 1G but i still get the same message then i get a little stuttering with audio lag. when i run this in MPC-HC i have it set to 4G while using MadVR with Linc 3 tap and my CPU would hover around 60-75%, but wouldnt get this message or audio trouble. on this i am getting the same CPU load with the error. i have an i5 sandy bridge, 8GB RAM, and a GTX660 running about 30-45% load...
man i thought i had it lol.....
Reply
(2014-02-01, 21:28)gregh77 Wrote: got it working! when i added XBMC to the whitelist for some reason it wasnt saving it. thanks guys for all the hellp. now i am getting SVP performance is too low. i tried to lower SVP all the way to 1G but i still get the same message then i get a little stuttering with audio lag. when i run this in MPC-HC i have it set to 4G while using MadVR with Linc 3 tap and my CPU would hover around 60-75%, but wouldnt get this message or audio trouble. on this i am getting the same CPU load with the error. i have an i5 sandy bridge, 8GB RAM, and a GTX660 running about 30-45% load...
man i thought i had it lol.....

Well, I'm glad that you got it working, but your performance problems are pretty disappointing. Post back if you ever sort out why that is happening to you.
Reply
It may be something with the filters? Some reason both ffdshow audio filter and lav audio filter is running at the same time. Maybe that's causing an issue. I'll research when I be back home. Thanks again...
Reply
Make sure you still are using CUDA. I had that get turned off accidentally when I was working on the system via RDP.
Reply
im planning of trying out DSPlayer on XBMC, but i have a few questions.

Almost everything i watch, is 1080p mkv bluray rips. Using an HTPC with AMD A10, and a Yamaha RX-A2010.

Is it just plug and play, or do i have to "set it up"? anything that i should do to get better audio/video?
HTPC: AMD A10-7850K - MSI A78M-E45 V2 - HyperX Genesis 8GB DDR3 1866Mhz - 120GB+240GB HyperX SSD + 86TB HGST HDD
Plasma: Panasonic TX-P65VT60 Receiver: Yamaha RX-A3020 Surround: Jamo S608, Jamo C60 Center + C60 Surround Subwoofer: XTZ W12.18 ICE
Kodi 14.2 w/Shednox v.3.0
Reply
There is some set-up required - have a look at the wiki http://wiki.xbmc.org/index.php?title=DSPlayer
Reply
(2014-02-03, 08:39)steelman1991 Wrote: There is some set-up required - have a look at the wiki http://wiki.xbmc.org/index.php?title=DSPlayer

I will have a look. Im new to this, but is it anything i NEED to do? I know i want my receiver to decode my audio, other than that Im quite blank.

The reason i want to try out DS is that i have audio sync issues with the xbmc player.
HTPC: AMD A10-7850K - MSI A78M-E45 V2 - HyperX Genesis 8GB DDR3 1866Mhz - 120GB+240GB HyperX SSD + 86TB HGST HDD
Plasma: Panasonic TX-P65VT60 Receiver: Yamaha RX-A3020 Surround: Jamo S608, Jamo C60 Center + C60 Surround Subwoofer: XTZ W12.18 ICE
Kodi 14.2 w/Shednox v.3.0
Reply
(2014-02-03, 12:11)Simkin84 Wrote:
(2014-02-03, 08:39)steelman1991 Wrote: There is some set-up required - have a look at the wiki http://wiki.xbmc.org/index.php?title=DSPlayer

I will have a look. Im new to this, but is it anything i NEED to do? I know i want my receiver to decode my audio, other than that Im quite blank.

The reason i want to try out DS is that i have audio sync issues with the xbmc player.

The short answer is YES, there is a lot you NEED to know, if you are trying to troubleshoot a problem. Especially because I am unsure that DSPlayer will give you what you want and may only add complexity.

In native XBMC, you can have your receiver decode audio and then troubleshoot:
For audio pass-through (which is what you are referring to), read here: http://wiki.xbmc.org/index.php?title=Set...dio_output
For sync issues, look here: http://wiki.xbmc.org/index.php?title=Vid...e_settings
and here: http://wiki.xbmc.org/index.php?title=Set...s#Playback
Reply
(2014-02-03, 12:28)KenV99 Wrote:
(2014-02-03, 12:11)Simkin84 Wrote:
(2014-02-03, 08:39)steelman1991 Wrote: There is some set-up required - have a look at the wiki http://wiki.xbmc.org/index.php?title=DSPlayer

I will have a look. Im new to this, but is it anything i NEED to do? I know i want my receiver to decode my audio, other than that Im quite blank.

The reason i want to try out DS is that i have audio sync issues with the xbmc player.

The short answer is YES, there is a lot you NEED to know, if you are trying to troubleshoot a problem. Especially because I am unsure that DSPlayer will give you what you want and may only add complexity.

In native XBMC, you can have your receiver decode audio and then troubleshoot:
For audio pass-through (which is what you are referring to), read here: http://wiki.xbmc.org/index.php?title=Set...dio_output
For sync issues, look here: http://wiki.xbmc.org/index.php?title=Vid...e_settings
and here: http://wiki.xbmc.org/index.php?title=Set...s#Playback

The audio sync issue are the well known 24p "bug" 50 and 60hz are fine. Was hoping that with DS i could get perfect audio sync. I have been troubleshooting alot on this, and it seems not so easy to fix.
HTPC: AMD A10-7850K - MSI A78M-E45 V2 - HyperX Genesis 8GB DDR3 1866Mhz - 120GB+240GB HyperX SSD + 86TB HGST HDD
Plasma: Panasonic TX-P65VT60 Receiver: Yamaha RX-A3020 Surround: Jamo S608, Jamo C60 Center + C60 Surround Subwoofer: XTZ W12.18 ICE
Kodi 14.2 w/Shednox v.3.0
Reply
(2014-02-03, 12:55)Simkin84 Wrote: The audio sync issue are the well known 24p "bug" 50 and 60hz are fine. Was hoping that with DS i could get perfect audio sync. I have been troubleshooting alot on this, and it seems not so easy to fix.

If when you playback a file using another DirectShow based player, such as MPC-HC, you do not have sync issues with 24Hz video, then DSPlayer may be a solution for you.
Reply
  •   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58
This forum uses Lukasz Tkacz MyBB addons.