•   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
#76
(2013-02-11, 12:42)Roman_V_M Wrote:
(2013-02-10, 15:55)hanserson1 Wrote: Thanks for the answer Roman but this is already configured properly. Meanwhile I found the culprit. When I start BD ISOs the ReclockHelper.dll hangs and XBMC gets a time out. When I end the dll with the task manager XBMC proceeds to the menu slection and the BD starts to play after selection a title. Any suggestions why reclock behaves like this only with BD ISOs?

I don't use reclock, so no idea.

Quote:The second issue which came up is stopping mkv videos which are packed in rar. Using AV Splitter with LAV video codecs in the mediaconfig.xml does start these files correctly but once I push the stop button XMBC chrashes. This is reproducible almost every time I try to play rared mkv files. Am I the only one where this happens or is it a bug? I use the frodo version from the 2nd of Feb. in the first post of this thread.

Maybe a bug, maybe not. Anyway, this is a very weird use case. Why do you pack your videos in RAR anyway? Common compression algorithms (ZIP, RAR, LZW etc.) do not work on files which are already compressed with any type of multimedia compression (mp3, mpeg, xvid, h264 etc.), thus providing absolutely no compression benefits on such files.

(2013-02-11, 10:45)Skank Wrote: Roman?

If you keep nagging me every day, I'll add you to my ignore list, and that will be the end of story. If you haven't noticed, this is not a commercial product, and this topic is not a paid support line with response time set in a SLA, so I post in this topic only when I have time and (most importantly) desire to do so. Period.

Gonna hazard a guess that they download in rar format for seeding purposes - unrar loses the ability to re-seed.
Reply
#77
Wow. It was just a question..
Guess i know your answer..
Reply
#78
Skank, don't take it wrong. Even i noticed u're being TOO insistent, u want things done now. This is a forum, and things go this way. Have a little patience and don't hassle people.
It can take time.
Cheers and peace.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
#79
(2013-02-11, 13:39)vicmanpergar Wrote: Skank, don't take it wrong. Even i noticed u're being TOO insistent, u want things done now. This is a forum, and things go this way. Have a little patience and don't hassle people.
It can take time.
Cheers and peace.

It wasnt meant to sound like hassling..
Its just that its always just not bugfree
Xbmc frodo doesnt play flawlass..
External players hasngt got the in play gui
And now dsplayer has some concert bug..
Theres with every way always something not working..

But i know... Everything is voluntary... For which i really have respect...

So if i sundtopushy..dont take it wrong... I just want it to be fixed so i can have it all running...
But i do know that if someone doesnt see the bug cause hr/she isnt using itthat way..it takes some time to fix/test it

Ah Sad sorry ipad typing isnt that good either lol.. I typ too quick
Reply
#80
Roman,

In regards to subtitles:

A) dsplayer ignores preferred subtitle language settings in xbmc (always play the first subtitle stream)
B) dsplayer loads internal mkv-muxed subtitles *before* external srt ones (so if there are two muxed streams and one srt the order will be 1. muxed, 2.muxed, 3.srt).

the combination of the two results in me having to manually change subtitle language on each and every file I start to play.
the preferred behavior is that SRT subtitles load before the mkv-muxed ones (obviuously, if I bothered to put an SRT, makes sense that I'd want to display it), or at least have dsplayer honor the preferred language setting in xbmc.

Any chance to get these to the developer to be fixed?

Thank you! Smile
Reply
#81
(2013-02-08, 01:13)ArieS Wrote: Roman, any chance you can forward my debug log to Eduard?
My issue is when I stop playing a video using DSPlayer, I get no navigation sounds and when I try to exit XBMC I get a black screen and can't access the desktop. I need to reboot the HTPC.
Also if I try to change the Audio settings under Settings/System/Audio after I played a video, XBMC crashes.
This happens only when I use DSPlayer. If I use DVDPlayer, no issues whatsoever.

http://xbmclogs.com/show.php?id=33748

Please thank him for all his hard work for all of us.
And thanks to you for being the 'messenger' between him and us.

One more thing, does anyone have a problem with fast forwarding? If I press the button once I see the x2 but it plays at reg speed and if I press more than once I can see x16 but it only fast forward at x2 speed.

(2013-02-08, 12:41)ArieS Wrote:
(2013-02-08, 09:26)Roman_V_M Wrote: 2 ArieS

As far I can see, you're using an outdated build. As for RW/FF, there's indeed something wrong with it.
Hmmm, I'm using the build you had posted maybe a week ago but anyway, I've been having this same issue since I started using DSPlayer, so I think it was with Frodo RC2 or 3, I forgot.
I guess I'll try the latest build you posted and report back.
Ok, I'm now using the final build you posted on the 1st page and I've got the same issue.
I've even tried to mess around with the sound config in Windows, changing from 24bits to 16bits. trying to uncheck the Exclusive Mode for the sound, still no luck.
From my log, I'm sure it has something to do with :
14:50:52 T:4492 ERROR: CAESinkDirectSound::UpdateCacheStatus: GetCurrentPosition failed. Unable to determine buffer status. HRESULT = 0x88780096
14:50:52 T:4492 ERROR: CSoftAE::RunOutputStage - sink error - reinit flagged

and
14:50:52 T:4492 ERROR: CAESinkDirectSound::CheckPlayStatus: Failed to play the DirectSound buffer: unknown

But I have no idea what that means so Sad Anyone has a clue?

By the way, you guys set up your audio in Windows as it says here in the sticky, right?
Box 1: Vero 4K
Box 2: Intel NUC D34010WYK (Windows afedchin's Krypton MVC Build)
Box 3: ChromeBOX
RIP schimi2k | I miss you buddy :(
Reply
#82
Yes, in my case, AMD High Definition Audio Device (HDMI)
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
#83
(2013-02-11, 13:19)steelman1991 Wrote: Gonna hazard a guess that they download in rar format for seeding purposes - unrar loses the ability to re-seed.

Yes, now I have remembered that some trackers and binary newsgroups use multi-volume RARs for file distribution. But this is completely unknown practice in our part of the world, so I wouldn't hold your breath for this to be fixed any time soon.

(2013-02-11, 14:14)purpleman Wrote: Roman,

In regards to subtitles:

A) dsplayer ignores preferred subtitle language settings in xbmc (always play the first subtitle stream)
B) dsplayer loads internal mkv-muxed subtitles *before* external srt ones (so if there are two muxed streams and one srt the order will be 1. muxed, 2.muxed, 3.srt).

the combination of the two results in me having to manually change subtitle language on each and every file I start to play.
the preferred behavior is that SRT subtitles load before the mkv-muxed ones (obviuously, if I bothered to put an SRT, makes sense that I'd want to display it), or at least have dsplayer honor the preferred language setting in xbmc.

Any chance to get these to the developer to be fixed?

Thank you! Smile

As for subtitle streams, as I understand, they are handled not by a DSplayer itself but by a splitter filter. Try to set up your splitter. E.g. AVsplitter allows you to select default languages for audio and subs.

(2013-02-11, 21:29)ArieS Wrote: Ok, I'm now using the final build you posted on the 1st page and I've got the same issue.
I've even tried to mess around with the sound config in Windows, changing from 24bits to 16bits. trying to uncheck the Exclusive Mode for the sound, still no luck.
From my log, I'm sure it has something to do with :
14:50:52 T:4492 ERROR: CAESinkDirectSound::UpdateCacheStatus: GetCurrentPosition failed. Unable to determine buffer status. HRESULT = 0x88780096
14:50:52 T:4492 ERROR: CSoftAE::RunOutputStage - sink error - reinit flagged

and
14:50:52 T:4492 ERROR: CAESinkDirectSound::CheckPlayStatus: Failed to play the DirectSound buffer: unknown

But I have no idea what that means so Sad Anyone has a clue?

By the way, you guys set up your audio in Windows as it says here in the sticky, right?

If this issue is specific to your system, I'm afraid there's little that can be done. The final Frodo build has been posted a while ago, and I guess there would have been mass outcry in this topic if it had had major issues.
The recent sound issues were easily reproducible and that is why they were fixed rather quickly.
Try to test different combination of sound renderers (in DSplayer and in XBMC itself, because they are independent).
Reply
#84
(2013-02-12, 12:37)Roman_V_M Wrote:
(2013-02-11, 13:19)steelman1991 Wrote: Gonna hazard a guess that they download in rar format for seeding purposes - unrar loses the ability to re-seed.

Yes, now I have remembered that some trackers and binary newsgroups use multi-volume RARs for file distribution. But this is completely unknown practice in our part of the world, so I wouldn't hold your breath for this to be fixed any time soon.

Was only answering on behalf of someone else - no worries if it never gets fixed lol.
Reply
#85
(2013-02-12, 12:37)Roman_V_M Wrote: As for subtitle streams, as I understand, they are handled not by a DSplayer itself but by a splitter filter. Try to set up your splitter. E.g. AVsplitter allows you to select default languages for audio and subs.

Thanks for your reply, however - you're mistaken. dsplayer is in control of the splitter, not the other way around:

The way it works (and I've read the source code to confirm this) is dsplayer querys the splitter for a list of available subtitle streams embedded in the (mkv) file. The splitter then reports back with the list, and dsplayer builds an internal array with matching entries. So if the splitter returned a list of 3 streams (eng,spa,fre), dsplayer's array would then be: [1. English] [2. Spanish] [3. French] (in this exact order). After that's done, dsplayer calls another function that checks for available EXTERNAL (file/srt) subtitles. If it finds such a file (German, for instance), it appends it to the end of the array so we get [1. English] [2. Spanish] [3. French] [4. German (External)]. After the array is built, dsplayer plays the first subtitle in the array (in our case - English from the splitter).

This behaviour is bad. It should be one of two options:

1) scan for external subtitles BEFORE querying the splitter (thus adding external subtitles to the top of the list) - this makes sense because if you bothered placing an external file, it's logical that you want that file to be selected.
2) leave the scanning order as it is, but after scanning is complete check xbmc's preferred subtitle language setting and automatically set to that language (whether it's internal from the splitter or external from a file).

by the way, dvdplayer does both (checks preferred language AND prefers external subtitles first).

I'd really love for this to get fixed, hope you can help Smile
Reply
#86
Update:

Covers, posters and fanart isnt shown in "concerts" (musicvideos)
I tried with aeon nox skin, aeon mq4, and it doesnt work

Using frodo built posted on first page..
So this is definately no skin bug but a dsplayer bug!
Using normal xbmc final built and everything works...

I hope this isnt being ignored..
Reply
#87
And if it is, you'd only have yourself to blame
Reply
#88
(2013-02-13, 12:42)steelman1991 Wrote: And if it is, you'd only have yourself to blame

Im just trying to narrow it down...
Perhaps it was a skin issue... So i tested 3 skins.. To be sure...
And i wanted to post my findings, whats wrong with that?
Reply
#89
Its called a thinly veiled bump - show some patience.

Many bugs etc are only fixed here where a dev has a particular interest in resolving it, If they have no desire to use the function they may choose to ignore it where it doesn't impact on them.

Keep pressing the issue though, I'm sure Roman's finger is continually hovering over the 'ignore' button.
Reply
#90
(2013-02-12, 23:43)purpleman Wrote:
(2013-02-12, 12:37)Roman_V_M Wrote: As for subtitle streams, as I understand, they are handled not by a DSplayer itself but by a splitter filter. Try to set up your splitter. E.g. AVsplitter allows you to select default languages for audio and subs.

Thanks for your reply, however - you're mistaken. dsplayer is in control of the splitter, not the other way around:

Not quite true. DSplayer indeed ignores XBMC language settings, however choosing appropriate languages (eng/eng for me) in AVsplitter setting works. As for external subs, I agree that they should be given priority.

(2013-02-13, 16:58)steelman1991 Wrote: Many bugs etc are only fixed here where a dev has a particular interest in resolving it, If they have no desire to use the function they may choose to ignore it where it doesn't impact on them.

True. Anyway, I passed the info a while ago, and the rest does not depend on me.
Reply
  •   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58
This forum uses Lukasz Tkacz MyBB addons.