•   
  • 1
  • 43
  • 44
  • 45(current)
  • 46
  • 47
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
(2014-03-13, 13:59)oldpainless Wrote: Good job guys Big Grin

As well as the subs, pressing i in play mode is not show movie info etc.

K
i noticed but i don't know where those info are requested within xbmc so i can't find out where the problem is coming from
Reply
(2014-03-13, 14:10)tiben20 Wrote:
(2014-03-13, 13:59)oldpainless Wrote: Good job guys Big Grin

As well as the subs, pressing i in play mode is not show movie info etc.

K
i noticed but i don't know where those info are requested within xbmc so i can't find out where the problem is coming from

Ok thanks Tiben.
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Onkyo TX-NR686, Samsung UE55KS8000, Mission M35i speakers, Kodi Dsplayer 17.6 X64
Reply
oldpainless i just tested the subtitles and they work
Reply
(2014-03-13, 15:21)tiben20 Wrote: oldpainless i just tested the subtitles and they work

Subtitles is not working here as well (Gotham beta 1 DSPlayer). It works fine with internal DVDPlayer though. Probably need some files from older build of DSPlayer (libass libsubs etc.) ?

Update: Copy over libsubs.dll from older build of DSPlayer and copy to /system/dsplayer solved the issue,
Reply
(2014-03-13, 15:21)tiben20 Wrote: oldpainless i just tested the subtitles and they work

My bad - subs work here too.

Thanks.
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Onkyo TX-NR686, Samsung UE55KS8000, Mission M35i speakers, Kodi Dsplayer 17.6 X64
Reply
i bet it was from the build with the missing dsplayer folder in the system directory. When you compile it try to copy libsubs but the copy return an error with the destination folder missing.

Ps: i think i found where is the problem with madvr not rendering the gui.
Reply
(2014-03-13, 16:13)tiben20 Wrote: Ps: i think i found where is the problem with madvr not rendering the gui.

Fingers crossed Big Grin
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Onkyo TX-NR686, Samsung UE55KS8000, Mission M35i speakers, Kodi Dsplayer 17.6 X64
Reply
ok

i solve the problem with the infolabel e infotag in osd



the latest build: XBMC_13_beta1_dsplayer_(build6)_exeonly.rar

(2014-03-13, 16:13)tiben20 Wrote: Ps: i think i found where is the problem with madvr not rendering the gui.

great Smile
Reply
I've been using the Dsplayer build for Eden and Frodo for a couple years now and have been very happy with the ability to use ffdshow and filters for viewing media. I do have one issue I've been trying to resolve for awhile now that I thought I would ask for some input. Currently I have a very simply playercorefactory.xml that just uses dsplayer for Avi/Mkv/Mp4 files and everything else defaults to dvdplayer.

<playercorefactory>
<rules action="prepend">
<rule filetypes="mkv|avi|mp4" player="dsplayer"/>
</rules>
</playercorefactory>

I've noticed that some programs like ESPN3 seem to stream mp4 files as when I try to watch a sporting event it will not work unless I use the option to watch with dvdplayer. I confirmed this was the case by removing the mp4 from my playercorefactory.xml which worked but of course I then end up with dvdplayer as the default for mp4 files I have. I'm looking for a solution that would use dvdplayer for mp4 files that are streamed and use dsplayer for mp4 files stored locally. I know there are rules for defaulting streaming to dvdplayer but in my case it already is the default.

thanks for any help..
Reply
(2014-03-14, 03:03)uncertainty Wrote: I've been using the Dsplayer build for Eden and Frodo for a couple years now and have been very happy with the ability to use ffdshow and filters for viewing media. I do have one issue I've been trying to resolve for awhile now that I thought I would ask for some input. Currently I have a very simply playercorefactory.xml that just uses dsplayer for Avi/Mkv/Mp4 files and everything else defaults to dvdplayer.

<playercorefactory>
<rules action="prepend">
<rule filetypes="mkv|avi|mp4" player="dsplayer"/>
</rules>
</playercorefactory>

I've noticed that some programs like ESPN3 seem to stream mp4 files as when I try to watch a sporting event it will not work unless I use the option to watch with dvdplayer. I confirmed this was the issue by removing the mp4 from my playercorefactory.xml which worked but of course I then end up with dvdplayer as the default for mp4 files I have. I'm looking for a solution that would use dvdplayer for mp4 files that are streamed and use dsplayer for mp4 files stored locally. I know I there are rules for defaulting streaming to dvdplayer but in my case it already is the default.

thanks for any help..

Try add this line

<rule name="other" protocols="daap|rtv|rtsp|rtmp|http|https|rtmpe|rtsp|mms|rtp|pvr" player="DVDPlayer" />

Since it was stream most case xbmc would look for protocol not file type.
Reply
i've fixed the problem with dsplayer's database creation
added the dsplayer's option for the subtitle: border, shadow, alpha

i don't know if there are other things to fix

but it seem that work good now


night

ciauzzz
Reply
(2014-03-14, 03:32)oldpoem Wrote: Try add this line

<rule name="other" protocols="daap|rtv|rtsp|rtmp|http|https|rtmpe|rtsp|mms|rtp|pvr" player="DVDPlayer" />

Since it was stream most case xbmc would look for protocol not file type.

I should have added I tried adding that streaming rule earlier but it had no effect. It could be how ESPN3 and a few other addons are written but they use the .mp4 extension while streaming. Here is a snippet from the XBMC.log for the ESPN3 addon.

<video src="mp4:lfc/replay/rtmp/espn/2014/03/13/176-194321/web-encodes/1703049_espn_400k/1703049_espn_400k.mp4" system-bitrate="400000">
</video>
<video src="mp4:lfc/replay/rtmp/espn/2014/03/13/176-194321/web-encodes/1703049_espn_800k/1703049_espn_800k.mp4" system-bitrate="800000">
</video>
<video src="mp4:lfc/replay/rtmp/espn/2014/03/13/176-194321/web-encodes/1703049_espn_1200k/1703049_espn_1200k.mp4" system-bitrate="1200000">
</video>
<video src="mp4:lfc/replay/rtmp/espn/2014/03/13/176-194321/web-encodes/1703049_espn_2200k/1703049_espn_2200k.mp4" system-bitrate="2200000">
</video>

Notice the video scr=mp4 which then causes dsplayer to try to play the video which fails and thus I then have to manually, within the ESPN3 addon, change the video to use dvdplayer per stream. I was just wondering if any other dsplayer and ESPN3 users have found a solution for using dvdplayer for the mp4 stream and dsplayer for the locally stored mp4's?
Reply
Try something like this then

<rule name="espn" filename="*espn*" player="DVDPlayer" />

Not sure if it would work but I guess it's worth a try.
Reply
(2014-03-14, 00:44)aracnoz Wrote: ok

i solve the problem with the infolabel e infotag in osd



the latest build: XBMC_13_beta1_dsplayer_(build5)_exeonly.rar

(2014-03-13, 16:13)tiben20 Wrote: Ps: i think i found where is the problem with madvr not rendering the gui.

great Smile

Works great - thanks.
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Onkyo TX-NR686, Samsung UE55KS8000, Mission M35i speakers, Kodi Dsplayer 17.6 X64
Reply
(2014-03-14, 00:44)aracnoz Wrote: ok

i solve the problem with the infolabel e infotag in osd



the latest build: XBMC_13_beta1_dsplayer_(build6)_exeonly.rar

(2014-03-13, 16:13)tiben20 Wrote: Ps: i think i found where is the problem with madvr not rendering the gui.

great Smile

UPDATE - can anyone confirm that they can get DNLA working with this build? For me, XBMC is not broadcasting as a DNLA renderer.
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Onkyo TX-NR686, Samsung UE55KS8000, Mission M35i speakers, Kodi Dsplayer 17.6 X64
Reply
  •   
  • 1
  • 43
  • 44
  • 45(current)
  • 46
  • 47
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58