•   
  • 1
  • 87
  • 88
  • 89(current)
  • 90
  • 91
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
(2015-03-29, 20:34)Slurm Wrote: I have an interesting problem with madVR version: When I pause a movie for some time my gpu fans start to noise, obviously there's high load on the gpu. This doesn't happen during playback.

thx for the segnalation... on pause i have to call madvr to redraw the frame, i do this each 40ms but for the same reason of the sluggish gui madvr sends 16 frame all together and this push gpu load

anyway i just fixed that
Reply
(2015-03-29, 23:06)Warner306 Wrote:
(2015-03-29, 22:53)vicmanpergar Wrote: @aracnoz

thanks for the build, I will try it.... The refresh rate is correct for me here, but i have to check which method i have, or if i have both.

@_Andy_

Lol... well, i was ONE of the guys thinking it would never happen (it really seemed so, after several times it was tried and abandoned). And i'm very happy i was wrong.

Edit:
Btw, i have Jinc3+AR (had nneid3 and it was perfect but HTPC became noisy), i have 0 dropped frames, but i do have repeated frames.... Anyone knows how to interpret this? should i care? Are they important?
The video looks smooth.

The repeated frames sound odd. But if your eyes say everything is fine, I wouldn't worry about.

Does this happen while navigating or stopping or starting the movie? Because this is normal. The counters for presentation glitches and dropped frames should not increase during continuous playback and the rendering queue must remain below 41 ms at all times.


It does.... I press Ctlr+J and after 5 mins, Ctrl+R , then after 10 mins or so, i check it again (Ctrl+J).... Everything is as it should be, except it says there's a repeated frame each 2 mins or so... Presentation Glitches, dropped frames, are all at zero. The rendering was 36 ms when doing it with NNEID3, and around 20 ms now with Jinc3....
But, to my eyes, it looks ok... It just fucks my mind not knowing what's the meaning, hahaha
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2015-03-29, 23:13)vicmanpergar Wrote:
(2015-03-29, 23:06)Warner306 Wrote:
(2015-03-29, 22:53)vicmanpergar Wrote: @aracnoz

thanks for the build, I will try it.... The refresh rate is correct for me here, but i have to check which method i have, or if i have both.

@_Andy_

Lol... well, i was ONE of the guys thinking it would never happen (it really seemed so, after several times it was tried and abandoned). And i'm very happy i was wrong.

Edit:
Btw, i have Jinc3+AR (had nneid3 and it was perfect but HTPC became noisy), i have 0 dropped frames, but i do have repeated frames.... Anyone knows how to interpret this? should i care? Are they important?
The video looks smooth.

The repeated frames sound odd. But if your eyes say everything is fine, I wouldn't worry about.

Does this happen while navigating or stopping or starting the movie? Because this is normal. The counters for presentation glitches and dropped frames should not increase during continuous playback and the rendering queue must remain below 41 ms at all times.


It does.... I press Ctlr+J and after 5 mins, Ctrl+R , then after 10 mins or so, i check it again (Ctrl+J).... Everything is as it should be, except it says there's a repeated frame each 2 mins or so... Presentation Glitches, dropped frames, are all at zero. The rendering was 36 ms when doing it with NNEID3, and around 20 ms now with Jinc3....
But, to my eyes, it looks ok... It just fucks my mind not knowing what's the meaning, hahaha

You could try using ReClock to correct the occasional repeated frames. I've been told this issue has something to do with multiple clocks in your computer not syncing perfectly with each other. ReClock can improve or eliminate this. This is normal, though.
Reply
@Warner306

I AM using reClock
Sad
Not sure if perhaps it's actually reClock causing it, i will take a second look.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2015-03-29, 23:37)vicmanpergar Wrote: @Warner306

I AM using reClock
Sad
Not sure if perhaps it's actually reClock causing it, i will take a second look.

It will probably be worse if you remove ReClock. You can't reach 0 repeated frames, but one per hour or two hours is possible.
Reply
(2015-03-29, 23:46)Warner306 Wrote:
(2015-03-29, 23:37)vicmanpergar Wrote: @Warner306

I AM using reClock
Sad
Not sure if perhaps it's actually reClock causing it, i will take a second look.

It will probably be worse if you remove ReClock. You can't reach 0 repeated frames, but one per hour or two hours is possible.

Fixed it...
At least in my case, i had "Disable media speed correction" checked
Now it says repeated frame each 2 days Smile
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Sometimes not all filters loaded, mostly subtitle filter. After some restart kodi / media it works. Didn't know what happenned.
Reply
Hmm i guess i'm missing something. No matter if i enable or disable use exclusive mode in dsplayer settings the option 'use a fullscreen window rather than true fullscreen' is always greyed out.

The settings display mode shows full screen with 1080p but the option 'use a fullscreen window rather than true fullscreen' is greyed out. I click alt+enter and kodi goes to window mode and the option 'use a fullscreen window rather than true fullscreen' is greyed out. This is correct.

I click alt+enter again kodi switch to full screen the option display mode shows full screen but the option 'use a fullscreen window rather than true fullscreen' is still greyed out.
I tried to reset settings to default but nothing happens. The option 'use a fullscreen window rather than true fullscreen' is always greyed out. Independently from the option use exclusive mode is dsplayer settings.

What i'm missing?

edit
Maybe i found something. If the selected renderer is madVR and try to reset the settings the option 'use a fullscreen window rather than true fullscreen' is still greyed out and i can't switch the fullscreen mode.
If i select as renderer EVR now and reset the option 'use a fullscreen window rather than true fullscreen' is now selectable and i'm able to change the fullscreen mode.
Now i go back to madVR as renderer and the option is stuck again.

The reason why i ask. If i'm in real fullscreen and try to play a movie with dsplayer the kodi gui never disappears and i get no movie picture. In the background i can hear the movie sound. No matter if i use exclusive mode or not.
I have to switch to use a fullscreen window in kodi and now i'm getting a movie picture with dsplayer. I could stay forever in fullscreen window mode but sometimes i have bad picture tearing and i need the true fullscreen.
Reply
(2015-03-30, 01:45)_Andy_ Wrote: Hmm i guess i'm missing something. No matter if i enable or disable use exclusive mode in dsplayer settings the option 'use a fullscreen window rather than true fullscreen' is always greyed out.

The settings display mode shows full screen with 1080p but the option 'use a fullscreen window rather than true fullscreen' is greyed out. I click alt+enter and kodi goes to window mode and the option 'use a fullscreen window rather than true fullscreen' is greyed out. This is correct.

I click alt+enter again kodi switch to full screen the option display mode shows full screen but the option 'use a fullscreen window rather than true fullscreen' is still greyed out.
I tried to reset settings to default but nothing happens. The option 'use a fullscreen window rather than true fullscreen' is always greyed out. Independently from the option use exclusive mode is dsplayer settings.

What i'm missing?

edit
Maybe i found something. If the selected renderer is madVR and try to reset the settings the option 'use a fullscreen window rather than true fullscreen' is still greyed out and i can't switch the fullscreen mode.
If i select as renderer EVR now and reset the option 'use a fullscreen window rather than true fullscreen' is now selectable and i'm able to change the fullscreen mode.
Now i go back to madVR as renderer and the option is stuck again.

The reason why i ask. If i'm in real fullscreen and try to play a movie with dsplayer the kodi gui never disappears and i get no movie picture. In the background i can hear the movie sound. No matter if i use exclusive mode or not.
I have to switch to use a fullscreen window in kodi and now i'm getting a movie picture with dsplayer. I could stay forever in fullscreen window mode but sometimes i have bad picture tearing and i need the true fullscreen.

As aracnoz said with MadVR it take control of fullscreen device (exlusive mode or not). So Kodi will always in window mode that's probably why that option always grayout.

In my system I have to set MadVR in exclusive mode for it to works normally. Disable exclusive mode makes it not smooth and lot of tearing.
Reply
There is no problem with using windowed mode; exclusive mode is supposed to improve performance slightly, but I have no problems with tearing when using windowed mode. Using windowed mode allows Kodi to be used in fullscreen rather than a window.

I did just experience a bug where the wrong filters were loaded during playback. FFDShow Audio was loaded as the decoder even though LAV Audio was set for the file type.

The problem with mp4s (and maybe other file types) crashing while seeking is the most annoying problem. The files play fine but crash when moving ahead or back by pressing Up or Down. This is not a madVR problem.

Edit..I do get occasional presentation glitches when using windowed mode with my laptop. About one every 20 seconds or so.

...Fixed by increasing value for "How many frames shall be presented in advance." Windowed mode works fine.
Reply
Never have problem with skipping ahead and back. I did that a LOT (maybe 20-30 times per movie up down left right I did all ,bad habit) and no crash regarding this issue so far. I also The bug as wrong filter loadead or not loaded it was there when Kodi madVR was introduced but it seems it happens more frequenly in later build.

Don't get confused with MadVR exclusive / non-exclusive mode with Kodi True Fullscreen / Fullscreen Window mode though. It is different thing just that MadVR in both mode doesn't work with Kodi True Fullscreen mode.
Reply
The crashing while seeking has only happened with mp4s. MKVs seem fine. Haven't tried other formats.
Reply
(2015-03-30, 03:39)Warner306 Wrote: The crashing while seeking has only happened with mp4s. MKVs seem fine. Haven't tried other formats.

Try with 3 different mp4, skip with up down right left 20-30 times per file. No crash.

The possible different is that I'm using FFDShow Audio not LAV Audio. You might want to change that to see if it's LAV Audio that's the culprit. And maybe Reclock.
Reply
The problem seems to relate to certain mp4s. Several other mp4s play fine. But, in general, skipping and seeking through these files can lead to crashes.

I noticed the audio track with the problems files are AAC. On one computer, I am bitstreaming with ReClock. On the other, I am using WASAPI directly to a television (no bitstreaming, no ReClock). On both systems, the channel layout is shown, but the audio codec is not read. The space for the audio codec appears blank. I wonder if this has something to do with the problem?
Reply
A wild guess, but are those problem mp4s "WEB-DL" or something like illegal stuff rip-off Itunes store. I read in Kodi forum that some of those files has something about variable framerate (whether it was real variable framerate or wrongly detect as that) and cause problem with Kodi.

You can try remux those mp4 to mkv and see if problem persists.
Reply
  •   
  • 1
  • 87
  • 88
  • 89(current)
  • 90
  • 91
  • 95
  •   



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available8
This forum uses Lukasz Tkacz MyBB addons.