Advanced Launcher - Fallout 3 - Crash on Load - Using AutoIt Script
#1
Hey folks,

So I'm setting up Advanced Launcher in XBMC to handle all my PC based games. There are only really 3 - Fallout 3, and two Sherlock Holmes games. Running Windows 7.

I first set up Advanced Launcher to work with links to the game exes, which worked quite well. However, when I exited the games XBMC would be minimized and I'd have to open it back up. Not really a huge deal but I'd like the system to operate seamlessly with a gamepad and/or remote control and allow me to hide away my keyboard and mouse for system updating.

So I decided to use AutoIt after some forum hunting and have the following very simple code:

Code:
run ("D:\Software\Games\Fallout 3\Fallout3.exe")
processwaitclose("Fallout3.exe")
run ("C:\Program Files (x86)\XBMC\XBMC.exe")

The code is identical except for the paths and filenames for the two Sherlock Holmes games and they both launch with no problem and return to XBMC upon exiting the game. Fallout 3, however, opens and crashes immediately, the error being the standard: "Fallout3 has stopped working - A problem caused ... is available."

I at first wondered if it was a resolution change issue. So I made sure that, desktop, XBMC, and Fallout resolutions are all identical. I also tried the launcher with XBMC in both fullscreen and fullscreen window modes.

I don't know if this is exactly the right place to ask, but if anybody has experienced anything similar and has a solution or any ideas on what I can try, I'd be most appreciative.

Cheers,


Steven
Reply
#2
What is exactly the full "Fallout3 has stopped working - A problem caused ... is available" error message?
Reply
#3
The generic windows error message with no details.

"A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

That's the whole message.

I got another problem with Project64 which I saw another user also had. You responded that you had tested it with Jaboo's plugin and default settings. I already had those settings and no dice.

I also got an error with zsnesw which I found strange because it used to work perfectly in Eden. I'm at work at the moment, but if the specific error messages would help I'm sure that I can replicate them when I get home.
I appreciate the help. It truly is a wonderful add-on.
Reply
#4
So enough fiddling and problem solved. The PJ64 and ZSNES were both lack of fullscreen window mode. That took care of those two. And making that switch meant that when the programs closed XBMC was back in focus and not minimized, so I was able to switch back to using links for Fallout 3.

Cheers!
Reply

Logout Mark Read Team Forum Stats Members Help
Advanced Launcher - Fallout 3 - Crash on Load - Using AutoIt Script0
This forum uses Lukasz Tkacz MyBB addons.