Linux CPU load and PythonCallbackHandler loop
#1
Hello,

Since I upgraded to Frodo final, my CPU load is very high, and I my logs are filled (> 1Mo/day) with this kind of logs :

Code:
14:16:21 T:140430207092480   DEBUG: NEWADDON PythonCallbackHandler construction with PyThreadState 0x7fb854005950
14:21:23 T:140430457481344   DEBUG: Previous line repeats 604 times.

Any ideas to fix this ?

Thanks,
Reply
#2
disable debug logging, fix will be included in 12.1
Reply
#3
(2013-02-04, 15:28)Kitof Wrote: Hello,

Since I upgraded to Frodo final, my CPU load is very high, and I my logs are filled (> 1Mo/day) with this kind of logs :

Code:
14:16:21 T:140430207092480   DEBUG: NEWADDON PythonCallbackHandler construction with PyThreadState 0x7fb854005950
14:21:23 T:140430457481344   DEBUG: Previous line repeats 604 times.

Any ideas to fix this ?

Thanks,
the log messages is fixed.

CPU is something else. find the addon that is causing if by removing /disabling each of them
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#4
Thanks for your answers.

Anyway, I unable to disable debug log, advancedsettings parameter seems ignore :

Code:
10:47:29 T:140643842873472  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <loglevel hide="false">-1</loglevel>
                                            </advancedsettings>
10:47:29 T:140643842873472  NOTICE: Log level changed to 0

And I disable all my addons, and I'm still in 100% Usage CPU...
Reply
#5
<loglevel hide="false">1</loglevel>

did you remove plugin.commoncache?
Reply
#6
(2013-02-08, 11:18)wsnipex Wrote: <loglevel hide="false">1</loglevel>

I'm confused : http://wiki.xbmc.org/index.php?title=Adv...oglevel.3E
Reply
#7
hmm sorry, make it 0 then. Never tried to disable logging completely.
Anyway, imho this is not the source of your problem, only the log spam will be gone.
Reply
#8
(2013-02-08, 18:42)wsnipex Wrote: hmm sorry, make it 0 then. Never tried to disable logging completely.
Anyway, imho this is not the source of your problem, only the log spam will be gone.

Loglevel could be broken.

Key is finding out what is hogging the cpu.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#9
Ok, I submit a bug for the loglevel ( http://trac.xbmc.org/ticket/14076 ).

I disabled all the addons (event the common cache), and I'm still at 100%.

I noticed that in 60hz, i'm at more than 100fps. Maybe it's a clue ?

When i switched to 50 hz, my CPU down at 80%...

Any ideas ?
Reply
#10
Enable Vertical Blank Sync in System -> System -> Video Hardware. Set it to "Always Enabled".
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#11
(2013-02-09, 12:39)fritsch Wrote: Enable Vertical Blank Sync in System -> System -> Video Hardware. Set it to "Always Enabled".

Thanks for your advice. Unfortunately, it's already set.
Reply



Logout Mark Read Team Forum Stats Members Help
CPU load and PythonCallbackHandler loop0
This forum uses Lukasz Tkacz MyBB addons.