Thread Rating:
  • 4 Vote(s) - 4 Average
Linux - HOWTO: Install Netflix on xbmcbuntu 12.0 frodo addon
SSH to your box and do the following

sudo cp /etc/fstab /etc/backupfstab

Change your fstab This is the command i used...
****but beware if this doesnt work on yours it will mess things up:
sudo sed -i 's/errors=remount-ro/errors=remount-ro,user_xattr/' /etc/fstab
safer method is to:
sudo /etc/fstab
and add ,user_xattr after errors=remount-r on your / fs the line should look something like this when its done
UUID=XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX / ext4 errors=remount-ro,user_xattr 0 1

sudo vim /etc/X11/xorg.conf
(if you dont have it sudo apt-get install vim)
change the Disable for Composite to Enable like this:
Option "Composite" "Enable"

sudo mount -o remount /
sudo apt-add-repository ppa:ehoover/compholio -y
sudo apt-get update
sudo apt-get install netflix-desktop -y

download the following file and install it from addons from zip file
Downlad Zip Addon here

go to videos and addons click on netflix...
youll need a keyboard and mouse to control netflix... it will also install a bunch of needed packages

I have gotten netflix working on xbmcuntu; here's the workarounds i have come up with.

first off, i would run the install and run netflix-desktop from a desktop session, not from xbmc the first time.
it will have to download and install some bits to get itself set up.

second- on having it grab focus: i've found this to be a problem in alot of situations involving external applications because controlling focus is usually the job of the window manager, and XBMC doesn't run one nor need one for most things it does as xmbcuntu in the stand-alone configuration. .
my solution is this script:

openbox &
netflix-desktop "$1"
kill %1

what this script does is run the open box window manager in the background, then open netflix-desktop.
once netflix-desktop exits, it kills the open box.

having a window manager running will automatically assign focus to the new window, witch is full screen so there won't be any window decoration. \

right now i am using advanced launcher to launch netflix; i may try and hack my way into one of the browser plugins that is already out there as that's a cleaner, more integrated way to do it that takes advantage of the groundwork done by others on the windows platform.

one other error i came across was that i needed to edit /etc/X11/xorg.conf to enable compositing.
Thank you - Ill give that a try...

You're right i forgot to mention that..

in /etc/X11/xorg.conf the Composite needs to be enabled (i think this may only hold true for nvidia cards from what I read)

Section "Extensions"
Option "Composite" "Enable"

How is your playback on your system?
it's pretty much flawless- we watched two movies last night and the load average averaged from 1.9-1.7 with piles of memory left available.

now, my setup is a bit 'dated' to say the least- it's an upgraded $100 special from the local PC recycler here in seattle, RE-PC.

it's a dell pavilion d4650y.
Core 2 Duo 1.86 GHz
6.5 gig of memory
GeForce 7300 LE

i also have Mythtv-backend running on this thing, with a Ledtek HDTV cinema tuner card.

display is via S-video to a 1991-era toshiba CRT TV.

so while the system is modest, i'm not asking it to do HD, either. however, to get some extra headroom for this and running handbrake i am currently saving up the $60-$80 to upgrade to a q6600 or q6700 quad core 2.4-2.6ghz processor, the fastest this old board supports.
Did you have to make any other changes?
Im thinking my audio or something might not be set right to work with openbox?
but I am running hdmi and passing audio that way but on this box an ion2 and i can stream bluray isos from my nfs server...
I also have a myth-backend with 2x hdhomerun 3s
the new pvr merge is nice!
I tried installing this on Eden, running on ubuntu. It's not xbmcbuntu, but I have it set up to boot right into xbmc with lightdm. I got to step 5, but got hit with an error, "Netflix dependencies not met."

Any ideas?
Havent tried it on Ubuntu Eden..

Are you saying that you get the error, when you try to install the addon zip file in xbmc? or before that?
It happens when I try to install the addon file.
If you go into the /home/<user>/.xbmc/addons dir you should see the extracted files i believe.

You might have to take a look at the addon.xml file (I may have put in a version number that required it to be on frodo) if you google xbmc addon xml you should find the page that has the version dependencies listed..

also what does your log say?
Here's the contents of the addons directory.
metadata.album.universal               script.tvtunes             script.watchlist
metadata.artists.universal       script.artistslideshow           script.xbmc.blindplayer     script.artwork.downloader        script.xbmc.debug.log        script.artworkorganizer          skin.back-row   script.commands                  skin.confluence-vertical  script.common.plugin.cache       skin.mediastream_redux         script.favourites                skin.metropolis          script.globalsearch              skin.neon  script.image.bigpictures         skin.quartz   script.module.beautifulsoup      skin.rapier   script.module.buggalo            skin.xeebo     script.module.elementtree        skin.xperience-more          script.module.parsedom           skin.xtv-saf                script.module.requests           weather.weatherplus
packages                         script.module.simple.downloader  weather.worldweatheronline              script.module.xbmcswift          webinterface.awxi              script.module.xbmcswift2         webinterface.home-row
plugin.image.picasa              script.mythbox                   webinterface.pwi       script.playalbum                 webinterface.wtouch                script.pseudotv                  webinterface.XWMM                 script.randomitems       script.rss.editor

I don't see a version requirement for frodo in the xml file, but there's the text, in case I'm missing something.
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addon id="netflix_install" name="Netflix" version="0.0.1" provider-name="fnc1">
    <import addon="xbmc.python" version="2.1.0" optional="true"/>
  <extension point="xbmc.python.script" library="">
  <extension point="xbmc.addon.metadata">
    <summary lang="en">Installs netflix-desktop and Adds an icon for Netflix.</summary>
    <description lang="en">Installs netflix-desktop and Adds an icon for Netflix.</description>

Here's what I found in the log.
22:56:46 T:139988528252672  NOTICE: Thread Jobworker start, auto delete: true
22:56:50 T:139990177965952   ERROR: Texture manager unable to load file: /media/godzilla/

Looks like an issue loading the icon.png file. I copied the file out of the zip and it didn't appear corrupted, so I'm unsure what the issue is.
yeah i think it gives the icon error when there is a version issue..
try changing the version here this is set for frodo
<import addon="xbmc.python" version="2.1.0" optional="true"/>
see here
section 2.1.2 for the current versions table (and pick yours under xbmc.python.

once you change that inside the dir

you should be able to rezip it and install it
you might have to do a
sudo apt-get install zip (or something like that)
zip -ur script.netflix_install-001/
then install your custom one
That did the trick, got the message that said "Netflix enabled.

But, in video add-ons, I click on Netflix and nothing happens. Under the information dialogue, it shows the status as "disabled".
like i said i pretty much set this up to just work with frodo... Im not sure why it would be disabled...

but do you have openbox installed - thats what is used to launch it..

i suppose you could try editing the file i think it is and put replace openbox with lightdm (which is what i think you were using) but i dont know how this will work...

the other thing is you may try installing openbox.

also try to uninstall then reinstall the addon....

and make sure to check your log files. xbmc.log Might say why it is disabled.

I do not understand

when i do " sudo vim /etc/X11/xorg.conf " i come to a empty file, what should i do? wright "Option "Composite" "Enable" " in it? and how do i exit it ?
you can try without... i *Think that is a specific to nvidia cards...

HOWTO: Install Netflix on xbmcbuntu 12.0 frodo addon44