Linux XBMC crash at activatig LiveTV
#1
hi to all,

please help...

1. Thanks to all who have built this great programm!

I've got a problem with my XBMC-Frontend.
My system:
Server: Mediaportalserver with MediaPortal_v123_TVServerXBMC_plugin_bin_rev120
Client 1+2: Windows 7 Home with MePo and XBMC Frodo.
Intel Atom 330 with ION GPU
I'm using the MePo PVR Addon in XBMC and it works fine.

Client 3: Ubuntu 12.04 and I tried also 12.10
Acer Revo RL70
XBMC Frodo
Everything works, but when I want to aktivate the LiveTV (System) after config the MePo Addon in XBMC the whole XBMC crashes!
Here´[/quote]s the Crashlog.

Thanks in advance!

mod edit:
please don't include your entire log here,
upload it to xbmclogs.com instead.
Reply
#2
Hello,
I got a similiar problem.
I got an MePo TV-Server as Backend and the Plugin installed.
The Ubuntu and OpenElec Frodo version is getting channels from the server. As soon as i activate a channel for watching, the screen wents black for some seconds (xbmc crashes?) and then i'm back at the main menu!
If I use XBMC under Windows 7 this problem doesnt occur!!!
Seems to be a Linux problem. After restarting the TV-Service on the server its working again, but only til starting the TV-PC again. Then same error again. On Windows 7 no problem, always working! Maybe I need to install some add-on?
Someone needs to know what this is! Please help! I'm already thinking about changing to tvheadend, but my linux knowledge is very small. The question is would it be better...
Reply
#3
Same problem here.

Using MP TV Server +Xbmc TV Server plugin + Raspberry Pi Raspbmc.

The connection to the TV Server is working. EPG data and all the other stuff is received. When starting live TV the screen goes green and the raspberrypi is rebooting.

Was not able to find a solution. Can anyone help please? It seems to be a bug within the xbmc tv server plugin.
Reply
#4
So you think its the Server Plugin? The Plugin Works Great with the windows 7 xbmc Version.
The error occurs with the ubuntu and openelec version. After restarting the Tv Service on the Server, it is working til shutting Down and restarting the Htpc.

Damn, thats the only Thing thats missing for a Perfect Htpc. Cant be that we are the only One with that problem.
Is someone sure that it is 100% working with an other Software than mediaportal Tv Server? Tvheadend?
Reply
#5
Today i will try out several other TV-Server Software. Slowly i'm getting tired of problems here and there...
I will inform you what my results are!
Reply
#6
It seems to be a problem with the raspberry pi.

In some forums i can read about a bug inside the omxplayer.
I´m not sure how this is involed into the life tv playback.

Unfortunatelly i was not able to find a solution for this problem! Sad
Reply
#7
Hi Olli,
sounds confusing. I dont have any raspberry pi. Just normal Intel or AMD HTPC's, everywhere the same error on Linux. No Problem with the XBMC under Windows 7.
As i'm getting home today, i will try Argus as TV-Server Software under WHS 2011 and TVheadend under Ubuntu. Ah, and I'm trying an old version of the MediaPortal TV-Server had the 1.3 Beta installed, maybe thats the problem.

Which one do you have installed? Let you know if the error still occurs.
Reply
#8
Yes this problem is confusing.

My hardware is a WHS2011 Server with Mediaportal TV Server, (v1.3 RC, server only)

#1 client is a AMD Fusion with Windwos 7 and Mediaportal client (v1.3 RC, client only)

#2 client is a AMD Athlon X2 with Windows 7 and Mediaportal cient (v1.3 RC, client only)

#3 client is a Raspberry Pi with Raspbmc (Linux)

All is running fine except the #3 Raspi.

I don't think that this is a problem with the TV Server because it is totaly stable to client #1 and #2.

So there are two parts of problem makers, the xbmc TV Server plugin (made for v1.3 beta btw) or/and the Linux frontend.

Maybe you will get Live TV working with another backend because you are also not using the xbmc Server plugin anymore.
I´m also not sure about the plugin. It seems to be just a "wooden bridge" from windows to linux. It seems not to stable right now. Looks like a experemental thing.......

I switch from Microsoft Mediascenter over to DVBLogic and after this to Mediaportal.
I will not change the backend anymore. I spend a lot of time in training my wife in using Mediaportal Smile

Just woundering that we both are the only people having problem with there live TV under XBMC Rolleyes
Reply
#9
Oh, we're three with this problem. But that doesn't make it better or mutch easier.

I think it's a problem with XBMC an the MePo-Addon or better the LiveTV-Part and the MePo-Addon because I use on the windows-clients also XBMC with the MePo-Addon and it works really fine! Just the Linux-HTPC will not work together with the MePo-backend.
And I also tried this link: http://forum.xbmc.org/showthread.php?tid=141369 . It works great (many thanks to Bram77) just the LiveTV with the MePo-Addon...

I don't have any idea about the problem.

(2013-02-25, 16:45)olli123 Wrote: I will not change the backend anymore. I spend a lot of time in training my wife in using Mediaportal Smile
And I really, really know about your problem Smile
Reply
#10
Yep, training your wife - priceless!!! :-)
Short update:
Argus is working, but the switching time is like the double of MePo 7-8 Sec. After a couple of restarts just one crash, but Live TV after that was working...
But the switching time... terrible. Had 3-4 Sec. with MePo HD channel with CI/Cam - So it looks like its the MePo Server plugin... Looking for alternatives...
So next I'm trying MePo 1.2.3 with the XBMC plugin! Keep you posted.
How about you guys, under Win7 did you expected crashes of XBMC after suspend/hibernation? Because thats why i try the ubuntu / openelec version. I need a stable version because of the WAF ;-)
Reply
#11
Got it working!!!
with the following config:
Openelec 3.0 RC3 - MePo TVServer 1.2.3 - TVServerXBMC Plugin 1.2.3.115
I'm not sure what would happen if upgrading. You know, never touch a running system!
I think i will test it till tomorrow, if its working, its time to change!
Have a nice evening!
Reply
#12
Without log files or crashlogs, I'm not able to tell whether your problems are the same.

@gandalf_white:
I saw the crash log from Gandalf_white before it was removed and it showed that the crash occured in the code that retrieves your card settings from the backend. Unfortunately your log and crashlog are removed, so I can't read the details anymore.
TVServer 1.2.3 + tvserverxbmc 1.2.3.120 and Ubuntu 12.10 work fine here, so it is something related to your particular configuration that is triggering this crash. I will double check my card retrieval code for potential crash candidates.

@maverickmu: switching times are high with Frodo for most backends (except for TVHeadend and VDR) due to the slow stream detection in ffmpeg. It is a known issue and it requires internal changes in ffmpeg + XBMC to solve it.

I don't think that the TVServerXBMC plugin causes these crashes. It is just a communication interface with the TVServer to control it from a non .NET application. E.g. it tells the TVServer to tune a channel and tells the PVR addon which stream or timeshift file it should open.

@olli123: I don't have a RPi for testing the addon. I can't help you with the RPi problems. The only thing I've seen is that the CPU usage might be a reason for the XBMC to fail playing Live TV. Some users reported >95% CPU usage and network buffering problems.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#13
@magro: as far as i know the MePo plugin is using TSreader instead of ffmpeg? How are the switching time witz tvheadend or VDR?
As I said before, I tried several configurations and I got it finally working with the TVServer 1.2.3.
Before i had the TVServer 1.3 with the corresponding tvserverxbmc installed and i had crashes as explained.
Olli has the 1.3 RC installed too, maybe he should try to uninstall it and install the 1.2.3 again! And give us a feedback.
Reply
#14
Yes i think i will go for a openelec OS on my raspi first. It is also avaible as raspi build.
If i dont have sucess i will test setting up tv server 1.2.3 like maverickmu. Maybe this will fix it.

@margro: thanks for joining this thread. I donn´t think that this is a raspi problem. The decoding of a .h264 stream is done by the gpu not the cpu and i also don´t have problems with high cpu load.
I´m also able to watch a hd1080p .h264 stream with vlc without any problem. And full HD streaming with raspi has been confirmed working on many other sides. So dont blame the raspi. I dont think that it is the problem. Also SD channels fail and the whole raspi go for reboot without any message in the syslog. So very very confusing. Never seen such a behaivior on a linux system before.

Which log do you need? The TV Server log and/or the syslog from the raspi?

I hope i can spend some time for testing in the next days......... maybe this evening.
Reply
#15
@maverickmu: yes, by default the MePo plugin is using TSReader mode (direct file access to the timeshift buffer file). However the playback in XBMC is also in that case still handled by the ffmpeg library. FFmpeg mode for the MePo addon actually means: "send the rtsp stream url to XBMC and let XBMC do all the playback handling using its ffmpeg library.

I don't have TVHeadend or VDR so I can't compare the switching times, but I do know that they switch faster because they do not (yet) automatically start a timeshift session like MediaPortal does and these addons use their own demuxer instead of the slower ffmpeg demuxer.

I can't reproduce the 1.3RC + XBMC on Linux crashes here, so I have no clue...

@olli123: SD channels use typically mpeg2 as codec. This requires a separately bought license for the RPi as far as I know.

First thing to test is to play a SD and an HD recording with XBMC directly from the recordings share (SMB share) using the standard "Video" menu. This is to test the network connection and XBMC's ability to play these files. This bypasses the PVR addon completely. If this does not work, we can rule out the PVR addon.

If this works, then we can actually blame the MePo PVR addon or the PVR interface. The PVR interface adds some overhead to the playback process, so it can still be a CPU issue.
My first guess is still that the problem is on the RPi side, so, a XBMC debug log (enable the debug log setting first) should be the minimum to figure out where the problem starts to occur.

Don't post the log here, but post it on pastebin or http://www.xbmclogs.com/ and put the URL here.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC crash at activatig LiveTV0
This forum uses Lukasz Tkacz MyBB addons.