Linux XBMC crash at activatig LiveTV
#16
@margo: here is my crashlog: http://www.xbmclogs.com/show.php?id=1187 After removing it, I posted it at the right place. Sorry for that.
Information about my systems:
Server:
Mainboard: MSI (i'm going to take a look which one)
CPU: AMD Athlon 4450e @2300MHz
RAM: DDR2 6GB
TV-Tuner: 3x KNC ONE DVB S2
HDD: 1x Boot, 1x TimeShift, 1x Rec, 1x Data
OS: Win7 Pro
MePo Server: 1.2.1.0 with tvserverxbmc 1.2.3.120

Client 1:
Mainboard: Zotac ION with Atom 330
RAM: DDR2 4GB
LG FullHD TV
OS: Win7 Home
MePo Client 1.2.1.0
XBMC 12.0 Frodo with MePo AddOn (works fine)

Client 2:
Acer Revo RL70
http://forum.xbmc.org/showthread.php?tid=141369 (current OS)
(I also tried Ubuntu 12.04 with XBMC 12.0 Frodo)
This is the system which crashes every time I activate the LiveTV in the configuration after configuring the addon.
I've had the same problem with Ubuntu 12.04.

Perhaps it's the MePo version with the addon (tvserverxbmc 1.2.3.120), but why does it work with windows?
Reply
#17
Hi,

I don't know what happened... But this evening I made some tests with a sync-database and XBMC... And at the end I wanted to get a crashlog (new one) from my linux client. I checked the config of the MePo-Addon und activated the LiveTV in the config. And... it started... I don't know what I've done...
Some reboots and it's still working...
Just some problems with the epg but I'm going to figure it out.

Best wishes and many thanks to you for thinking about the problem.
Reply
#18
Good to hear that the problem is solved. I've tried to reproduce the crash with the same XBMC build and Ubuntu version, but I couldn't trigger it.
From your crashlog, I could see that it crashed while processing your TV card settings. I've already added some additional checks there to prevent potential problems. Thanks for posting your crashlog again.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#19
Thank you margo for doing such a great job!
Reply
#20
(2013-02-26, 20:48)margro Wrote: @olli123: SD channels use typically mpeg2 as codec. This requires a separately bought license for the RPi as far as I know.

First thing to test is to play a SD and an HD recording with XBMC directly from the recordings share (SMB share) using the standard "Video" menu. This is to test the network connection and XBMC's ability to play these files. This bypasses the PVR addon completely. If this does not work, we can rule out the PVR addon.

If this works, then we can actually blame the MePo PVR addon or the PVR interface. The PVR interface adds some overhead to the playback process, so it can still be a CPU issue.
My first guess is still that the problem is on the RPi side, so, a XBMC debug log (enable the debug log setting first) should be the minimum to figure out where the problem starts to occur.

Don't post the log here, but post it on pastebin or http://www.xbmclogs.com/ and put the URL here.

OK so far I´ve done some testing:

First i changed to openelec. Using the latest pi build, something like Version:2.99.4.
The mpeg2 codec has been bought and activated in the past already.
Playing a .h264 and a SD movie from a SMB share.
SD CPU load is around 50%
HD CPU load is around 90%

but HD is not lagging or stuttering. Using the OSD while playing a 1080p file makes the pi go stuttering.
As exspected there is no network problem. (1Gbit with proofed bandwith of > 100Mbyte/s).

And yes ofc i dont want to blame your plugin margro................ I think it has to deal with the pi AND the live tv feature.
But trieing to use live tv with openelec (SD and HD channels) make the xbmc restarting before the tv starts playing!

For me there is only one question:
Can i replace my HTC with the PI without loosing functionality? Answering this question with a yes would be great.
So thats the point i want to get it working.

And yes, i know. still no logfiles. I hope i can create some this evening and upload them.

Best regards,
Oliver
Reply
#21
The issue of Live TV on the Pi (black screen, followed by restart of XMBC after several seconds) looks to be an omxplayer issue on the Pi. It happens trying to watch LiveTV from HTS tvheadend as well (and has done since around the end of December 2012).

Other symptoms you may observe:

- if logging is enabled in XBMC, you can watch the available memory drop and drop until the Pi runs out and the kernel kills XBMC as a runaway process
- pressing X / STOP before XBMC is killed, you will often see a single static frame of the video you were trying to watch get displayed before you are returned to the XBMC menu
- if you press ENTER (to show the OSD), you will see that the audio is being reported as "0.0" instead of "2.0" or "5.1"

So far, nobody has identified what the problem is in the omxplayer code (the issue appears to be quite complicated, not least because nobody knows exactly when the bug was introduced). There are a number of threads that cover this:

- http://forum.xbmc.org/showthread.php?pid=1351268 (which suggested incorrectly that the HTS.pvr add-on was to blame - it isn't)
- http://forum.stmlabs.com/showthread.php?tid=4478&page=9 (which focused on workarounds like using an HTSP source)

The problem is that the XBMC dev team are too busy to spare time on this issue at the moment. Which means it is down to the community to:

1. locate the exact version of the omxplayer (or related) code that broke the LiveTV functionality
2. look at the differences between that and the previous version that worked
3. build a test version to confirm whether undoing -just- the changes that broke LiveTV results in a working solution
4. submit a suitable patch to the XBMC devs for inclusion in the next build / release

Or, of course, to figure out the problem by analysing the source code, coding a fix and skipping (1-3) above...
Reply
#22
Same problem here. Recordings play fine but LiveTV reboots the Pi. I've tested Raspbmc, OE rbej and thestateofme builds.

It was working at some point recently with an rbej build but I update that quite often so couldn't say which build exactly.

Incidentally, it's telling me there's an update available but I can't seem to download it. Is there a zip I can download to install somewhere?
Reply
#23
I have a problem that is similar, except it works on my PI (Raspbmc) and Windows 7. On my Android phone and iPad is where I get the crash. I use a HD-PVR as my source, so all TV channels are h.264, not mpeg2.

On the backend I am using:
  • MP 1.3
  • TV Server 1.2.200.0
  • TVServerXBMC 1.2.200.119



Where are the crash logs located on Android and iPad? I will post them when I figure out where they are at.
TV Mosaic on Windows 10 as PVR Backend |  1 RaspberryPI 3 Client (LibreElec) | Amazon FireTV box | 5 Amazon FireTV sticks | FireTV Cube | 2 Nvidia Shield TV
Tuners: HD HomeRun 4 ATSC (OTA) | IPTV
Reply
#24
I've only had a quick look through the thread (sorry not a lot of time) but to those who have crashing TV using Mediaportal and the Rpi. Have you tried using ffmpeg instead of TS? TV crashed for me using TS. I swapped to ffmpeg and it has worked fine ever since.
-----------------------------------
Front End: Asrock ION 3D running OpenElec - Backend: Dedicated server Running Ubuntu with TBS 6981 DVB-S2 USB
Reply
#25
Yeah, I did try swapping to ffmpeg and it still didn't work.

I've been using TVheadend with tvhpiproxy instead recently and that's been relatively OK.
Reply
#26
I tried ffmpeg also, and it still crashes.
TV Mosaic on Windows 10 as PVR Backend |  1 RaspberryPI 3 Client (LibreElec) | Amazon FireTV box | 5 Amazon FireTV sticks | FireTV Cube | 2 Nvidia Shield TV
Tuners: HD HomeRun 4 ATSC (OTA) | IPTV
Reply
#27
As Im interested to see whats going wrong with your installs I installed Openlec on a blank SD and tried the PVR. I use Mediaportal 1.3.0RC and the latest XBMC plugin.

Before starting the PVR I changed the plugin settings from TS to FFMpeg (to be the same as my normal rPi install) and the IP address to where my server is. I started BBC 1 and instantly the machine rebooted. This is similar what happening to your guys.

I then went back to the Mediaportal config page and changed a couple of settings.
Connection settings: Windows user account (SMB) & Windows password (SMB): I changed to the actual account user on the server PC.
Playback settings: I changed 'convert host name to ip' to false, and 'wait time for channel change' too 100mil.secs

I then rebooted the PI and tried again. TV started up and works fine.

If I get time later I will have a play and change the settings above to see if one or any have made it work. It may in my case simply be the reboot made it work. Most of the testing I did last night but this morning to make sure I unplugged the Pi, re-plugged it in and tried again. Still all working.
-----------------------------------
Front End: Asrock ION 3D running OpenElec - Backend: Dedicated server Running Ubuntu with TBS 6981 DVB-S2 USB
Reply
#28
My PI works great, it is Android and IOS that I am having this issue. I will try what you did with your PI with my iPad and my Galaxy Note 2 and see if that helps. Thanks.
TV Mosaic on Windows 10 as PVR Backend |  1 RaspberryPI 3 Client (LibreElec) | Amazon FireTV box | 5 Amazon FireTV sticks | FireTV Cube | 2 Nvidia Shield TV
Tuners: HD HomeRun 4 ATSC (OTA) | IPTV
Reply
#29
Awesome, setting the wait for channel change to 100 milliseconds fixed my problem for android and setting it to 200 fixed the problem for my iPad.

On my Android phone, I can use tsreader or ffmpeg. On the iPad, only ffmpeg.

My only problem now is my iPad 1 doesn't have horsepower to play the live tv stream. Is there any way to set it so that it is transcoded on the server for iPad playback?
TV Mosaic on Windows 10 as PVR Backend |  1 RaspberryPI 3 Client (LibreElec) | Amazon FireTV box | 5 Amazon FireTV sticks | FireTV Cube | 2 Nvidia Shield TV
Tuners: HD HomeRun 4 ATSC (OTA) | IPTV
Reply
#30
Same problem here on rasp pi with raspbmc newest addon, newest version plugin mp server, mp 1.3 final release server. Crash before picture all channels both sd and hd. Streaming tv from other plugin working so only some bug with live tv. Margro any idea?

EDIT 25/3-13
Got it working with RASPBMC nighly version 12.1 and also an older one from the start of march 5/3 I think the build date was. All other including openelec makes the PI reboot when trying to start Live TV

EDIT 30/3-13
Well because of problems I started trying other bulids, but XBMC restarts everytime I try to start LIVE TV. Tried different versions of RASPBMC and also different openelec versions including RBEJ build. What to do and anyone know how to fx it?
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC crash at activatig LiveTV0
This forum uses Lukasz Tkacz MyBB addons.